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1 Get started as a Tekla
Structures administrator

To get started as a Tekla Structures administrator, you should familiarize
yourself with the concepts related to installation, licensing and customization.

• Installation from the point of view of an organization's Tekla Structures
administrator is explained in Tekla Structures installation for administrators
(page 11).

• License administration tasks are explained in Manage licenses (page 31).

• You can customize Tekla Structures extensively and distribute the
customized configurations using various configuration files. Basic
customization tasks are explained in Tekla Structures setup guidelines for
administrators (page 116) and Environment, company and project settings
for administrators (page 129). See Files and folders in Tekla Structures
(page 224) for more detailed information on the file and folder structure.

1.1 Information sources for administrators
Tekla User Assistance

Tekla User Assistance provides help information for all levels of users,
including administrators. You can access the Tekla Structures help material in
Tekla User Assistance by pressing the F1 button in Tekla Structures. If you have
a dialog box open, Tekla Structures takes you straight to the related topic.

By default, all help content is online. Offline help installation packages are
available in Tekla Downloads. We recommend that you use the online help
when possible as it is updated constantly.

The help is also available when Tekla Structures is not running. Depending on
your Windows operating system, through the Start menu or Start screen,
select the Tekla Structures <version> and click Documentation.
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Release notes and Administrator's release notes

Release notes and Administrator's release notes are published in Tekla User
Assistance for each new main and intermediate version of Tekla Structures.
They contain very useful information that you can use when upgrading to a
newer version of Tekla Structures.

Release notes contains information about the new features, improvements
and fixes to existing features. Administrator's release notes contains useful
information on how to localize and start using the new features in Tekla
Structures.

Tekla Discussion Forum

Tekla Discussion Forum is a useful place to share experiences, ask questions,
and discuss with advanced users. You need a Trimble Identity to log in.

Tekla Structures training

To use Tekla Structures to its full potential we strongly recommend users to
attend training courses held by the local Trimble Solutions office or a reseller.

Your local support

If you have a valid maintenance contract, you can e-mail or phone your local
support for help.

You can find the email address and phone number of your local support in
Tekla User Assistance when you are logged in and your account is connected
to your organization's group.
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2 Tekla Structures installation for
administrators

You can install Tekla Structures on a workstation using the standard
installation packages or by creating your own centralized installation using MSI
packages. You can also run Tekla Structures in a Citrix virtual environment.

To use Tekla Structures, you also need to install a license server.

2.1 Installation requirements
Trimble Identity

Tekla Online services use Trimble Identity for identification. You can use your
Trimble Identity with other Trimble services, such as Trimble Connect and
SketchUp 3D Warehouse.

Each organization has at least one account administrator, who is responsible
for managing the organization group used in Tekla Online services. As an
administrator, you manage the people in your organization group so that they
can access the services they need. Several people in your organization can be
administrators. The first user is invited by a Trimble representative, and that
person is then responsible for adding other users and administrators as
necessary.

As an administrator, you are responsible for:

• Inviting employees to your organization's user group to include them in
your organization's maintenance contract and allow them access to the
following services:

• Tekla Model Sharing. You must also choose the individual users who are
allowed to use your organization's Tekla Model Sharing licenses and
keep track of license expiration date(s).

• Tekla discussion forum.

• Some additional content in Tekla User Assistance and Tekla Warehouse.
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• Removing people from your organization's user group when they no longer
belong to your organization.

For more information, see Trimble Identity for Tekla Online services and
Managing Trimble Identities and Tekla Model Sharing licenses.

Operating system and hardware recommendations

Tekla Structures can be installed on recent 64-bit Windows operating systems.

If the operating system is not one of the supported versions of Windows, the
installation is cancelled. The installation also requires that Microsoft .NET
Framework 4.5.1 or newer is installed on the computer. The installation
of .NET Framework 4.5.1 is included in the Tekla Structures installation
package, and it is executed if needed.

For more information on recommended operating system and hardware
specifications, see Tekla Structures 2018 Hardware Recommendations.

2.2 Installing Tekla Structures
You can download Tekla Structures software and environments from Tekla
Downloads. To have the latest software in use, we recommend that you install
the latest service pack of Tekla Structures. Service packs include improvements
and fixes to the latest or to a previous main version or service pack of Tekla
Structures. Service packs are available for all users with a valid maintenance
contract.

NOTE You need to install Tekla Structures with administrator rights.

When you use centralized installation to install Tekla Structures on the client
computers, the end users do not necessary need administrator rights.

Tekla Structures installation wizard has detailed instructions about the
installation. For more information, see also Install Tekla Structures.

2.3 Centralized installation of Tekla Structures
Installing Tekla Structures centrally across the company network saves time in
a large company when there are many Tekla Structures users.

Centralized installation allows you to run the Tekla Structures installation
silently in the background so that the users do not see the installation wizard
dialog boxes. For detailed information on centralized installation, see
Centralized distribution of Tekla Structures 2018.
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2.4 Installation in a virtual environment
You can also run Tekla Structures in a Citrix virtual environment. Application
and desktop virtualization allow users to run software from a Citrix server on
the network without locally-installed Tekla Structures on their workstation. For
detailed information on virtualized installation, see Using Tekla Structures with
application and desktop virtualization (page 25).

2.5 Installing the license server
FlexNet licensing system

Tekla Structures uses a licensing system called FlexNet Publisher License
Management (FlexNet), a system provided by Flexera Software. The FlexNet
licensing system is activation-based, which means that hardware locks or
passwords are not required. Instead, a floating license system is used where
the license is stored on a license server.

If you only use one license of Tekla Structures, you can install the license
server on the same computer as Tekla Structures, making the license available
on this one workstation. In an environment with multiple licenses and users,
you install the license server in your company network, which allows for more
flexible and efficient use of your licenses according to need.

When a user starts Tekla Structures, the program checks for an available
license from the license server and uses that license. When the user exits Tekla
Structures, the license becomes available for other users connected to the
same license server. For offline use, the user can borrow a license from the
server and then return it later.

To see which license server version to use with your current Tekla Structures
version , see Which license server version to use (page 44).

In an activation-based licensing system, the following tasks need to be
performed before users can start using Tekla Structures:

• Install and set up a license server on a computer.

• Save the entitlement certificate and activate the licenses.

• Connect each client computer with Tekla Structures to the license server.

NOTE Keep backup copies of your license entitlements in a safe place.

For more information, see Tekla Structures licensing system (page 31).

Operating system

The server that is used as the Tekla Structures license server does not have to
be very efficient or have maximum performance capability. However, it is
important to ensure that the server hardware is reliable, and to maintain the
server system carefully. See Tekla Structures 2018 Hardware
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Recommendations for information on operating systems and virtual machine
platforms.

For more detailed information on how to set up the license server, see
Installing Tekla Structures license server (page 43) and Checklist for the Tekla
Structures license server administrator (page 35).

Useful information on the FlexNet system can be found in the documents
provided with the installation and in Tekla Downloads. The following
introductions are available:

• FlexNet License Administration Guides by Flexera Software are general
guides that contain, for example, instructions on how to create user groups
and manage access rights:

• C:\TeklaStructures\License\Server\fnp_LicAdmin.pdf

• C:\TeklaStructures\License\Server\LicenseAdministration.pdf

Using multiple license servers in one company

You may want to spread your license pool on several servers in your company.
You may have offices in many cities, each office with its own license server, or
you may simply want to divide the license pool if there is server downtime.

For example, you can divide your total license entitlement on several servers
simply by activating one half of your licenses on one server and the other half
of the licenses on another server. This way, if there is a maintenance break on
one of the servers, you can advise your users to obtain the license from the
other server.
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You can also configure Tekla Structures to check licenses from several servers:

1. In Tekla Structures, open a model and click File --> Settings --> Change
license server.

2. In the Server address box, give the port@host addresses of the license
servers separated with a semicolon (; ).

3. Click OK.

The updates will take place the next time you start Tekla Structures.

NOTE Defining several license servers may slow down the starting of Tekla
Structures. Therefore, we do not recommend defining more than two
servers in the Connect to license server dialog box.

Monitor license usage

You can monitor the usage of Tekla Structures in your company based on the
licensing information. The tool for monitoring the license usage is called
LMTOOLS, and it is delivered with the Tekla Structures license server. The
license server statistics area on the Statistics tab displays information about
the license use. For more information, see Tekla Structures License
Administration Tool options and settings.

To view which licenses are currently in use, you need to have administrator
rights and take the following steps on your license server:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system. 

2. On the Utilities tab, define which license server you want to monitor.
Type tekla in the Vendor Name box and your license server port@host
definition in the Path box.

3. Click Override Path.

4. On the Server Status tab, click Perform Status Enquiry. You will now
receive a listing of how many licenses and which configurations are
activated on the server, and how many of the licenses are in use at the
moment of enquiry.
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The status enquiry functionality uses abbreviations of Tekla Structures
configurations. You can find the description of the abbreviations in your
entitlement certificate or in Tekla Structures License Administration Tool.

For a comprehensive description of the status enquiry syntax, see LMTOOLS
options and settings used in Tekla Structures licensing.

2.6 Tekla Structures multi-user server
Multi-user mode allows several users to access the same model
simultaneously. Multi-user mode is suitable for local teams with projects
where the team members work in the same location, and do not necessarily
have an Internet connection.

If your company takes part in external projects, or whenever more than one
user works with the same model at different locations, we recommend that
you use Tekla Model Sharing instead. With Tekla Model Sharing, the users in
your company can work with the same shared model, offline and with high
performance, and synchronize the changes with other team members even in
a low-speed network. Tekla Model Sharing requires a separate subscription.
You can view and manage your company's shared models with Management
Console for Tekla Model Sharing.

The multi-user model consists of a single master model. Each user can access
this model and open a local view of the model. The local view is called a
working model. Any changes a user makes to the working model are local and
not visible to other users until the working model is saved to the master
model. The multi-user system can contain several client computers, where
users work on their working models. The master model can be located
anywhere in the network, including any of the client computers.
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A Tekla Structures multi-user system runs in your organization's internal
network using standard TCP/IP networking and consists of:

• Tekla Structures multi-user server computer running xs_server.exe
(started by the AlwaysUp utility)

• A file server computer containing the master model

• Client computers running Tekla Structures

The image below shows one possible configuration of the multi-user system.

The multi-user server is a separate installation that is available in Tekla
Downloads.

For instructions on how to install the multi-user server and on how to run the
multi-user server as a service, see Multi-user system.

NOTE When more than one user is working within the same model in different
locations and at different times, use Tekla Model Sharing instead of the multi-
user mode.
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2.7 Installing .tsep packages
Tekla Structures extension packages, .tsep packages, are Tekla Structures
extensions or additional environment content installers. .tsep packages are
available for download in Tekla Warehouse.

You can install .tsep packages in three different ways.

Direct installation

1. Double-click the .tsep installer that you have downloaded.

2. The Tekla Structures extension manager dialog box opens with the
name of the extension that is going to be installed.

By default .tsep installers are opened with Tekla Structures extension
manager. Some .tsep installers are run directly from Tekla Warehouse
with the Insert into model option.

3. Select the Tekla Structures versions to which you want to import and click
the Import button. The next time you start Tekla Structures, the extension
is automatically installed, and it is shown in Tekla Structures extension
manager.

NOTE If the .tsep installer is not set to open with Tekla Structures
extension manager by default, you can set it manually. Right-click on
the .tsep installer and select Properties. In Opens with, select
Change and browse to TsepFileDispatcherLauncher.

Installation in Tekla Structures extension manager

You can also install a .tsep installer from Tekla Structures extension
manager in Tekla Structures.

1. In the Applications & components catalog, click  > Manage
extensions --> Extension manager to open Tekla Structures extension
manager.

2. Click Import and browse to the .tsep installer that you want to install.

3. Click Open.

The imported .tsep is installed the next time you start Tekla Structures. It
is shown in Tekla Structures extension manager, and is ready for use in
the Applications & components catalog.

Centralized installation

You can centrally install a batch of .tsep installers across company
workstations. This method is meant for system administrators.

By default, the .tsep installers waiting for installation are stored in
\ProgramData\Tekla Structures\<version>\Extensions\To be
installed. To install centrally, you need to copy the .tsep installers to the

Tekla Structures installation for administrators 18 Installing .tsep packages



%XSDATADIR%\Extensions\To be installed folder. Create the \To be
installed folder if it does not exist yet.

When Tekla Structures starts, it checks the available .tsep installers from the
\To be installed folder and installs them automatically. If there is an older
version of the same extension package, it is uninstalled before installing the
new version. Installation is cancelled if the same or newer version has already
been installed.

• The installed .tsep installers are stored in the %XSDATADIR%\Extensions
\Installed folder.

• Invalid .tsep installers are uninstalled and moved to the %XSDATADIR%
\Extensions\Invalid installations folder.

• Cancelled .tsep installers are stored in %XSDATADIR%\Extensions
\Cancelled installations.

Copying .tsep installers

We recommend that you use ROBOCOPY from the command prompt (cmd.exe)
to copy the .tsep installers. More information on ROBOCOPY can be found on
the Microsoft website, for example.

The basic syntax for ROBOCOPY is: robocopy <Source> <Destination>
[<File>[ ...]] [<Options>]
For example, to copy .tsep installers:

robocopy
"\\Server1\prod\TeklaStructures\2017\Environments_TSEP"
"C:\ProgramData\Tekla Structures\2017\Extensions\To be installed"
*.tsep

This command will take all .tsep installers from the \Server1 network
directory and copy them to the local user's \To be installed folder.

Centralized uninstallation

You can uninstall .tsep packages in batches by creating an empty file without
an extension, with the name RemoveExtensionOnStartup, in
\ProgramData\Tekla Structures\<version>\Extensions\Installed\
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[Extension_To_Be_Uninstalled]. The extensions are removed the next
time Tekla Structures is started.

2.8 Upgrading Tekla Structures
You can install service packs on top of the existing installation of Tekla
Structures. You can update to new service packs without updating the existing
licenses. A new Tekla Structures version installs as a separate instance and can
exist on the same workstation with other Tekla Structures versions. An update
to a new version requires that you also update your licenses, as the licenses
have a highest allowed version.

If you already have an older version of Tekla Structures installed on your
computer, you can use Migration Wizard to copy the personal settings to the
new version. With the Migration Wizard you can choose to copy any of the
following settings and values:

• user.ini file

• Registry values, such as:

• Toolbars

• Dialog boxes

• General options

When you customize Tekla Structures, for example, add or change drawing or
report templates and catalog entries, we strongly recommend that you create
project and firm folders for the customized files. This is useful if you want to
store the files for future use, or if you want to retain them when you install a
new release.

Tekla Structures does not replace files in the project and firm folders when you
install a new release. You can retain your customized files without having to
copy and paste, or export and import from the previous versions. This makes
upgrading faster and easier. If you have customized previous Tekla Structures
versions without using firm or project folders, you will need to transfer the
customized information to the next Tekla Structures version.

Before you start using a new Tekla Structures version, always test that the old
company settings work.

TIP If you want to copy the settings later, you can start Migration Wizard manually by
double-clicking the MigrationWizard.exe in the \Tekla Structures
\<version>\nt\bin\applications\Tekla\Migrations folder. You can
select the version from which the settings are copied and the version to which
the settings are copied.
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2.9 Folder structure
Folder structure on local computer

See Tekla Structures installation folders for information on how the folder
structure on the local computer is set up.

Company folder structure

We recommend using a central file folder for storing the models and setup
files for the company-specific settings and the project-specific settings. Tekla
Structures then reads the settings from the central file server. When upgrading
to a new Tekla Structures version, or updating the company logo, for example,
the files only need to be replaced in one place. This way taking backups and
upgrading is easier.

For more information, see Create project and firm folders (page 225).

Backup

As all valuable information and work your company stores, it is also important
to take backups of the model folders, and firm and project settings. If your
company has a system for taking automatic scheduled backups, schedule your
system to take the backups at night time, outside working hours to prevent
any possible conflicts in the model. Do not forget to also take a backup of the
license entitlements.

Virus protection

Virus protection software has sometimes caused problems in saving models
and drawings to the model folder. These problems may occur especially if you
have your model saved on a network drive. We strongly recommend that you
add Tekla Structures into the safe list of your antivirus system, and to set up
your virus protection in a way that actions in your model folder are not
blocked or scanned.

2.10 Create startup shortcuts with customized
initializations
You can use shortcuts to start teklastructures.exe with customized
initializations. You can use this functionality to create shortcuts for different
purposes, for example, to have customized setup files depending on the client
you are working for in a project. The Tekla Structures installation automatically
creates shortcuts for the selected environments.

NOTE We recommend that only administrators create the customization and the
necessary shortcuts. Otherwise, your settings may differ from the settings
defined for your firm, or for the particular project you are working for.

Tekla Structures installation for administrators 21 Create startup shortcuts with customized
initializations



Create a startup shortcut with customized initialization
1. Open the user.ini file using any standard text editor.

2. Save the file with a new name, for example, customer.ini or
project.ini.

3. Modify the file by adding the required settings.

4. Save the modified initialization file.

5. Open the Windows Start menu and select All Programs --> Tekla
Structures <version> .

6. Right-click Tekla Structures <version> and select Copy.

7. Paste the shortcut to your desktop.

8. Select the shortcut, right-click and select Properties.

9. Modify the Target of the shortcut by adding the required project
initialization information to it. 

First enter the path to the current teklastructures.exe, then the
desired parameters.

Use the quotation marks (") in the path to avoid possible problems if the
path contains spaces. If you have installed Tekla Structures to a path that
does not contain spaces, there will be no problems even if you remove
the quotations marks, for example, C:\TeklaStructures\. If you have
installed Tekla Structures to a path that contains spaces, the quotation
marks are needed, for example, C:\Program Files\Tekla
Structures\.
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The maximum length of a shortcut is 256 characters. If you have problems
with the length, you can call all other necessary initialization files from
your customized initialization file instead of adding them to the shortcut.

10. To override the settings defined in the shortcuts, use the parameter -i
<initialization_file> in the user.ini and option.ini files.

Available parameters in shortcuts
You can use the following parameters in shortcuts:

Parameter Description
-I <ini_file_path> The given .ini file is loaded before the

environment .ini files. This parameter can be
specified multiple times.

This parameter could be used to bypass the
Choose Setup dialog (the login dialog).

Example:

"C:\Program Files\Tekla 
Structures\2016\nt\bin
\TeklaStructures.exe" -I
"C:\ProgramData\Tekla Structures
\2016\Environments\usimp
\us_roles\engineering
\EngBypass.ini"

-i <ini_file_path> The given .ini file is loaded after the role .ini
files. This parameter can be specified multiple
times.

Example:
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Parameter Description
"C:\Program Files\Tekla 
Structures\2016\nt\bin
\TeklaStructures.exe" -i
"C:\TeklaStructures
\MySettings.ini"

<model_path> The given model is opened after startup.

Example:

 "C:\Program Files\Tekla 
Structures\2016\nt\bin
\TeklaStructures.exe"
"C:\TeklaStructuresModels\New 
Engineering model"

-m
<macro_file_path>

The given macro is executed during startup.

Example:

"C:\Program Files\Tekla 
Structures\2016\nt\bin
\TeklaStructures.exe" -m
"c:\ProgramData\Tekla Structures
\2016\Environments\usimp\macros
\modeling\Directory Browser.cs"

These parameters can be used in combination, and they automatically bypass
the Tekla Structures - Choose setup dialog box, open a model and run a
macro, for example.

"C:\Program Files\Tekla Structures\2016\nt\bin\TeklaStructures.exe" -I
"C:\ProgramData\Tekla Structures\2016\Environments\usimp\us_roles
\engineering\EngBypass.ini"
"D:\Models\_TS2016\New Engineering model" -m "c:\ProgramData\Tekla 
Structures\2016\Environments\usimp\macros\modeling\Directory Browser.cs"

Example of an initialization file
Below is an example of a customized project initialization file that calls other
initialization files.

MyProject.ini
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The project shortcut for this initialization file:

C:\Program Files\Tekla Structures\21.0\nt\bin
\TeklaStructures.exe -i \\MyServer\MyProject\MyProject.ini \
\MyServer\MyProject\MyModel\MyModel.db1

2.11 Using Tekla Structures with application and desktop
virtualization
Using Tekla Structures with the Citrix application and desktop virtualization is a
flexible and safe way to quickly add users to Tekla Structures projects without
locally installing Tekla Structures and copying project data to a user's
computer. Citrix application and desktop virtualization products are products
of Citrix Systems, Inc.

Using Tekla Structures from a centralized location ensures that all users in the
project are using the same project environment set-up. Streaming applications
from the server enables the use of Tekla Structures on client computers,
tablets and smartphones that have different hardware and software
configurations. The project data is protected as everything is stored only on
the server.

The key components for using Tekla Structures with the Citrix application and
desktop virtualization are:

• Windows server

• Virtualization solution, such as Citrix XenServer or VMware vSphere

• Citrix application virtualization or Citrix desktop virtualization solution
installed

• The server is typically set up by the company's IT department.

• User groups, in other words, delivery groups defined on the server

• Delivery groups are set up by the administrator of the virtualization
environment.

• Access rights for delivery groups defined on the server

• Access rights are set up by the administrator.

• Citrix Receiver installed on client computers

• The Citrix Receiver is typically delivered through an Internet browser.

• Tekla Structures installed on the server or on the virtual machine running
on the server

• High-end Windows server that can serve multiple concurrent users

• Fast access to project files

• Connection to Tekla Structures license server as each Tekla Structures user
needs a valid Tekla Structures license
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The image below shows the main concepts in Tekla Structures virtualization.

1 Desktop user
2 Tablet or smartphone user
3 Citrix thin client
4 Secure display data connection over the Internet
5 Tekla Structures instances running on a virtual machine
6 Virtual Windows server OS
7 Virtualization platform (hypervisor layer)
8 Server hardware
9 Data center hosted by the user organization, Trimble, Amazon, or by a

third party
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Prerequisites for using Tekla Structures in a virtual
environment
Citrix virtualization is set up either on a physical server or on a virtual server.
Users and user groups are added, and access rights are defined with Citrix
Studio for accessing computing resources on the server.

Recommended hardware is described in Tekla Structures 2017i Hardware
Recommendations.

For detailed instructions on installing and setting up XenApp and XenDesktop,
see the Citrix documentation.

The image below shows the main components in Tekla Structures
virtualization.

1 Citrix XenApp 7.6
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2 Thin client application: Citrix XenApp client or Citrix XenDesktop
desktop viewer

3 Tablet / Phone user
4 Desktop user
5 Multiple concurrent clients may share one virtual machine instance
6 Data center hosted by the user organization, Trimble, Amazon, or by a

third party
7 A graphics processing unit (GPU) can be dedicated for each virtual

machine instance with 0.5 GB to 2 GB of graphics memory, depending
on the usage.

8 High-end computer:

• Fast graphics card, NVIDIA GRID K520 or the newer NVIDIA Tesla
GPUs

• 8 GB to16 GB of main memory for each user, depending on the
usage

• Good CPUs, such as the latest generation of Intel Xeon E5 or E7
families

• Windows Server 2012 R2 OS
9 Local, enterprise or cloud Tekla Structures license server. Each

TeklaStructures.exe running on the virtual machine needs a valid
license.

10 Network bandwidth, 1 Mbps or more
11 Accessing files from the client's local file system may be very slow and

should be avoided.
12 Never use the local disk of the virtual server for saving model folders.
13 Citrix XenDesktop 7.6
14 VMware vSphere 6.0 hypervisor
15 File server
16 Normal Windows file system permission handling on the file server
17 Project data including environments should be stored on another

(server) machine in the data center or file system inside the company
network.

18 Desktop application: Tekla Structures
19 Virtual machine instance
20 Hypervisor
21 Windows server machine hosting the virtual machines
22 Network-attached storage (NAS)
23 Data center
24 Tekla Structures license server (on premises or hosted outside the data

center)
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25 Get license
26 Read/write project files. Fast disk access is needed.

Set up the virtual environment for Tekla Structures
You need to set up the server, define delivery groups, install the Tekla
Structures software and environments on the server, and Tekla Structures
users need to install the Citrix Receiver on their computers.

1. Set up the server. 

High-end computer with a fast graphics card, such as NVIDIA GRID K520
or the newer NVIDIA Tesla GPUs, for serving multiple concurrent users.
There needs to be enough main memory for each user depending on the
size and level of detail of the projects they are working on. The server
computer needs to have a good CPU and it should be running the
Windows Server 2012 R2 operating system.

For detailed instructions on installing and setting up XenApp and
XenDesktop, see the Citrix documentation.

2. Install Tekla Structures software and the needed environments on the
server. 

NOTE Storing models on the virtual computer local disk may cause
access problems. Use a dedicated file server for models, and
remember to select the correct network location for the model
folder during the Tekla Structures installation.

Tekla Structures environment settings are the same for all users
that use the same virtual computer. In the same manner as with
normal desktop installations, you still have to make sure that the
environments on different virtual machines are the same or
matching.

We strongly recommend that you use standard Tekla Structures
environments and amend them with company or project-specific settings
(on the network file server).

3. Install the Citrix Receiver on the Tekla Structures client computer: 

We recommend that you use the Citrix Receiver web user interface.

a. Open the Citrix Receiver web user interface in your web browser. 

Use the https address provided by your company's administrators.

b. Install the Citrix Receiver client software by following the steps in the
installation wizard. Do not create an account, or login in the
installation wizard, but finish the installation and return to the web
user interface.
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c. After the installation, return to the Citrix Receiver web user interface
and log in with the credentials provided by your company's
administrators.

d. Select the desired virtual desktop. If the virtual desktop does not start
automatically, run the downloaded Citrix (.ica) file.

You can now start using Tekla Structures on the virtual desktop, in the
same manner as if it was installed on your own computer.

• When you use the virtual desktop for the first time, you can give read
and write access to your local files in the file access dialog box.

• Note that referencing local files from your computer directly in Tekla
Structures is not recommended. If you need to access those files in
Tekla Structures, you should copy them to a shared network location
first.

• Note that model folders are not copied to the client computers.

The Citrix Receiver client is updated frequently. Always install the latest
client when the web user interface suggests you to do so.
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3 Manage licenses

To get started with license administration:

1. Make sure you understand how licensing works, see Tekla Structures
licensing system (page 31).

2. Install the license server as explained in Installing Tekla Structures license
server (page 43).

3. Make sure the license server can connect to Trimble's activation server
and clients can connect to the license server, see Allowing Tekla Structures
license server to operate through Windows Firewall (page 52).

4. Activate your licenses on the server as explained in Activating Tekla
Structures licenses (page 71).

5. Test that licensing works and connect the clients to the license server as
explained in Connect Tekla Structures to the license server (page 76).

Additionally, you can ensure that the correct types of licenses are available to
the users who most need them by defining access rights for using and
borrowing licenses as explained in Modify Tekla Structures license access
rights (tekla.opt) (page 77). This can prevent situations where there are no
licenses available for users that need them because someone else has
reserved or borrowed a license that they do not really need.

When you renew licenses and when you need to make hardware changes on
the license server, you must deactivate your licenses as explained in
Deactivating Tekla Structures licenses (page 82).

If your licenses have become untrusted or disabled, they cannot be used and
you need to repair them. For information about how to do this, see Repair a
Tekla Structures license (page 84).

See also

Troubleshoot Tekla Structures licensing (page 86)
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3.1 Tekla Structures licensing system
Tekla Structures uses FlexNet Publisher License Management version 11.13
(later on FlexNet) licensing system. FlexNet is a licensing system provided by
Flexera Software. The FlexNet licensing system is activation-based, and it
supports redundancy via a server list. In an activation-based licensing system
you need to activate your licenses to transfer the license rights from Trimble
Solutions to your license server.

Tekla Structures cannot be used without a valid license. To get an entitlement
certificate, you need to buy a license. If you have problems downloading and
installing a commercial version of Tekla Structures, please contact your local
Tekla office: http://www.tekla.com/contact/offices-and-resellers. There are no
trial licenses available.

Tekla Structures holds licenses in trusted storage. This means that Tekla
Structures does not support three-server redundancy, where licenses are held
in license files. However, you may have any number of license servers, and use
search paths for defining and finding them.

Key steps in an activation-based licensing system

In an activation-based licensing system the following tasks need to be
performed before users can start using Tekla Structures:

• Install and set up a license server on a computer: Installing Tekla Structures
license server (page 43)

• Save the entitlement certificate and activate the licenses: Activate Tekla
Structures licenses using automatic server notification (page 72)

• Connect each client computer with Tekla Structures to the license server:
Connect Tekla Structures to the license server (page 76)

Benefits from using activation-based licensing

The main benefits of the activation-based FlexNet licensing system:

• You do not need hardware locks or password files.

• You can update and renew licenses easily.

• You can create user groups with different access rights for different Tekla
Structures configurations.

• You have multiple options for managing licenses. You do not have to
activate all of the licenses on the same license server. You can activate
some of the licenses on a common server and the rest locally on each
user’s computer, for example. You can easily change the location of the
licenses by deactivating them on one license server and activating on
another.

• You can handle licenses efficiently. You can activate licenses on a license
server in a local area network. When you start Tekla Structures, a license is
checked out from the license server. When you close Tekla Structures, the
license is checked in and it is available for another user.
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• You can use Tekla Structures offline by borrowing licenses.

Prerequisites for using FlexNet

There are several issues the administrator needs to take into account before
starting with FlexNet licensing. Take a look at the following listings:

• Checklist of Trimble Solutions deliverables needed in Tekla Structures
licensing (page 33)

• Checklist of IT resources needed in Tekla Structures licensing (page 34)

• Checklist for the Tekla Structures license server administrator (page 35)

• Rights needed for performing administrator's tasks in Tekla Structures
licensing (page 35)

Tekla Campus users

The FlexNet licensing system is not used with Tekla Structures Learning
Edition, and FlexNet licensing instructions do not apply. For more information
about Tekla Structures Learning Edition, see https://campus.tekla.com/

Checklist of Trimble Solutions deliverables needed in Tekla
Structures licensing

To get started with the FlexNet licensing, the administrator needs to have the
following items provided by Trimble Solutions:

• Entitlement certificate

Trimble Solutions has sent the license entitlement certificate in an e-mail to
the person in your organization who has made the license purchase, or to
someone named as the contact person. The entitlement certificate lists all
the Tekla Structures licenses you are entitled to use and includes the
activation IDs for entitled licenses.

For entitlement requests, contact your local Tekla Structures
representative.

• Tekla Structures license server installation package

The Tekla Structures license server installation package is available on Tekla
Downloads product download service. The installation package contains
the license server files and Tekla Structures License Administration Tool.

• License Administration Guide

This guide by Flexera Software is a general guide that contains, for
example, instructions on how to create user groups and manage access
rights. This guide is provided in the license server installation package and
is installed in the folder where you install the license server in the .pdf
format.
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Checklist of IT resources needed in Tekla Structures
licensing

You need to take into account the following IT resource related requirements:

• Supported operating system

The FlexNet licensing system for Tekla Structures runs in Windows
operating system. The support for virtual servers is limited. For more
information, see Tekla Structures Hardware recommendations in Tekla
User Assistance.

• Windows user account with administrator rights

Your Windows login user name should not contain any special characters.

You need to have administrator rights to install and manage the license
server. For more information, see Rights needed for performing
administrator's tasks in Tekla Structures licensing (page 35).

• TCP/IP port 27007 for license server

Tekla Structures licensing service (lmgrd) is automatically run in the TCP/IP
port 27007. This port should be dedicated for Tekla Structures licensing
service only. If required, you can manually set a different TCP/IP port for
the licensing service, see Modify the license file tekla.lic manually
(page 49).

• Local area network

The license server and the client computers need to be in the same local
area network. The clients need to be able to contact the license server. If
there is no local area network in your company, we recommend that you
install the license server on each computer that has Tekla Structures and
activate one license on each computer.

• Internal firewall and direct communication

The internal firewall of your company (for example, Windows Firewall) must
allow the communication between the server computer and the computers
with Tekla Structures. You must allow the applications tekla.exe and
lmgrd.exe to operate through the firewall. For more information, see
Allowing Tekla Structures license server to operate through Windows
Firewall (page 52).

Direct communication from the server computer to the Internet needs to
be allowed when the license server at your company contacts the
activation server at Trimble Solutions. The activation communication uses
SOAP over HTTP on the TCP/IP port 80.

Your firewall should not block any incoming or outgoing information during
the activation. To allow the activation communication, use the activation
server address in your firewall settings:
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http://activate.tekla.com:80/flexnet/services/ActivationService?wsdl

If direct communication from the server computer to the Internet is not
allowed, contact your local Tekla Structures support for manual activation.

• System backup settings

If you have an automatic backup and restore system in your company,
configure your system so that it does not overwrite your actual Trusted
Storage with the backup copy. Trusted Storage is the place where the
licensing information is stored on the server computer, and it is located in
C:\ProgramData\FLEXnet depending on the operating system.

Checklist for the Tekla Structures license server
administrator

Your company or organization should assign an administrator for the license
server. The license server administrator's primary responsibilities are:

• Install the Tekla Structures license server: Installing Tekla Structures license
server (page 43)

• If automatic installation is not possible, manually install and configure Tekla
Structures license server: Install Tekla Structures license service - manual
installation (page 46), Configure Tekla Structures license server manually
(page 50), Modify the license file tekla.lic manually (page 49)

• Save the entitlement certificate on the license server computer and activate
licenses on the server to make the licenses available for Tekla Structures
users, or for yourself, if the license server is installed on your own
computer: Activate Tekla Structures licenses using automatic server
notification (page 72)

• Inform users of the license server name and port number so that they can
connect Tekla Structures to the server: Connect Tekla Structures to the
license server (page 76)

• If necessary, modify the firewall settings to allow licensing traffic: Allowing
Tekla Structures license server to operate through Windows Firewall
(page 52)

• If necessary, modify license access rights in the tekla.opt options file:
Modify Tekla Structures license access rights (tekla.opt) (page 77)

• Export a customized product ID files for license borrowing and deliver them
to offline users: Provide offline users with a customized product ID file
(page 111)

• Inform users of the license policy of the company and monitor license use.
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Rights needed for performing administrator's tasks in Tekla
Structures licensing

You need to have Windows administrator rights to install and manage the
license server. Some applications also need to be run as administrator
separately. This depends on the Windows version you are using.

• In Windows 7, Windows 8/8.1 and Windows 10, you need to log in as
administrator. In some cases, you need to run applications as
administrator. To do this, go to the folder containing the application, right-
click the application and select Run as administrator from the pop-up
menu.

• In Windows Server you need to log in as administrator. In some cases, you
need to run applications with unrestricted rights. To do this, right-click the
application, select Run as, and clear the Run this program with restricted
access check box.

Distributing and managing Tekla Structures licenses
The FlexNet licensing system offers several options for distributing licenses to
users. The way you distribute the licenses depends on the size of the company
or organization, and the amount of Tekla Structures users.

There are two basic ways of distributing licenses to users:

• The licenses are available for multiple users on a common license server.

• The licenses are activated on each user’s own computer.

You can also use a combination of license distribution methods. For example,
you can activate one license on a separate computer and activate the rest of
your licenses on a common license server.

The following table shows what is typical for managing the licenses that are
activated separately on each computer, and for licenses that are activated on a
common license server.

Licenses are activated on user's
own computer

Licenses are activated on a
common license server

No need for an assigned license
server administrator.

Each user manages the license server
that is installed on the user's own
computer.

Centralized maintaining and
administration of licenses is needed.

A license server administrator
maintains the license server and
manages the license use.

Typically, there are a few Tekla
Structures main users in a company.
The main users are good candidates
for license server administrators,
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Licenses are activated on user's
own computer

Licenses are activated on a
common license server

because they are already familiar with
Tekla Structures. For more
information on the responsibilities of
the license server administrator, see
Checklist for the Tekla Structures
license server administrator (page 35)

No need to manage license access
rights.

Each user activates only the licenses
that are needed.

By default, all license configurations
activated on the server are available
for all Tekla Structures users.
However, centralized access rights
management is possible.

The license server administrator can
give different users access to different
configurations. The license server
administrator needs to modify the
tekla.opt options file to manage
the license access rights. For more
information on managing license
access rights, see Modify Tekla
Structures license access rights
(tekla.opt) (page 77).

Tekla Structures can be used out of
office.

If the user's license is activated on a
computer, license borrowing or a VPN
connection is not needed.

Tekla Structures can be used out of
office.

A user needs to borrow a license from
the common license server or use a
VPN connection to the license server
to use Tekla Structures out of office.

Licenses are used only by one person.

Users have access only to the licenses
that are activated on their own
computer. If a user needs a license
that is activated on another
computer, the user needs to use the
other computer. Another option is to
deactivate licenses on one computer
and activate them on another, which
requires effort.

Licenses are checked out frequently
by several users.

When the licenses are activated on a
common server, they are available for
multiple users. The licenses are
checked out from the license server
only when they are needed. When a
user does not need a license, the user
closes Tekla Structures and the
license becomes available for another
user. Switching from using one
license to another is simple.

 Rules of license usage

Tekla Structures users should accept
common rules or an internal
company policy. The rules should
contain regulations of managing the
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Licenses are activated on user's
own computer

Licenses are activated on a
common license server

licenses, for example, who is allowed
to borrow licenses. Usage of common
rules minimizes the amount of
conflicts in license management.

Examples of different Tekla Structures licensing system
setups

The purpose of the following examples is to provide guidelines for license
management in companies or organizations of different sizes.

Example 1: One Tekla Structures user, all licenses activated on one
computer

Only one user in the company uses Tekla Structures. The user installs Tekla
Structures and the license server on the same computer.

• Installing the license server is straightforward, and the default license
server settings can be used. The user does not need to modify the license
server settings, because the user runs the license server and Tekla
Structures on the same computer.

• Because the user installs the license server on a computer, the user does
not need to borrow a license or use a VPN connection to use Tekla
Structures out of office.
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Example 2: Three Tekla Structures users, necessary licenses activated
separately on each computer

There are three Tekla Structures users in a company. Because the users use
different Tekla Structures configurations, each user installs a license server
separately on the user's own computer and activates only the needed licenses.

• A license server administrator is not needed, the users maintain their
license servers.

• Because the users install the license servers on their computers, they do
not need to borrow a license or use a VPN connection to use Tekla
Structures out of office.
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Example 3: Ten Tekla Structures users, necessary licenses activated on a
common license server and one user's computer

There are ten Tekla Structures users in a compan

y.
Because the users use different configurations, the company uses a common
license server.

• The company has an internal policy for license use containing regulations
for managing the licenses.

• One of the main users is assigned as the license server administrator. The
administrator installs the license server and informs the other users of the
hostname and port number of the server. The license server administrator
also performs other server maintenance duties.

• One of the users travels a lot and needs Tekla Structures on the journeys. A
license server is installed separately on the user’s computer, so the user
does not need to borrow a license or use a VPN connection for offline use
of Tekla Structures.

• Other users borrow licenses from the license server when they need to use
Tekla Structures offline.
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Example 4: Fifty Tekla Structures users in two offices, necessary licenses
activated on two separate servers

There are fifty Tekla Structures users in two separate offices. Both offices have
their own license servers.

• Both offices have assigned license server administrators. The license server
administrators install the license servers and perform license server
maintenance duties.

• The company has an internal policy for using licenses. The policy contains,
for example, the rules that define who is allowed to borrow licenses.

• Because the amount of Tekla Structures users is large, the license server
administrators create tekla.opt options files for controlling the access
rights for different licenses.

• Only a couple of users need to use Tekla Structures offline. The license
server administrators modify the option files to enable the license
borrowing only for those users who need to borrow licenses.

• If one server fails, the users can connect to the license server at the other
office. If there are licenses available on the license server, the users can use
the licenses.
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3.2 Installing Tekla Structures license server
The Tekla Structures license server installation package contains license server
files, applications for license management and guides. To install the license
server software, download the license server installation package with the
latest updates from Tekla Downloads product download service.

You have two choices in installation:

• Automatic default installation: Select automatic installation for normal
setup. Automatic installation is recommended.

For detailed installation instructions, see Install Tekla Structures license
server - automatic installation (page 45).
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• Manual installation: Use manual installation if you need to separately
install the license server, modify the license file, configure the license
service, and start the server software. This is needed if you want to use
another TCP/IP port than the one used in the automatic installation, for
example. Use manual installation only if you are an advanced user of
FlexNet or FlexIm licensing.

For detailed installation instructions, see Install Tekla Structures license
service - manual installation (page 46).

Before installing Tekla Structures license server

• Install the license server using administrator's rights.

• Turn off the internal firewall and pause the antispyware/antivirus
protection.

• Ensure that you have access to the Internet. The Internet connection is
needed during the license activation process. An unreliable connection
speed may cause errors.

• If you are using other FlexNet licensing services, you need to stop them
before you install the Tekla Structures license server. When you have
completed installing the Tekla Structures license server, you can restart the
other licensing services.

See also

Problems in Tekla Structures license server installation and connecting to the
license server (page 87)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Activating Tekla Structures licenses (page 71)

Allowing Tekla Structures license server to operate through Windows Firewall
(page 52)

Which license server version to use

Check the table below to see which license server version to use with your
current Tekla Structures version. Also check if you need to upgrade to a new
service pack or progress release.

Tekla Structures
version

License Server 2016
SP1

License Server 2017

2018  

2017i - all versions  

2017 - all versions
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Tekla Structures
version

License Server 2016
SP1

License Server 2017

2016i - all versions

2016 SP5/PR5 or later

2016 up to SP4/PR4 Upgrade to 2016
SP5/PR5 or later

21.1 SR7 or later

21.1 up to SR6 Upgrade to 21.1 SR7 or
later

21.1 all PV versions

21.0 or earlier

For instructions on how to install the license server, see Install Tekla Structures
license server.

Install Tekla Structures license server - automatic
installation

Before you start license server installation, stop FlexNet licensing services and
other licensing services.

For more information about which license server version to use, see Which
license server version to use (page 44).

To install the default setup of the Tekla Structures license server to a computer
that does not have a previous version of Tekla Structures license server
installed:

1. Download the license server installation package with the latest updates
from Tekla Downloads product download service.

2. Select the installation language.

3. Select Automatic as the licensing service installation type to install the
default setup.

4. Select the folder where you want to install the license server and complete
the installation.

Tekla Structures license server is installed.

In automatic license server installation, the license server address is
automatically set to 27007@your_hostname, where 27007 is the port and
your_hostname is the computer name/hostname. 27007@your_hostname is
used as the license server address in every Tekla Structures installation.

When you have installed the license server, you need to do the following:
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• Save the entitlement certificate and activate the licenses. For more
information, see Activate Tekla Structures licenses using automatic server
notification (page 72).

• Connect Tekla Structures to the license server. For more information, see
Connect Tekla Structures to the license server (page 76).

• You can also change the language of the user interface in Tekla Structures
License Administration Tool by opening the tool and clicking Language.

See also

Install Tekla Structures license service - manual installation (page 46)

Problems in Tekla Structures license server installation and connecting to the
license server (page 87)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Install Tekla Structures license service - manual installation
Use manual installation if you want to separately install the license server,
modify the license file, configure the license server, and start the license server
software. In manual installation of Tekla Structures license server, you also
install two files: installanchorservice.exe and
uninstallanchorservice.exe. You need these files when you manually
install or uninstall FlexNet Licensing Service.

For example, you need to install the license server manually if the default
TCP/IP port 27007 is already in use by other services or applications, and you
need to define another port in the license file tekla.lic.

Before you start license server installation, stop other FlexNet licensing
services.

To install the license server manually:

1. Download the license server installation package with the latest updates
from Tekla Downloads product download service.

2. Select the installation language.

3. Select Manual as the licensing server installation type and complete the
installation.

4. Go to the Start menu or Start screen (depending on your Windows
operating system) and open Command Prompt as administrator.

5. At the command prompt, enter the following commands:

a. cd /d %SYSTEMDRIVE%\TeklaStructures\License\Server
b. installanchorservice.exe 
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The licensing server is installed.

6. Modify the license file to include the hostname or IP address of the server,
and the correct TCP/IP port:

a. Open the ..\TeklaStructures\License\Server folder on the
server computer.

b. Open the tekla.lic (license file) file with a text editor.

c. Replace text localhost on the line SERVER localhost ANY with
the hostname (computer name) or IP address of the license server.

d. Enter the TCP/IP port number after text SERVER server_hostname
ANY.

e. Save the changes and close the text editor.

7. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

8. On the Service/License File tab, click Configuration using Services.

9. On the Config Services tab to configure the licensing service:

a. In the Service Name box, enter the name of the service exactly as
follows: Tekla Structures Licensing Service.

b. Click the Browse buttons to locate the lmgrd.exe (license server
manager), tekla.lic and tekla_debug.log files. 

By default, lmgrd.exe, tekla.lic and tekla_debug.log are
located in the C:\TeklaStructures\License\Server folder.

Note that if you set Path to the debug log file outside the "C:
\ProgramData\..." folder, you get an error message: "Windows
preferred path <SystemDrive>\ProgramData to store service data is
not set." This error message can be ignored.

c. Select the Use Services check box to run the licensing service as a
Windows service.

d. Select the Start Server at Power Up check box to start the licensing
service automatically after Windows startup.

e. Select the Trusted Storage in Use check box. This should always be
selected for Tekla Structures Licensing Service.
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f. Click Save Service to save the settings. 

10. Go to the Start/Stop/Reread tab and click Start Server to start the
license server. 

11. Go to the Server Status tab and click Perform Status Enquiry. 

In the status list, the line License server status shows the TCP/IP
port and hostname of the license server.

Now you can activate the licenses and connect Tekla Structures to the
license server.

You can also change the language of the user interface in Tekla
Structures License Administration Tool by opening the tool and clicking
Language.
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See also

Modify the license file tekla.lic manually (page 49)

Activate Tekla Structures licenses using automatic server notification
(page 72)

Configure Tekla Structures license server manually (page 50)

Problems using LMTOOLS in Tekla Structures licensing (page 97)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Modify the license file tekla.lic manually

If you selected the Automatic installation option, the license server is set to
your hostname: 27007@server_hostname (port@hostname).

The licensing system automatically searches for an available TCP/IP port and
uses the first available port detected. The Automatic installation sets the port
to 27007.

You need to modify the tekla.lic license file if you:

• Select the Manual license server installation option

• Want to change the TCP/IP port of the licensing server

• Want to use the IP address of your computer instead of the hostname

To modify the license file tekla.lic manually:

1. Go to the ..\TeklaStructures\License\Server folder on the server
computer.

2. Open the tekla.lic file in a text editor.

3. Make the necessary changes: 

• To use hostname or IP address: Replace text on the first line between
words SERVER and ANY with the hostname or IP address of your
license server.

Do not delete texts SERVER and ANY when you enter the hostname or
IP address of the license server.

The following formats are valid:

Hostname:server_hostname
Domain name: server_hostname.mycompany.com
IP address: 10.0.0.12
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You can check the hostname of the license server in LMTOOLS on the
System Settings tab. Go to Tekla Structures Licensing --> LMTOOLS
through the Start menu or Start screen, depending on your Windows
operating system.

• To set the TCP/IP port manually: Enter the TCP/IP port number after
text SERVER server_hostname ANY.

The port number can be any free port in the range of 0 - 64000.

4. Save the changes and close the text editor.

5. Restart the Tekla Structures Licensing Service in LMTOOLS or Windows
Services for the changes to take effect.

See also

Install Tekla Structures license service - manual installation (page 46)
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Configure Tekla Structures license server manually
If you encounter problems during the Tekla Structures license server
installation, the license server may not start automatically. If this happens, you
need to configure the license server manually using LMTOOLS.

To configure the Tekla Structures license server manually:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system. Start
LMTOOLS with administrators rights.

2. Go to the Service/License File tab and select Configuration using
Services.

3. Go to the Config Services tab and do the following: 

Service Name: Select the licensing service. When working with Tekla
Structures license server, always select Tekla Structures Licensing
Service.

Path to the lmgrd.exe: Click Browse and locate lmgrd.exe. This file is by
default located in the C:\TeklaStructures\License\Server folder.

Path to the license exe: Click Browse and locate tekla.lic. This file is
by default located in the C:\TeklaStructures\License\Server
folder.

Path to the debug log file: Click Browse and locate tekla_debug.log.

This file is by default located in the C:\TeklaStructures\License
\Server folder.

To append the logging entries in the debug log file, start the debug log file
name path with the plus sign (+), like by default for tekla_debug.log. If
the plus sign is missing, the log file will be rewritten each time the service
is started.

Note that if you set Path to the debug log file outside the "C:
\ProgramData\..." folder, you get an error message: "Windows
preferred path <SystemDrive>\ProgramData to store service data is not
set." This error message can be ignored.

Use Services: Select the check box to run the licensing service as a
Windows service.

Start Server at Power Up: Select the check box to start the licensing
service automatically after Windows startup.

Trusted Service in Use: Always select this check box for Tekla Structures
Licensing Service.

4. Click the Save Service button to save the settings.

5. Go to the Utilities tab and do the following: 
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Vendor Name: Enter tekla (all letters lowercase).

Path: Enter the name of the license server.

• If you run the license server and Tekla Structures on the same
computer, enter @localhost. You can also enter the TCP/IP port, for
example, 27007@localhost.

• If you run the license server and Tekla Structures on separate
computers, enter the hostname of the license server, for example,
@server_hostname.

• You can also enter the TCP/IP port of the license server, for example,
27007@server_hostname. You must define the port if you use
another port than the default port.

• You can also enter several license servers. Separate the server names
with a semicolon. For example, 27007@server_hostname;
27007@localhost.

6. Click the Override Path button to replace the existing license servers
displayed in the status list on the Server Status tab.

7. Go to the Start/Stop/Reread tab and start the license server by clicking
Start Server. 

The status bar should display a message telling that server start was
successful.

8. Go to the Server Status tab and enquire the license server status by
clicking Perform Status Enquiry.

The status list displayes the TCP/IP port and hostname of the license server.
The list should indicate that license server is up and vendor daemon tekla is
up. The list also displays all the activated licenses on the server.

See also

Installing Tekla Structures license server (page 43)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)
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3.3 Allowing Tekla Structures license server to operate
through Windows Firewall
When you set up Tekla Structures license server in your network, you may also
need to configure the firewall and antivirus settings:

• You need to allow the applications tekla.exe and lmgrd.exe to operate
through the firewall on the license servers and on the client computers.

• The internal firewall at your company must allow the communication
between the license server computer and the computers with Tekla
Structures.

• In addition to allowing the exceptions in your actual firewall, you may need
to configure exceptions for Windows Firewall. Windows Firewall may be set
on without you being aware of it, because some Windows updates may
automatically turn on the Windows Firewall.

For instructions on how to modify the firewall settings so that the Windows
Firewall on the license server allows Tekla Structures licensing traffic, see:

• Allow exceptions in firewall for lmgrd.exe and tekla.exe: Windows Server
2008 (page 53)

• Allow exceptions in firewall for lmgrd.exe and tekla.exe: Windows 7, 8, 8.1,
10 and Windows Server 2012 (page 56)

• Allow traffic in fixed TCP/IP ports: Windows Server 2008 (page 57)

• Allow traffic in fixed TCP/IP ports: Windows 7, 8, 8.1, 10 and Windows
Server 2012 (page 62)

In addition to Windows Firewall, the information given also applies to firewalls
from other vendors.

Allow exceptions in firewall for lmgrd.exe and tekla.exe:
Windows Server 2008
You need to allow the applications tekla.exe and lmgrd.exe to operate
through the firewall on the license server computer to enable licensing traffic.
The instructions apply to Windows Server 2008.

To allow exceptions for lmgrd.exe and tekla.exe:

1. On your server computer, go to Start --> Control Panel --> Windows
Firewall .

2. Click Allow a program through Windows Firewall in the left pane.

3. On the General tab, make sure that you have not selected the Don’t
allow exceptions or Block all incoming connections, depending on your
Windows operating system. 

If you have selected the check box, the modifications do not take effect.
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4. On the Exceptions tab, click Add program to open the Add a Program
dialog box. 

5. In the Add a Program dialog box, click Browse and browse for the Server
folder. 

By default, the path is ...\TeklaStructures\License\Server.

6. In the Server folder, select lmgrd.exe. 

Manage licenses 54 Allowing Tekla Structures license server to
operate through Windows Firewall



7. Click Open to add lmgrd.exe to the program list in the Add a Program
dialog box.

8. In the Add a Program dialog box, ensure that lmgrd.exe is selected, and
click OK. 

The lmgrd.exe application is added to the list of exceptions.
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9. To allow the exceptions also for tekla.exe, repeat the steps 3 – 7.

10. Click OK to confirm the changes.

Allow exceptions in firewall for lmgrd.exe and tekla.exe:
Windows 7, 8, 8.1, 10 and Windows Server 2012
You need to allow the applications tekla.exe and lmgrd.exe to operate
through the firewall on the license server computer to enable licensing traffic.
The instructions below apply to Windows 7, 8, 8.1, 10 and Windows Server
2012.

To allow exceptions for lmgrd.exe and tekla.exe on the license server
computer:

1. Press the Windows logo key + R on your keyboard to show the Run
dialog box, then type firewall.cpl and press Enter.

2. In the left pane, click Allow a program or feature through Windows
Firewall or Allow an app or feature through Windows Firewall
(depending on the operating system).
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3. In Allowed programs or Allowed apps (depending on the operating
system), click Change settings. 

Administrator permission is required. If you're prompted for an
administrator password or confirmation, enter the password or confirm.

4. Click Allow another program or Allow another app (depending on the
operating system).

5. Click Browse to browse for the \Server folder on the computer, select
lmgrd.exe and click Open. 

By default, the path is ...\TeklaStructures\License\Server.

6. Click Add to add lmgrd.exe to the Allowed programs or Allowed apps
and features list (depending on the operating system).

7. Select both Home/Work (Private) or Private (depending on the
operating system) and Public check boxes next to lmgrd.exe.

8. Allow the exceptions also for tekla.exe by repeating the steps 4 – 7.

9. Click OK to confirm the changes.

See also

Allowing Tekla Structures license server to operate through Windows Firewall
(page 52)

Allow traffic in fixed TCP/IP ports: Windows Server 2008
You need to modify the firewall settings to allow traffic through fixed TCP/IP
port. The following instructions apply to Windows Server 2008.

To allow traffic in fixed TCP/IP ports in Windows Server 2008 on the license
server computer:

1. Ensure that no other software or service is using the ports that you are
about to set fixed. 

Use the command line command netstat -anp TCP to find out which
ports are in use.

The numbers in the Local Address column after the colon (:) are the port
numbers that are in use.
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2. Browse for tekla.lic, and open it using a text editor. 

By default, the path is ..\TeklaStructures\License\Server.

3. To set a fixed port for lmgrd.exe, enter the TCP/IP port number at the
end of the SERVER row. 

The Automatic installation option sets the port to 27007.

4. Enter the text port=free_port at the end of the VENDOR row, for
example, port=1234. 

Defining the TCP/IP port number on the VENDOR row may slow down the
restart time of Tekla Structures Licensing Service.

5. Save the changes and close tekla.lic.

6. Update your license server with the changes:

a. Go to Tekla Structures Licensing --> LMTOOLS through the Start
menu or Start screen, depending on your Windows operating
system.
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b. Go to the Service/License File tab and ensure that Configuration
using services and Tekla Structures Licensing Service are selected. 

c. Go to the Start/Stop/Reread tab and stop the license server by
clicking Stop Server, and then start the server again by clicking Start
Server.

7. Click Start --> Control Panel --> Windows Firewall .

8. Click Allow a program through Windows Firewall in the left pane.

9. On the General tab, make sure that you have not selected the Don’t
allow exceptions or Block all incoming connections check box,
depending on your Windows operating system . 

If you have selected the check box, the modifications do not take effect.

10. On the Exceptions tab, click Add Port. 
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11. In the Add a Port dialog box: 

• In the Name box, enter lmgrd.

• In the Port box, enter the TCP/IP port number that you set in step 3.

12. Click OK to confirm the changes. 

lmgrd is added to the list of exceptions.

13. On the Exceptions tab, click again Add Port to open the Add a Port
dialog box.

14. In the Add a Port dialog box: 
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• In the Name box, enter tekla.

• In the Port box, enter the TCP/IP port number that you set in step 4.

15. Click OK to confirm the changes. 

tekla is added to the list of exceptions.

16. Click OK to confirm the modifications. 
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See also

Allowing Tekla Structures license server to operate through Windows Firewall
(page 52)

Allow traffic in fixed TCP/IP ports: Windows 7, 8, 8.1, 10 and
Windows Server 2012
You need to modify the firewall settings to allow traffic through fixed TCP/IP
port. The following instructions apply to Windows 7, 8, 8.1, 10 and Windows
Server 2012.

To allow traffic in fixed TCP/IP ports in Windows 7, 8, 8.1, 10 and Windows
Server 2012 on the license server computer:

1. Ensure that no other software or service is using the ports that you are
about to set fixed. 

Use the command line command netstat -anp TCP to find out which
ports are in use.

The numbers in the Local Address column after the colon (:) are the port
numbers that are in use.

2. Browse for tekla.lic, and open it using a text editor. 

By default, the path is ..\TeklaStructures\License\Server.

3. To set a fixed port for lmgrd.exe, enter the TCP/IP port number at the
end of the SERVER row. 

The Automatic installation option sets the port to 27007.
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4. Enter the text port=free_port at the end of the VENDOR row, for
example, port=1234. 

Defining the TCP/IP port number on the VENDOR row may slow down the
restart time of Tekla Structures Licensing Service.

5. Save the changes and close tekla.lic.

6. Update your license server with the changes:

a. Go to Tekla Structures Licensing --> LMTOOLS through the Start
menu or Start screen, depending on your Windows operating
system.

b. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected. 
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c. Go to the Start/Stop/Reread tab and click Stop Server to stop the
license server, and then start the server again by clicking Start
Server.

7. Click the Windows logo key on your keyboard to show the Start menu or
Start screen, depending on the operating system.

8. Type wf.msc and press Enter. The Windows Firewall with Advance
Security MMS snap-in is displayed.

9. In the navigation tree, select Inbound Rule, and then in the Actions pane,
click New Rule. 
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10. On the Rule type panel, select Port and then click Next. 
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11. On the Protocol and Ports panel, select TCP, enter the TCP/IP port
numbers that you set in steps 3 and 4 in Specific local ports, and then
click Next. 
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12. On the Action panel, select Allow the connection, and then click Next.

13. On the Profile panel, select the appropriate profiles, and then click Next. 
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14. On the Name panel, enter the name of the rule, and then click Finish. 
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The rule is created and automatically enabled.
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Tekla Structures

Allow exceptions in firewall for lmgrd.exe and tekla.exe: Windows 7, 8, 8.1, 10
and Windows Server 2012 (page 56)

Allowing Tekla Structures license server to operate through Windows Firewall
(page 52)

3.4 Activating Tekla Structures licenses
You need to activate the licenses on the license server to be able to use them.
When you activate the licenses, your license server contacts the activation
server at Trimble Solutions, and the license rights are transferred to the license
server at your company or, in the case of a single user, to your computer.
Tekla Structures License Administration Tool is the application used for
activating licenses. To be able to activate the licenses, you need an entitlement
certificate.

Consider the following when you are activating licenses:

• If the license server is installed on the same computer as Tekla Structures,
the user activates the licenses.
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• If the license server is installed on a separate server computer, the
administrator activates the licenses, grants the users the rights to use the
activated licenses, and provides the users all the required information.

• You do not need to activate all the licences at once. You can activate part of
the licenses now and part of the licenses later on some other computer, for
example. Different configurations and different versions need to be
selected for activation separately.

• Internet access is required in license activation because the license server
at your company needs to contact the activation server at Trimble
Solutions.

• You need to decide whether you want to notify the license server of license
changes manually or automatically. Do not use automatic notification if you
are using some other FlexNet license and license server administration
tool, such as FlexNet Manager.

Entitlement certificate EntitlementCertificate.html
• You need to save the Tekla Structures license entitlement certificate, which

is sent in an e-mail to the person in your organization who has made the
license purchase, or to someone named as the contact person. The
entitlement certificate states the configurations, quantities and activation
IDs of the Tekla Structures licenses you are entitled to use. The activation ID
enables the transfer of license rights. Before activating any licenses, you
need to download the entitlement certificate file
EntitlementCertificate.html from your e-mail to the ..
\TeklaStructures\License\Server folder. After that you can open the
entitlement certificate with Tekla Structures License Administration Tool
and activate your licenses.

See also

Activate Tekla Structures licenses using automatic server notification
(page 72)

Activate Tekla Structures licensing using manual server notification (page 74)

Problems in Tekla Structures license activation (page 90)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Activate Tekla Structures licenses using automatic server
notification
You can activate Tekla Structures licenses in Tekla Structures License
Administration Tool. In activation, the license server at your company
contacts the activation server at Trimble Solutions using an Internet
connection. Before the activation can be done, the entitlement certificate
needs to be opened. You can notify the license server automatically or
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manually about license changes, but the automatic server notification is
recommended.

NOTE Do not use automatic notification if you are using some other FlexNet
license and license server administration tool, such as FlexNet
Manager. To notify the license server about license changes manually,
see Activate Tekla Structures licensing using manual server notification
(page 74).

To activate the licenses and notify the license server automatically:

1. Go to Tekla Structures Licensing --> Tekla Structures License
Administration Tool through the Start menu or Start screen, depending
on your Windows operating system.

2. If not already enabled, enable the automatic license server notification
functionality by clicking the Notify Server button.

3. Open the license entitlement certificate located in the ..
\TeklaStructures\License\Server folder by clicking Open,
navigating to ..\TeklaStructures\License\Server, selecting
EntitlementCertificate.html, and clicking Open again. The license
information is displayed in the Entitled Licenses area.

4. Click the Activate cell and select the number of licenses to activate. 

5. Click the Activate button. 

Your license server contacts the license activation server at Trimble
Solutions.

• The activated licenses are displayed in the Activated Licenses area.

• Do not forget to take a backup copy of the trusted storage of the activated
licenses.

• When you open Tekla Structures License Administration Tool later on, it
detects expired and broken licenses you may have and asks if you want to
deactivate or repair them. If you select Yes, an automatic deactivation or
repair is run.
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Useful links

For more information about the status of the activated licenses in the trusted
storage and manual license activation, the following Support Articles in Tekla
User Assistance:

How to list the activated licenses using command lines

Checking the status of the activated licenses in the trusted storage

Checking the status of the activated licenses in the trusted storage (including
borrowing info)

How to activate licenses using command lines - Manual Activation

See also

Activating Tekla Structures licenses (page 71)

Problems in Tekla Structures license activation (page 90)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Activate Tekla Structures licensing using manual server
notification
You can activate Tekla Structures licenses in Tekla Structures License
Administration Tool. In activation, the license server at your company
contacts the activation server at Trimble Solutions using an Internet
connection. You can notify the license server manually of license changes.
Before the activation can be done, the entitlement certificate needs to be
opened.

NOTE Do not use automatic notification if you are using some other FlexNet
license and license server administration tool, such as FlexNet
Manager.

To activate the licenses and notify the server manually:

1. Go to Tekla Structures Licensing --> Tekla Structures License
Administration Tool through the Start menu or Start screen, depending
on your Windows operating system.

2. Open the license entitlement certificate located in the ..
\TeklaStructures\License\Server folder by clicking Open,
navigating to ..\TeklaStructures\License\Server, selecting
EntitlementCertificate.html, and clicking Open again. The license
information is displayed in the Entitled Licenses area.

Manage licenses 74 Activating Tekla Structures licenses

https://teklastructures.support.tekla.com/en/support-articles/how-list-activated-licenses-using-command-lines
http://teklastructures.support.tekla.com/en/support-articles/checking-status-activated-licenses-trusted-storage
http://teklastructures.support.tekla.com/en/support-articles/checking-status-activated-licenses-trusted-storage-including-borrowing-info
http://teklastructures.support.tekla.com/en/support-articles/checking-status-activated-licenses-trusted-storage-including-borrowing-info
https://teklastructures.support.tekla.com/en/support-articles/how-activate-licenses-using-command-lines-–-manual-activation


3. Click the Activate cell and select the number of licenses to activate. 

4. Click the Activate button. 

Your license server contacts the license activation server at Trimble
Solutions.

5. Next, you need to notify the server. This has to be done each time you
activate a license.

a. Go to Tekla Structures Licensing --> LMTOOLS through the Start
menu or Start screen, depending on your Windows operating
system.

b. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

c. In the LMTOOLS dialog box, go to the Start/Stop/Reread tab.

d. Click ReRead License File. 

The license server reads the license information.

• The activated licenses are displayed in the Activated Licenses area.

• Do not forget to take a backup copy of the trusted storage of the activated
licenses.

• When you open Tekla Structures License Administration Tool, it detects
expired and broken licenses you may have and asks if you want to repair or
deactivate them. If you select Yes, an automatic deactivation or repair is
run.

Useful links

For more information about the status of the activated licenses in the trusted
storage and manual license activation, see the following Support Articles in
Tekla User Assistance:

How to list the activated licenses using command lines

Checking the status of the activated licenses in the trusted storage

Checking the status of the activated licenses in the trusted storage (including
borrowing info)

How to activate licenses using command lines - Manual Activation
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See also

Activating Tekla Structures licenses (page 71)

Problems in Tekla Structures license activation (page 90)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

3.5 Connect Tekla Structures to the license server
To be able to use Tekla Structures on your computer, you need to connect
Tekla Structures to the licenses available on the license server.

• When you start Tekla Structures for the first time, the system asks you to
define the Tekla Structures license server.

1. Start Tekla Structures. 

2. Enter the port@hostname address of the license server in the Server
address box. 

For example, 27007@server_hostname.

You can define several license servers by separating the addresses with
semicolons. For example,
27007@server_hostname_1;27007@server_hostname_2.

3. If you want to check which licenses are available on the license server,
click Check licenses.

4. Click OK to start Tekla Structures.

Manage licenses 76 Connect Tekla Structures to the license server



5. If you need to redefine the license server at some point, go to the File
menu and click Settings --> Change License Server in Tekla Structures. 

The change comes into effect the next time you start Tekla Structures.

See also

Install Tekla Structures license server - automatic installation (page 45)

Modify the license file tekla.lic manually (page 49)

Activate Tekla Structures licenses using automatic server notification (page 72)

Problems in starting Tekla Structures (page 100)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

3.6 Maintain licenses
After the initial licensing setup, you need to make changes in the following
situations:

• You can ensure that the correct types of licenses are available to the users
who most need them by defining access rights for using and borrowing
licenses, see Modify Tekla Structures license access rights (tekla.opt)
(page 77)

• You need to deactivate your existing licenses (page 82):

• When you start using a new version of Tekla Structures, which requires
activating renewed licenses.

• When you make hardware changes that affect the license server.

• If your licenses become untrusted or disabled, you can repair them a
limited number of times as explained in Repair a Tekla Structures license
(page 84).

See also

Troubleshoot Tekla Structures licensing (page 86)

Modify Tekla Structures license access rights (tekla.opt)
The license server administrator may grant different users and user groups
different rights to use licenses by modifying the tekla.opt options file. This
can prevent situations where there are no licenses available for users that
need them because someone else has reserved or borrowed a license that
they do not really need.
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The licensing options file tekla.opt is located in the ..\TeklaStructures
\License\Server folder.

The most common configuration options include the following:

• You can define the access rights for specific usernames or hostnames/IP
addresses either individually or using groups that you define. You can use
the same username or hostname in several groups.

• You can reserve a number of licenses for a specific configuration (e.g.,
Steel detailing) for exclusive use by a specific user or user group. If
necessary, the users in the group can reserve more licenses than the
reserved quota. Other users can only use one of the remaining free
licenses outside the reserved quota.

• You can define a maximum (max) number of licenses that a user or group
can simultaneously use. Users who are not included in this limitation can
use any free license.

• You can include (allow) a user or group in the exclusive use of all licenses
for a specific configuration. Other users are prevented from using the
configuration.

• You can exclude (disallow) specific users from using any licenses for a
specific configuration. All other users are allowed to use the configuration.

• You can include and exclude users from borrowing licenses.

To modify access rights in the tekla.opt file:

1. Go to the ..\Tekla Structures\License\Server folder.

2. Open the tekla.opt file in a text editor.

3. Enter your definitions for license access rights and restrictions. 

The definition string consists of the following parts: [keyword] [Tekla
Structures feature] [user type] [name]
When you write the definition, follow the rules below.

• Note that the options file is case sensitive.

• If you need to define user groups and host groups, define them first.

Use Windows user names when defining user groups and hostnames
or IP addresses when defining host groups.

• Enter one definition per row. A definition consists of the following
things:

• An options keyword that defines the actions.

• A feature, such as a configuration, that is affected by the keyword.

• The type that is affected by the keyword.

The options are: USER, GROUP, HOST, and HOST_GROUP.
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• The name of the user, user group, host, or host group that is
affected by the keyword.

You can use the hostnames or IP addresses of the computers with
the HOST and HOST_GROUP keywords.

• To disable a row in the options file, enter # in the beginning of the row.

Examples of definitions:

INCLUDE PCD-C USER scarlett (Only the user scarlett is allowed to
use the Precast Concrete Detailing configuration.)

RESERVE 1 RCD-C USER vera (One license of the Rebar Detailing
configuration is reserved for the user vera.)

For details about the allowed keywords and configuration codes together
with more examples, Configuration codes and keywords used in access
right definitions (page 79).

4. Save the changes and close the text editor.

5. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

6. In LMTOOLS, go to the Start/Stop/Reread tab and click the ReRead
License File button to update the changes in the license file and in the
options file.

Useful links

For more information about limiting certain Tekla Structures versions to
certain users, see the following Support Article in Tekla User Assistance: How
to limit certain Tekla Structures version to certain users

Configuration codes and keywords used in access right definitions
When you define access rights in tekla.opt, you need to use correct
abbreviations (codes) for the configurations, otherwise the definitions do not
work. The access rights are defined using certain keywords.

Configuration codes

When you define access rights for different Tekla Structures configurations in
the tekla.opt options file, you need to add a proper code for each
configuration in the definition.

NOTE The configuration codes are backward compatible, and the codes used
for licensing in older Tekla Structures versions still work. However, the
commercial product name of the configuration may change between
versions. For example, the commercial product name for STDL-C used
to be Steel Detailing Limited, but now it is Primary.

The codes for the Tekla Structures configurations are listed below:
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Configuration code Configuration
CM-C Construction Modeling
DEV-C Developer
DFR-C Drafter
EDU-C Educational
FUD-C Full
PCD-C Precast Concrete Detailing
RCD-C Rebar Detailing
SDE-C Engineering
STD-C Steel Detailing
PPC-C Production Planner - Concrete
STDL-C Primary
VIE-C Project Viewer

Most common keywords

The most common keywords that are used for defining license access rights
and restrictions in the tekla.opt options file are listed and described below:

Keyword Description Usage information
EXCLUDE Prevent access to a Tekla

Structures configuration.
Use with the
abbreviation of the
configuration.

EXCLUDE_ENTITLEMENT Prevent license
borrowing.

Use with the activation
ID of the license.

EXCLUDEALL Prevent access to all
Tekla Structures
configurations.

 

GROUP Define a user group for
use with any options.

Use with Windows user
names (separated with
spaces).

HOST_GROUP Define a host group for
use with any options.

Use with computer
hostnames or IP
addresses (separated
with spaces).

INCLUDE Allow a user to use a
Tekla Structures
configuration.

Use with the
abbreviation of the
configuration.

INCLUDE_ENTITLEMENT Allow a user to borrow a
license.

Use with the activation
ID of the license.

INCLUDEALL Allow a user to use all
Tekla Structures
configurations.
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Keyword Description Usage information
MAX Limit the usage of a

configuration.
Use with the number of
licenses and the
abbreviation of the
configuration.

RESERVE Reserve licenses for a
user/host or a group of
users/hosts.

Use with the number of
licenses and the
abbreviation of the
configuration.

• When somebody is allowed to use a configuration with the INCLUDE
keyword, other users are automatically prevented from using the
configuration.

• When somebody is denied to use a configuration with the EXCLUDE
keyword, other users are automatically allowed to use the configuration.

• If no rules exist, everybody is allowed to use the configuration.

Some examples of definitions in a tekla.opt options file are given below:

Options file definition Description
INCLUDE PCD-C USER
scarlett

Only the user scarlett is allowed to use the
Precast Concrete Detailing configuration.

EXCLUDE FUD-C USER justin The user justin is not allowed to use the
Full configuration. Other users are allowed
to use the Full configuration.

GROUP tsusers jessica joe
neil
INCLUDEALL GROUP tsusers

The users jessica, joe and neil belong to
the group tsusers. Only the group tsusers
is allowed to use all configurations.

EXCLUDEALL HOST pcrobert No configuration is allowed to be used on
the computer pcrobert.

INCLUDE_ENTITLEMENT
qwer-1234-asdf-5678-zx
USER gwen

Only the user gwen is allowed to borrow a
license whose activation ID is qwer-1234-
asdf-5678-zx.

EXCLUDE_ENTITLEMENT
rtyu-9876-fghj-5432-cv
USER matt

The user matt is not allowed to borrow a
license whose activation ID is rtyu-9876-
fghj-5432-cv.

GROUP students amy chloe
andy dean
MAX 3 EDU-C GROUP
students

The users amy, chloe, andy, and dean
belong to the group students. The limit to
the usage of the Educational configuration
for the group students is three licenses.

RESERVE 1 RCD-C USER vera One license of the Rebar Detailing
configuration is reserved for the user vera.
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Options file definition Description
GROUP STUDENTS user1
user2 user3
RESERVE 3 VIE-C GROUP
STUDENTS

The users user1 user2 user3 belong to the
group STUDENTS. 3 licenses of the Project
Viewer configuration are reserved for the
group STUDENTS.

STUDENTS is a group name.

user1 - user 3 are Windows user names
separated with spaces.

The number 3 is the number of licenses to
reserve.

VIE-C is the configuration code for the
Project Viewer configuration.

Note that any licenses reserved for a group
are dedicated to that group. Even when
that group is not actively using the licenses,
the licenses are unavailable to other users.

INCLUDE VIE-
C:VENDOR_STRING=Enterpris
e USER john

Only the user john is allowed to use the
Project Viewer configuration which is of
type Enterprise.

Useful links

For more information about limiting certain Tekla Structures versions to
certain users, see the following Support Article in Tekla User Assistance: How
to limit certain Tekla Structures version to certain users

Deactivating Tekla Structures licenses
When you deactivate a license, the license rights are transferred from your
license server back to Trimble Solutions. Subsequent Tekla Structures licenses
are linked to each other. This means that you need to deactivate the previous
licenses in the chain before you can activate the subsequent licenses. Linking
works also the other way around: if you have activated a subsequent license,
you cannot activate the earlier license after that.

• You need to deactivate all the licenses that are displayed on the same row
in the Activated Licenses area in the Tekla Structures License
Administration Tool.

• Internet access is required in license deactivation.

• After deactivation, you can activate the licenses again on the same or on
another server.
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NOTE Before you deactivate licenses, ensure that the licenses are not in use or
borrowed. The borrowed licenses must be returned before they can be
deactivated.

When you need to deactivate licenses

• Before activating the next temporary license or a permanent license in the
license chain.

• When renewing the annual maintenance, for example, when you switch
from Tekla Structures 20 licenses to Tekla Structures 21 licenses, you need
to deactivate the licenses from the previous year to be able to activate the
licenses for the following year.

• If you have activated a wrong configuration or too many configurations.

• Before re-hosting the license server from one computer to another.

• Before changing hardware or the IP address on the license server.

• Before reinstalling or upgrading Windows on your server computer.

• Before formatting your server computer.

When you do not need to deactivate licenses

You do not need to deactivate licenses before uninstalling and reinstalling the
license server.

See also

Deactivate Tekla Structures licenses (page 83)

Problems in Tekla Structures license deactivation (page 95)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Deactivate Tekla Structures licenses

NOTE Before you deactivate licenses, ensure that the licenses are not in use
or borrowed. The borrowed licenses must be returned before they can
be deactivated.

To deactivate licenses:

1. Go to Tekla Structures Licensing --> Tekla Structures License
Administration Tool through the Start menu or Start screen, depending
on your Windows operating system. Start Tekla Structures License
Administration Tool with administrator rights.

2. In the Tekla Structures License Administration Tool dialog box, go to
the Statistic tab and ensure that no-one is using the licenses.
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3. If you have not activated the automatic server notifications (the Notify
Server option in Tekla Structures License Administration Tool), you
need to stop the license server manually in LMTOOLS:

a. Go to Tekla Structures Licensing --> LMTOOLS through the Start
menu or Start screen, depending on your Windows operating
system. Start LMTOOLS with administrator rights.

b. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

c. Go to the Start/Stop/Reread tab and click Stop Server.

4. In Tekla Structures License Administration Tool, go to the Licenses tab.

The Activated Licenses area lists the active licenses.

5. Select the Deactivate check box to select the license for deactivation. 

If you activated more than one license of the same type in one go, you
cannot deactivate those licenses one by one, but you need to deactivate
all of the licenses in one go.

6. The Deactivate button is activated, click it.

The license server contacts the activation server at Trimble Solutions. Internet
access is required at this stage. After a successful deactivation you will see the
license successfully deactivated message, and the Tekla Structures License
Administration Tool dialog box is updated.

For more information about manual license deactivation, see the following
Support Article in Tekla User Assistance:

How to deactivate licenses using command line - Manual Deactivation

See also

Deactivating Tekla Structures licenses (page 82)

Problems in Tekla Structures license deactivation (page 95)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Repair a Tekla Structures license
If your licenses have become untrusted or disabled, they cannot be used and
you need to repair them.
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The license trust status is indicated in the Activated Licenses area in Tekla
Structures License Administration Tool. If a trust status symbol is green, the
information is trusted, if red, the information is untrusted.

WARNING Because of technical and security reasons, you can repair a
license only a limited number of times, which at the moment is
two times a year. Therefore it is important that you inform your
local Tekla Structures representative about the license repairs you
have been performing, and keep count of the repairs.

The status can be one of the following:

• A red H (Host) indicates whether the server has been moved to another
computer, or whether the computer hardware has changed radically.

The Host trust status of your license is not trusted:

NOTE Licenses that have the Host trust status untrusted cannot be
repaired.

• A red T (Time) indicates whether the system clock has been tampered with.

The Time trust status of your license is not trusted:

• A red R (Restore) indicates whether the license is obtained from a backup
copy.

The Restore trust status of your license is not trusted:

To repair a Tekla Structures license:

1. Go to Tekla Structures Licensing --> Tekla Structures License
Administration Tool through the Start menu or Start screen, depending
on your Windows operating system. 

The Activated Licenses area displays the activated licenses.

2. Click Repair. 

The license server contacts the activation server at Trimble Solutions.
After successful repairing the trust status in Tekla Structures License
Administration Tool dialog box is updated.
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For more information about the status of the activated licenses in the trusted
storage, see instructions in the following Support Articles in Tekla User
Assistance:

Checking the status of the activated licenses in the trusted storage

Checking the status of the activated licenses in the trusted storage (including
borrowing info)

Troubleshoot Tekla Structures licensing
Click the links below for help in solving problems encountered in the following
areas:

• View and diagnose errors in Tekla Structures license activation, deactivation
and borrowing (page 86)

• Problems in Tekla Structures license server installation and connecting to
the license server (page 87)

• Problems in FlexNet (page 90)

• Problems in Tekla Structures license activation (page 90)

• Problems in Tekla Structures license deactivation (page 95)

• Problems in Tekla Structures license borrowing (page 95)

• Problems in Tekla Structures license trusted storage (page 96)

• Problems using LMTOOLS in Tekla Structures licensing (page 97)

• Problems in starting Tekla Structures (page 100)

• Problems with options file tekla.opt (page 101)

For more information about error messages starting with an error code, see
Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102).

View and diagnose errors in Tekla Structures license activation,
deactivation and borrowing
Tekla Structures License Administration Tool and Tekla Structures License
Borrow Tool both give error messages when errors occur. The tools
automatically create packages of all necessary files required for diagnosing the
errors.

If you have a problem with activating or deactivating licenses, or borrowing or
returning licenses, Tekla Structures License Administration Tool and Tekla
Structures License Borrow Tool display an error message in the Activating
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Licenses(s), Deactivating License(s), Borrowing License(s) or Returning
Borrowed License(s) dialog boxes, depending on the subject of the error.

• You can view more detailed information about an error by clicking the View
button in an error dialog box.

• Tekla Structures License Administration Tool and Tekla Structures
License Borrow Tool automatically create zip packages of all necessary
files required for diagnosing the errors in the C:\TeklaStructures
\License\Server\Reports folder and in the %TEMP%\Tekla
Structures License Borrow Tool\Reports folder. Click Browse in
the error dialog box to browse for the folder containing the error report
package. You can send the package to your local support to get help.

The error report package contains the following files:

tekla_debug.log - Tekla Structures license server debug log file

error.txt - error report, contains error information. The Tekla
Structures License Borrow Tool zip package only contains this file.

tekla.opt - access rights options file

tekla.lic - Tekla Structures license file

See also

Troubleshoot Tekla Structures licensing (page 86)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Problems in Tekla Structures license server installation and connecting
to the license server

License server installation fails, and the following message is displayed:
"A newer version of this application is already installed on this computer.
If you wish to install this version, please uninstall the newer version first.
Click OK to exit the wizard."

Reason: You have a newer version the license server installed.

Solution: You should not install an old version of the license server. Check the
latest available license server release on the Tekla Downloads product
download page.

The license server version is not dependent on the Tekla Structures. However,
if you need to use an older version of the license server for some reason,
uninstall the newer version on your computer before installing the older
version.
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License server installation does not finish (no error message)

Reason: Another software using the FlexNet licensing system is running on the
computer.

Solution: Stop all licensing services in LMTOOLS, then install the Tekla
Structures license server and restart the licensing services you stopped earlier:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services is selected, select a license service from the services list, go to
the Start/Stop/Reread tab and click Stop Server.

Do the same for all the services you need to stop.

3. Install the Tekla Structures license server.

4. In LMTOOLS, start the licensing services you stopped earlier.

Problem in license server connection. The following message is displayed:
"Error when connecting to the license server. Contact your system
administrator or try another server".

Reason: This problem is often related to firewall settings.

Solution: Check that your firewall allows the client to contact the license
server.

License library initialization failed with error: The licensing service is not
installed.

Reason: The error occurs when you are starting Tekla Structures License
Administration Tool, or when you are trying to run serveractutil.exe
command line tool.

Solution: If you selected the Manual option for Tekla Structures licensing
service installation then you need to manually install FLEXnet licensing service:

1. If you have some other FlexNet licensing service running on the server,
stop it before entering the commands.

2. Go to the Start menu or Start screen, depending on your Windows
operating system, and open Command Prompt as an administrator.

3. At the command prompt, type the following commands:

cd /D full_path_to_installation_directory
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For example, if you install Tekla Structures license server to the default
folder, you need to enter cd /D C:\TeklaStructures\License
\Server.

installanchorservice.exe

Cannot connect to the license server.

Solution: For the first time that you connect to the Tekla Structures license
server a client computer that has a new version of Tekla Structures installed,
you need to do the following:

• Ensure that both (the client computer and the license server) are in the
same domain.

• Ensure that Local Area Network connection is established. The license
server and the client computers need to be in the same Local Area
Network.

• Turn off the firewall and pause the antispyware/antivirus protection of your
computer.

After the steps above do the following on your company's license server:

1. Make sure that no one is using Tekla Structures (ask all users to close
Tekla Structures).

2. Go to C:\TeklaStructures\License\Server and open the
tekla.lic file in a text editor.

3. Add a free TCP/IP port for the licensing service at the end of the first row,
if it does not exist by default. Note that the automatic installation option
sets the port by default to 27007.

Example of the first row: SERVER MYSERVER ANY 27007, where
MYSERVER is the license server and 27007 is the port.

4. Save and close the file after changes.

5. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

6. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

7. On the Start/Stop/Reread tab, click Stop Server. Wait couple of seconds
and click on Start Server.

After defining the server and the port, do the following on your Tekla
Structures workstations:

1. Start Tekla Structures.

2. In the Connect to License Server dialog box, add the port to the front of
the server definition and click OK.

Example: 27007@MYSERVER
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Cannot start the Tekla Structures licensing service.

Reason: The tekla-debug.log file may be locked, thus preventing the
service from starting.

Solution: Delete the tekla-debug.log and restart the computer.

See also

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Installing Tekla Structures license server (page 43)

Allowing Tekla Structures license server to operate through Windows Firewall
(page 52)

Problems in FlexNet

An internal error occurred. FlexNet internal error.

Reason: There is a problem with the Tekla Structures License Server
installation.

Solution: This error can often be fixed by performing the steps below:

1. Uninstall all existing Tekla Structures license server installations.

2. Check that all the files are deleted from the Tekla Structures license server
installation folder: .. \TeklaStructures\License\Server.

3. Install the latest Tekla Structures license server. Check for the latest
version in Tekla Downloads.

See also

Installing Tekla Structures license server (page 43)

Uninstall the license server manually (page 0 )

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Problems in Tekla Structures license activation

The following message is displayed: "Error reading entitlement file".
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Reason: The .NET Framework is not working for some reason.

Solution: Reinstall the existing .NET Framework, or install the latest .NET
Framework version that is available for your operating system.

License activation fails, and the following message is displayed: "Unable
to activate more licenses than you are entitled to".

Reason: There are a couple of possible reasons for the problem:

• You may have activated licenses on another computer. You cannot activate
more licenses than you are entitled to.

• You tried to activate a renewed temporary license or a permanent license
without deactivating the previous temporary license.

Solution: There are two possible solutions:

• Deactivate a license on another computer and then activate the license on
your computer.

• Deactivate the existing temporary license and then activate the succeeding
linked license.

For more information about deactivating licenses, see Deactivate Tekla
Structures licenses (page 83).

The amount of activated licenses in Tekla Structures License
Administration Tool and LMTOOLS does not match.
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Reason: The licensing service is not updated with new license information.

Solution 1: Reread the license file in LMTOOLS:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

2. On the Start/Stop/Reread tab, click ReRead License File.

Solution 2: If you are connected to several license servers, rereading the
license file may not work. In that case, you need to stop the license server and
then restart it in LMTOOLS:

1. Ensure that no one is using Tekla Structures license server.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

3. On the Start/Stop/Reread tab in LMTOOLS, select the Force Server
Shutdown check box and click Stop Server.

4. Check that the status is "Stopping server". Wait for a few minutes.

5. Click Start Server, and ensure that "Server Start Successful" is displayed.

Manage licenses 92 Maintain licenses



TIP To avoid the problem in the future, ensure that the license server is
automatically notified when you activate, deactivate, or repair licenses.

To enable the automatic notification functionality in Tekla Structures
License Administration Tool, click the Notify Server button.

For more information about starting and stopping server and rereading
the license file, see LMTOOLS options and settings used in Tekla
Structures licensing.

For more information about activating licenses, see Activate Tekla
Structures licenses using automatic server notification (page 72).

No warning is displayed, even though the temporary license will expire
within one month.

Reason: The expiry warning message appears only when someone uses the
expiring license. Probably there are several permanent licenses (that have
been activated first) and some temporary licenses that have been activated
after the permanent ones.

When somebody starts Tekla Structures, the system uses licenses in the order
of activation. For example, if you have 10 permanent and 2 temporary
licenses, all 10 licenses must be in use before someone obtains the temporary
license, and receives the warning about the expiring license.

When you try to open the entitlement certificate in Tekla Structures
License Administration Tool, nothing is shown.

Reason 1: You have not downloaded the attached entitlement certificate from
your e-mail application, but opened the certificate in an Internet browser and
saved it as an .html file from the browser.

Solution: Open the e-mail containing the entitlement certificate attachment
EntitlementCertificate.html. Download the entitlement certificate to
the ..\TeklaStructures\License\Server folder from e-mail. Then try to
open it again in Tekla Structures License Administration Tool by clicking
Open.

For more information, see Activate Tekla Structures licenses using automatic
server notification (page 72).

Reason 2: The virus protection system of your computer has removed the
Trimble Solutions logo from the license entitlement certificate.

Solution: The sender of the entitlement certificate should zip the entitlement
certificate file. Unzip the entitlement certificate file on the computer where the
licenses are going to be activated.
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License was activated successfully, but the following error message is
displayed when you run the command line command ”serveractutil -
view”: "Activation library initialization failed."

Reason: The license server installation was not successful.

Solution: Do the following:

1. Stop other FlexNet licensing services in LMTOOLS.

2. Run the installanchorservice.exe at the command prompt, restart
the license server.

After doing this you will be able to activate your licenses and use Tekla
Structures.

If the above did not work, you need to uninstall the license server and reinstall
the recent version once again with administrator rights.

For more information about uninstalling and installing the license serve, see
Uninstall the license server manually and Installing Tekla Structures license
server (page 43).

The automatic notification functionality in Tekla Structures License
Administration Tool does not work: nothing happens when you click the
Notify Server button

Reason: One of the reasons why the Notify Server button does not work in
Tekla Structures License Administration Tool might be that Tekla Structures
Licensing Service is not started on the computer.

Solution: To solve the issue, open Windows Control Panel --> Administrative
Tools --> Services . Ensure that the Tekla Structures Licensing Service status
is Running . The Startup Type of the service should be set either to
Automatic or to Automatic (Delayed Start).

Your licenses no longer appear as activated licenses, or old version
licenses are activated, but they do not work.

Reason: Windows system restore may cause problems for licensing. For more
information, see Windows system restore might affect your model and
licensing.

Useful links

For more information about the status of the activated licenses in the trusted
storage, see instructions in the following Support Articles in Tekla User
Assistance:
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Checking the status of the activated licenses in the trusted storage

Checking the status of the activated licenses in the trusted storage (including
borrowing info)

See also

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Problems in Tekla Structures license deactivation

Unable to select a license for deactivation.

Reason: You cannot select a license for deactivation if the license is still
borrowed.

Solution: Return the license and then deactivate the license.

See also

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Deactivating Tekla Structures licenses (page 82)

Problems in Tekla Structures license borrowing

Unable to select a date from the calendar in the Borrow Until box.

Reason: The maximum borrowing period is one month.

Solution: In Tekla Structures License Borrow Tool, select a date that is
within one month from the date of borrowing:

1. Go to Tekla Structures License Borrow --> Tekla Structures License
Borrow Tool through the Start menu or Start screen, depending on your
Windows operating system.

2. In the Products area, click the Borrow Until box and select from the
calendar the expiration date that is within one month from the date of
borrowing.

Tekla Structures does not start up with the borrowed license.
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Problem: You borrowed a license and disconnected from the network. When
you open Tekla Structures, the Tekla Structures - Connect to License Server
dialog box is displayed, but Tekla Structures does not find the borrowed
license.

Solution: If Tekla Structures does not start up with the borrowed license,
please type only an asterisk character (*) into the Server address box in the
Tekla Structures - Connect to License Server dialog box.

This will force Tekla Structures to search for all possible locations for the
license. It might take some time until it finds the license.

The computer that is running a borrowed license crashed, what should I
do?

Solution: If your computer only needs rebooting, you can use the borrowed
license again after rebooting. If your computer completely breaks down, the
license will automatically be available on the license server when the
borrowing period expires.

See also

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Borrowing Tekla Structures licenses for offline use (page 109)

Problems in Tekla Structures license trusted storage

A license cannot be used.

Reason: The Host (H) trust status of your license is not trusted. Hardware
setup of your server computer has changed radically.

Solution: The licenses with the untrusted H trust status cannot be repaired.
Contact your local Tekla Structures support.

We recommend that you run your license server on a proper server computer
that is regularly maintained. You need to deactivate your licenses before
performing any maintenance actions on your server computer. However,
unnecessary deactivations should be avoided due to technical and security
reasons.

For more information, see Repair a Tekla Structures license (page 84).

A license cannot be used.
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Reason: The Time (T) trust status of your license is not trusted. Time settings
of your server computer have changed radically.

Solution: You need to set the correct system date and time and after that
repair the license in Tekla Structures License Administration Tool.

Do not manipulate system clock settings of the server computer that has
activated licenses.

For more information, see Repair a Tekla Structures license (page 84).

A license cannot be used.

Reason: The Restore (R) trust status of your license is not trusted. Your
backup system may have overwritten some licensing information.

Solution: You need to repair the license in Tekla Structures License
Administration Tool.

We recommend that you configure your system backup settings so that the
existing licensing software, tools and files are not automatically overwritten or
replaced with the restored ones.

For more information, see Repair a Tekla Structures license (page 84).

See also

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Repair a Tekla Structures license (page 84)

Problems using LMTOOLS in Tekla Structures licensing

LMTOOLS does not reread the license file.

Reason: Rereading the license file does not work if you are running a licensing
service locally on your computer and you are connected to another license
server at the same time.

Solution: You need to stop and restart the licensing service. Do the following:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.
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2. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

3. On the Start/Stop/Reread tab, click Stop Server and wait a few seconds
for the service to stop.

4. Click Start Server.

LMTOOLS is unable to stop the license server, and the message "Unable
to Stop Server" is displayed in the LMTOOLS message bar.

Reason: You may have selected an incorrect licensing service.

Solution: You need to select Tekla Structures Licensing Service as the
licensing service. Do the following:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

3. Go to the Start/Stop/Reread tab, and click Stop Server.

4. If this does not help, select the Force Server Shutdown check box and
click Stop Server again.

LMTOOLS is unable to stop the license server.

Reason: You did not run LMTOOLS with administrator rights.

Solution: Run LMTOOLS with administrator rights. For more information, see
Rights needed for performing administrator's tasks in Tekla Structures
licensing (page 35).

Starting or stopping the server or rereading the license file cannot be
performed, and the message "No Server Selected" is displayed.

Reason: You have not selected the licensing service.

Solution: You need to select Tekla Structures Licensing Service as the
licensing service. Do the following:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

3. Go to the Start/Stop/Reread tab and start or stop the server or reread
the license file.
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Starting or stopping the server or rereading the license file is not
possible.

The status list in LMTOOLS indicates that the license server manager (lmgrd)
has not been started: "Error getting status: Cannot connect to license server
system. The license server manager (lmgrd) has not been started yet, the
wrong port@hostname or license file is being used, or the port or hostname in
the license file has been changed".

Reason: LMTOOLS points to the wrong lmgrd.exe.

Solution: You need to modify the settings in LMTOOLS. Do the following:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

3. Go to the Config Services tab, and click Browse to locate the lmgrd.exe
file.

By default, the file is installed in the ..\TeklaStructures\License
\Server folder.

4. Click Save Service.

5. Go to the Start/Stop/Reread tab and click Stop Server.

6. Click Start Server to restart the server.

The changes are applied.

LMTOOLS does not show the licensing service status.

The status list on the Server status tab in LMTOOLS indicates that the license
file cannot be found: "Error getting status: Cannot find license file. The license
files (or license server system network addresses) attempted are listed below.
Use LM_LICENSE_FILE to use a different license file, or contact your software
provider for a license file".

Reason: You are trying to perform a status enquiry of a licensing service that is
not running.

Solution: You need to start Tekla Structures Licensing Service. Do the
following:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

3. Go to the Start/Stop/Reread tab and click Start Server.

4. Go to the Server Status tab and click Perform Status Enquiry again.
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See also

Install Tekla Structures license service - manual installation (page 46)

Configure Tekla Structures license server manually (page 50)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Problems in starting Tekla Structures

 Tekla Structures does not start. The following message is displayed:
"Error when connecting to the license server. Contact your system
administrator or try another server".

Reason: You are not connected to the license server.

Solution: Check the following:

• Check that your network connection is working.

• Check that you have entered the license server name correctly.

For more information, see Connect Tekla Structures to the license server
(page 76).

• Check that license information in LMTOOLS is correct. If not, reread the
license file in LMTOOLS and try to start Tekla Structures again.

For more information about LMTOOLS, see LMTOOLS options and settings
used in Tekla Structures licensing.

Tekla Structures does not start. The following message is displayed:
"License server system does not support this feature".

Reason: Your license server may not be up to date.

Solution: Update the status of your license server. Do the following:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system. Start
LMTOOLS using administrator rights.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

3. On the Start/Stop/Reread tab, click Stop Server and wait a couple of
seconds.

4. Click Start Server.
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5. Start Tekla Structures.

If the problem still persists, contact your local Tekla Structures support. The
support will need a copy of the following files: tekla.lic, tekla.opt, and
tekla_debug.log files.

Tekla Structures does not start occasionally.

The following message is displayed: "Cannot connect to license server system.
The license server manager (lmgrd) has not been started, the wrong
port@host or license file is being used, or the port and hostname in the license
file has been changed".

Reason: There may be communication problems between your license server
and Tekla Structures client computers if the port of the license server is not
defined.

Solution: Define the port for the license server. Do the following:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

3. On the license server computer, define a free port for the license server in
the tekla.lic file. For more information, see Modify the license file
tekla.lic manually (page 49).

4. Go to the Start/Stop/Reread tab and stop the license server by clicking
Stop Server.

5. Click Start Server.

6. Start Tekla Structures on a client computer.

7. In Tekla Structures, click Tools --> Change License Server . Define the
port and hostname of the license server.

8. Close Tekla Structures.

9. Repeat steps 5 to 7 on all Tekla Structures client computers.

See also

Connect Tekla Structures to the license server (page 76)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Problems with options file tekla.opt

The tekla.opt file does not take effect.
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Reason: The licensing service has not read the options file.

Solution: Do the following:

1. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Structures Licensing Service are selected.

3. On the Start/Stop/Reread tab, click ReRead License File.

4. Browse to the ..\TeklaStructures\License\Server folder and open
the tekla_debug.log file and the tekla.opt file with a text editor.

5. Check that the tekla_debug.log file contains the same keyword strings
as the tekla.opt file.

If this does not help, please contact your local support.

See also

Modify Tekla Structures license access rights (tekla.opt) (page 77)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)
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Problems in Tekla Structures licensing: Error codes and their
descriptions

Error 6

Problem: License library initialization failed with error: Activation Library
Initialization error #6. Please, contact software vendor to resolve the
problem.

Reason: Tekla Structures license server installation folder contains .dll files
that are from the previous Tekla Structures license server version.

Solution: To resolve the problem, do the following:

1. Close Tekla Structures License Administration Tool and stop the Tekla
Structures license server in LMTOOLS by clicking Stop Server on the
Start/Stop/Reread tab.

2. Uninstall all existing Tekla Structures license server installations.

3. If the Tekla Structures license server installation folder contains any .dll
files, remove the files manually.

4. Now you can install Tekla Structures license server to the same folder
where the uninstalled version was.

For more information about license server installation, see Installing Tekla
Structures license server (page 43).

NOTE Deactivation is not needed in this case. Licenses are kept safe in a
specific Flexera Software location outside Tekla Structures license
server installation directory.

Error 20

Problem: Error 20: The licensing service is not installed.

Reason: The error occurs when you are starting Tekla Structures License
Administration Tool, or when you are trying to run serveractutil.exe
command line tool.

Solution: If you selected the Manual option for Tekla Structures licensing
service installation then you need to manually install FLEXnet licensing service:

1. If you have some other FlexNet licensing service running on the server,
stop it before entering the commands.

2. Go to the Start menu or Start screen, depending on your Windows
operating system, and open Command Prompt as an administrator.

3. At the command prompt, type the following commands:

cd /D full_path_to_installation_directory
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For example, if you install Tekla Structures license server to the default
folder, you need to enter cd /D C:\TeklaStructures\License
\Server.

installanchorservice.exe

Error 109

Problem: There are no activated licenses to return. Another program may
have modified the activated licenses rights concurrently. (109) Unable to
return as there is no licenses in Trusted Storage.

Reason: The trusted storage has been modified, probably by some other
program.

 The red Restore (R) trust status of your license is not trusted. The
license is broken, therefore it cannot be returned.

Solution: The license will become available on the server machine
automatically when the borrow period ends.

Error 123 or error 50030

Problem: Message 1: Row n: An error occurred but FLEXnet Licensing did
not return an error number. (123)

Message 2: Failed to load trusted storage or specified ASR. (50030)

Reason: These error messages indicate that the trusted storage cannot be
loaded, and your trusted storage is corrupted.

Solution: Your licenses need to be replaced. Contact your local Tekla
Structures representative for a replacement along with some instructions.

Error 1316

Problem: License server installation fails.

The following message is displayed: "A network error occurred while
attempting to read from the file C:\Documents and Settings\paha\Local
Settings\Application Data\Downloaded Installations\...\Tekla
Structures License Server v1.01.msi".

Reason: You have an older version of the license server installed.

Solution: Uninstall the old version and then install the new version of the
license server.

For more information about uninstalling the server, see Uninstall the license
server manually.

Error 1316

License activation fails, and the following message is displayed:
"Unspecified FLEXnet Error with code 7174 Only deployed entitlement
line item can be fulfilled."
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Reason: You are trying to activate an obsolete license.

Solution: You should have received a new entitlement certificate from your
local Tekla Structures representative. Try the activation again with the new
entitlement certificate, and move the old obsolete entitlement certificate in an
archive folder.

For more information, see Activate Tekla Structures licenses using automatic
server notification (page 72).

Error 7284

Problem: Unspecified FLEXnet Error with code 7284. Cannot perform
support actions on inactive fulfillment record
FID_xxxxxxxx_xxxxxxxxxxx__xxxx.

Reason: Trusted Storage has been restored from an old backup copy. The
license with fulfillment ID FID_ xxxxxxxx_xxxxxxxxxxx__xxxx has been
deactivated already.

Solution: You need to restore trusted storage files from the most recent
backup copy and then repair licenses if needed.

For more information about repairing licenses, see Repair a Tekla Structures
license (page 84).

Error 7288 and error 111

Message 1: The activation of the fulfillment is denied by the activation
policy because fulfill count exceeded the available seat count.

Message 2: The activation of the fulfillment is denied by the activation
policy because number of copies left is zero.

Reason 1: You may be trying to activate some licenses that have been
activated before on another server/computer.

Solution: Deactivate the licenses from the other computer, and then activate
the licenses on the new server/computer.

Reason 2: You may be trying to activate a renewed temporary license or
permanent licenses without deactivating the previous linked activated licenses.

Solution: Deactivate the existing temporary licenses first and then activate the
succeeding linked licenses.

For more information about deactivating licenses, see Deactivate Tekla
Structures licenses (page 83).

Error 7343

Problem: Unspecified FLEXnet Error with code 7343 Entitlement line item
has expired on <date> <time>.

Reason: License has expired. It is not possible to activate or repair expired
licenses.
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Error 7466

Problem: License deactivation fails, and the following message is
displayed: "The return of the fulfillment is denied by the return policy
because max return exceeded".

Reason: You have deactivated the license too many times in a 30 days period.

Solution: You can deactivate the license again when 30 days have passed
since the first deactivation of the license in the past 30 days. The number of
deactivations of a license within a given time period is limited due to technical
and security reasons.

Error 7581

Problem: Unspecified FLEXnet Error with code 7581. Online Return/Repair
Request for the activationId XXXX-XXXX-XXXX-XXXX-XXXX-XX is not
originated from the original client machine.

Reason and solution: The computer is not the same where the licenses were
originally activated, and you need to return/repair licenses from the original
computer. Another reason might be that the computer has changed so much
that activation server at Trimble Solutions no longer recognizes it as the same
one, in which case you need to replace your licenses.

For more information about returning and repairing licenses, see Return a
borrowed Tekla Structures license (page 114) and Repair a Tekla Structures
license (page 84).

Error 9999

Problem, reason and solution:: Licensing server at Trimble Solutions is down.
Wait for a while and retry.

Error 50005

Problem: Error (5005) License Activation failed - Initialization of API
Failed.

Problem: The activated licenses are not visible and it is not possible to activate
new licenses.

Reason: The installation package has failed to initialize or register some of the
software components.

Solution: Do the following:

1. Log in with administrator's rights.

2. Close License Administration Tool.

3. Stop Tekla Structures license server and other license servers on the same
computer on the LMTOOLS --> Start/Stop/Reread tab.

4. Go to ..\TeklaStructures\License\Server folder.

5. Double-click installanchorservice.exe.
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6. Start Tekla Structures license server and other license servers on the same
computer on the LMTOOLS --> Start/Stop/Reread tab.

7. Open License Administration Tool. The message should not be
displayed anymore.

Error 50018

Problem: License borrowing fails.

Reason: Wrong product ID file is used.

Solution: Do one of the following:

• Export a product ID file in Tekla Structures License Administration Tool
and use the file for borrowing.

Error 50033

Problem: License borrowing fails.

Reason 1: Your license server may not have up-to-date license information.

Solution: In LMTOOLS, stop and then restart the server.

Reason 2: The INCLUDE keyword in the options file prevents the borrowing of
the configuration.

Solution: You need to add a dummy user "ACTIVATED LICENSE(S)" into the
group of the included users to enable the borrowing. Do the following:

1. Open tekla.opt using a text editor.

2. Add "ACTIVATED LICENSE(S)" in the group of the included users, for
example:

GROUP steel "ACTIVATED LICENSE(S)" user1 user2 user3
user4
INCLUDE STD-C GROUP steel

3. Save the changes you made in tekla.opt.

4. In LMTOOLS, reread the license file or stop the server and then start the
server.

Error 50035

Problem: License borrowing fails.

Reason: The user tried to borrow a license that is not activated on the license
server. For example, the user tried to borrow a version 20 license and there
are only version 21 licenses activated on the server.

Solution: Do the following:

• Check that the product ID file is up to date. If not, export a new product ID
file in Tekla Structures License Administration Tool ( File --> Export )
and send this file to the user for borrowing. Then ask the user to save the
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new product ID file, open the Tekla Structures License Borrow Tool , click
Open and browse for the new .tpi file and try borrowing again.

• Check that your license information is up to date in LMTOOLS. If not,
reread the license file.

Error 50036

Problem: License borrowing fails.

Reason: You are not allowed to borrow the license.

Solution: Do one of the following:

• The options file (tekla.opt) needs to be modified so that the borrowing of
the license is allowed. For more information, see Modify Tekla Structures
license access rights (tekla.opt) (page 77)

• Borrow another license.

Error 50037

Problem: License returning fails.

Reason: You tried to return the license to a different license server than it was
borrowed from.

Solution: You need to return the license to the same license server that it was
borrowed from. Do the following:

1. Go to Tekla Structures License Borrow --> Tekla Structures License
Borrow Tool through the Start menu or Start screen, depending on your
Windows operating system.

2. In the Borrow from License Server dialog box, enter the name of the
license server where you originally borrowed the license from and click
OK.

3. Select the Return check box in the Borrowed Licenses area to select the
license for returning.

4. Click the Return button to return the license.

After successful returning of licenses, the Borrowed Licenses area is
updated.

Error 50040 or error 50041

Error 50040 or error 50041, problem 1: License activation, deactivation or
repairing fails

Reason: Your license server was not able to connect to activation server at
Trimble Solutions correctly. Usually this is a temporary problem in online
activation.

Solution: Do the following:
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• Check that your Internet connection is working. An Internet connection is
needed during license activation and deactivation. A low connection speed
may also cause errors.

• Close Tekla Structures License Administration Tool and try to activate
the license a while later.

• Try to activate another license.

• Your firewall may block the activation communication. Check your firewall
settings. For more information, see Allowing Tekla Structures license server
to operate through Windows Firewall (page 52).

• Check that you have the latest Tekla Structures license server version.

• This error could be caused by unfinalized Windows updates on the server
computer. Reboot the server and try again.

• Your Windows login user name may contain special characters. Try to log in
with another user name, for example, administrator.

• Check that your Internet connection is working.

• Contact your local Tekla Structures support and ask for a manual
activation.

Error 50040 or error 50041, problem 2: License borrowing fails.

Reason: You are not connected to the license server.

Solution: Do the following:

• Check that your network connection is working.

• Start Tekla Structures License Borrow Tool and check that you have
entered the correct license server information in the Borrow from License
Server dialog box.

See also

View and diagnose errors in Tekla Structures license activation, deactivation
and borrowing (page 86)

Problems in Tekla Structures license activation (page 90)

Problems in Tekla Structures license borrowing (page 95)

Problems in Tekla Structures license deactivation (page 95)

3.7 Borrowing Tekla Structures licenses for offline use
When you want to work offline, you can borrow an activated license from the
Tekla Structures license server. The borrowed license is transferred from the
license server to your computer, so it is not available for other users during
the borrowing. Also a product file is needed for borrowing licenses. You do not
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need to borrow a license for offline use if you have installed a license server
on your computer.

You can borrow Tekla Structures licenses for offline Tekla Structures use in
Tekla Structures License Borrow Tool:

• The version of Tekla Structures License Borrow Tool should be the same
as the version of Tekla Structures license server.

• The maximum license borrow duration is one month. You define the
borrow expiration date when you borrow the license.

• The borrowed license is reserved for you until the borrowing period
expires, or until you return the license, depending on which comes first.

• You need a network connection to the license server while you are
borrowing or returning a license. You can also borrow licenses through a
VPN connection. After borrowing, you can turn off the network or VPN
connection and work with the borrowed license.

• When you want to stop borrowing a license, return it to the license server.

Product ID file

A product ID (.tpi) file is needed for borrowing licenses. The product ID file
contains all the information needed in license borrowing. The administrators
need to provide the offline users with a customized product ID. For more
information, see Provide offline users with a customized product ID file
(page 111).

When you install Tekla Structures License Borrow Tool, the standard.tpi
file is automatically installed in the ..\TeklaStructures\License\Borrow
folder. This default product ID file lists all Tekla Structures configurations and
their product IDs. However, you can only borrow the licenses that are activated
for you on the license server. If you want that Tekla Structures License
Borrow Tool only displays the activated licenses, ask your license server
administrator for a customized product ID file and open it in Tekla Structures
License Borrow Tool when you start license borrowing.

How does the license borrowing work

License borrowing works in the following way:

1. The administrator installs and sets up a Tekla Structures license server on
a separate server computer, and activates the licenses for borrowing.

2. The user installs the Tekla Structures License Borrow Tool, connects the
computer with Tekla Structures to the Tekla Structures license server, and
opens the product ID file to see the licenses that are available for
borrowing.

For more information about setting up license borrowing, see Set up Tekla
Structures License Borrow Tool for Tekla Structures offline use (page 112).
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3. The user borrows licenses from the license server.

For more information about borrowing licenses, see Borrow a license
from Tekla Structures license server (page 113).

4. The user waits for the license expiration date, or returns the licenses to
the server before the expiration date.

For more information about returning borrowed licenses, see Return a
borrowed Tekla Structures license (page 114).

See also

Modify Tekla Structures license access rights (tekla.opt) (page 77)

Problems in Tekla Structures license borrowing (page 95)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

Provide offline users with a customized product ID file
Tekla Structures License Borrow Tool needs the activation IDs of the licenses
during borrowing. When you export a product ID file (.tpi) in Tekla
Structures License Administration Tool, the activation IDs of the activated
licenses are written in the file. Then you can send the file to offline users.

Because the default product ID file lists all configurations, the offline users
need to have a customized product ID file that only lists the activation IDs of
the activated licenses available for borrowing. You need to export the product
ID file on the license server computer using Tekla Structures License
Administration Tool and send the file to the users who borrow licenses. The
activation IDs are encrypted.

WARNING Product ID files are not updated automatically. If you deactivate
borrowable licenses or activate new licenses for borrowing, you
need to export a new product ID file and send it to Tekla
Structures offline users who borrow licenses.

To export the product ID file on the Tekla Structures license server computer:

1. Go to Tekla Structures Licensing --> Tekla Structures License
Administration Tool through the Start menu or Start screen, depending
on your Windows operating system.

2. Click Export.

3. In the Save Product ID file As dialog box, enter the name of the product
ID file or keep the default file name, select a folder where you want to
save the file and click Save. 

If the name of the file is standard.tpi and the file is saved in the ..
\TeklaStructures\License\Borrow folder on the user’s computer,
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the file is opened automatically when the user starts Tekla Structures
License Borrow Tool.

4. Send the product ID file to the Tekla Structures users who need to borrow
licenses and inform the users about the usage of the file. 

If the name of the file is standard.tpi and the file is saved in the ..
\TeklaStructures\License\Borrow folder on the user’s computer,
the file is opened automatically when the user starts Tekla Structures
License Borrow Tool.

See also

Set up Tekla Structures License Borrow Tool for Tekla Structures offline use
(page 112)

Set up Tekla Structures License Borrow Tool for Tekla
Structures offline use
You can use Tekla Structures offline by borrowing Tekla Structures licenses
with Tekla Structures License Borrow Tool.

Before you start, download and install the latest Tekla Structures License
Borrow Tool from the Tekla Downloads product download page.

You can use the same Tekla Structures License Borrow Tool for borrowing
licenses for different Tekla Structures versions. The version of Tekla
Structures License Borrow Tool should be the same as the version of Tekla
Structures license server.

To set up Tekla Structures License Borrow Tool for Tekla Structures offline
use:

1. Go to Tekla Structures License Borrow --> Tekla Structures License
Borrow Tool through the Start menu or Start screen, depending on your
Windows operating system.

2. In the Borrow from License Server dialog box, enter the port number
and the hostname (computer name) of the license server in the Server
box in the format port@hostname, for example, 
27007@server_hostname. 

3. Click OK.

4. If you administrator has sent you a customized product ID file, open the
file now and update the list of accessible licenses: 
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a. Click Open.

b. In the Select Product ID file dialog box, select the product ID file and
click Open.

The Products area in the Tekla Structures License Borrow Tool is
updated.

5. In the Tekla Structures License Borrow Tool dialog box, click Language
and change the language of the Tekla Structures License Borrow Tool
user interface, if necessary. 

NOTE When you start Tekla Structures, and if Tekla Structures does not start with
the borrowed license, enter an asterisk (*) in the Server address box of the
Connect to License Server dialog box. This will force Tekla Structures to
search for all possible locations for the license. This may take a while.

See also

Problems in Tekla Structures license borrowing (page 95)

Borrow a license from Tekla Structures license server
In Tekla Structures License Borrow Tool, you can borrow licenses from Tekla
Structures license server when you want to work offline. Borrow the license on
the same computer that you will use for offline work.

Before you can borrow a license, you need to install Tekla Structures License
Borrow Tool, connect the computer with Tekla Structures to the license server
and open the product ID file.

For more information about the prerequisites, see Set up Tekla Structures
License Borrow Tool for Tekla Structures offline use (page 112).

To borrow a Tekla Structures license:

1. Close Tekla Structures.

2. Go to Tekla Structures License Borrow --> Tekla Structures License
Borrow Tool through the Start menu or Start screen, depending on your
Windows operating system.

3. In the Borrow from License Server dialog box, enter the port number
with the host name (computer name) in format port@host in the Server
text box, for example: 
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27007@HOST_NAME
You need to use exactly the same port and host name as in the Connect
to License Server dialog box when starting Tekla Structures.

4. Click OK.

5. Click the Open button.

6. Select the product ID file and click Open.

7. In the Products area, click the Borrow Until box and select the expiration
date for the borrowing period from the calendar. 

The maximum borrowing period is one month. The exact maximum
borrow period varies between 29 to 32 days depending on the borrowing
date.

8. Click the Borrow button to borrow the license. 

The borrowing progress is displayed in the Borrowing License(s) dialog
box. After successful borrowing, the Borrowed Licenses area shows the
borrowed license.

9. To ensure that the borrowing succeeded, disconnect your computer from
the license server and start Tekla Structures with the borrowed license.

See also

Problems in Tekla Structures license borrowing (page 95)

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)

View and diagnose errors in Tekla Structures license activation, deactivation
and borrowing (page 86)

Borrowing Tekla Structures licenses for offline use (page 109)

Return a borrowed Tekla Structures license
You can return a borrowed license back to the Tekla Structures license server
before the expiration date.
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A borrowed license is automatically available on the license server on the day
following the expiration date.

However, the Borrowed Licenses area in Tekla Structures License Borrow
Tool is not automatically updated. The license should be returned to the
server that has the same name as the name of the server from which the
license was borrowed. We recommend that you always return the expired
licenses when you want to stop borrowing a license.

To return a borrowed Tekla Structures license:

1. Ensure that you are connected to the license server.

2. Close Tekla Structures.

3. Go to Tekla Structures License Borrow --> Tekla Structures License
Borrow Tool through the Start menu or Start screen, depending on your
Windows operating system.

4. Select the Return check box in the Borrowed Licenses area to select the
license for returning.

5. Click the Return button to return the license. 

After successful returning of licenses, the Borrowed Licenses area is
updated.

See also

Problems in Tekla Structures licensing: Error codes and their descriptions
(page 102)
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4 Create and distribute
customized configurations

To create your customized Tekla Structures configurations and use them in
different projects and on different computers:

• Get familiar with the different configuration files and some basic ways to
change how Tekla Structures works, see Tekla Structures setup guidelines
for administrators (page 116).

• You can use Trimble's default settings as well as create your company's
general settings and project-specific settings, see Environment, company
and project settings for administrators (page 129).

Many of the configurations you distribute are closely linked to working in Tekla
Structures and you find the instructions related to the configuration files you
can distribute as part of the documentation of each feature. Additionally, you
can find some general configuration tasks in this section:

• You can create and distribute a customized ribbon interface as explained in
Distribute custom ribbons using a firm or environment folder (page 134)
and Distribute custom tabs using a firm or environment folder (page 135).

• You can customize the catalogs of materials (page 138), profiles (page 146),
shapes (page 200) and bolts (page 205).

4.1 Tekla Structures setup guidelines for administrators
Tekla Structures administrator is the person responsible for ensuring that the
company standards are used and set up in Tekla Structures. The following
sections explain how you can customize Tekla Structures.
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Customizing Tekla Structures
Each new version of Tekla Structures introduces new features and
functionalities to improve the overall process used for completing a project.
Tekla Structures has multiple environments to suit the needs and
requirements of specific markets. Many features are localized in each Tekla
Structures version. Most of the changes in versions are focused on making the
default saved attributes more consistent, organized, simplified, and practical.

Your local technical team is dedicated to improving your knowledge and
experience of each new version. The team aims at enhancing your user
experience of Tekla Structures by performing tasks that have been identified
as essential by the existing users, new users, and potential users.

Before you start customizing Tekla Structures to suit the needs of your
company and your projects, collect the needed information, such as drawing
standards, used profiles, grades and materials, company logos, and naming
conventions.

The overall localization of Tekla Structures can be divided into four different
layers:

• Tekla Structures environment

• Company-level settings

• Project-level settings

• Multi-user settings

The three last ones are mainly managed by company administrators.

Setting up the standard that a company uses, and the standards that a specific
project needs will make the designing process much more efficient because
the end user can concentrate on the design process.

Tekla Warehouse

Tekla Warehouse has a lot of additional content, such as application tools and
environment content. Tekla Warehouse offline offering that comes as an
option with Tekla Structures installation has all the catalog content of
environments, such as profiles, bolts, materials, and reinforcement. You can
access those inside Tekla Structures via Quick Launch.

In Tekla Warehouse, you can find the catalog content under Tekla Structures
collections. From there all catalog content is installed into the currently open
model. If you did not install the offline content with the Tekla Structures
installation, you can later search for the needed area-specific offline
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collections from the online Tekla Warehouse, and install them. The content is
in .tsep packages that are installed when opening Tekla Structures.

You can also create a local collection for your company, and share it for your
organization in your internal network. You can manage the access rights on
the folder and collection level in the collections.json file on each user's
computer. Copy the file to the same location on each user's computer. The file
is located in C:\Users\Public\Public Documents\Tekla\Tekla
Warehouse\collections.json.

The image below shows an example of the collection paths with four Tekla
Structures collections:

In Tekla Warehouse the collections are found after mapping under My
collections --> Local and network collections.

Overview of environments, roles and licenses
Tekla Structures is one product that has many different configurations. The
licenses you have determine which configurations you can use.

A Tekla Structures environment is set up for the materials, grades, profiles,
drawing settings, component settings, .ini file settings that are used in a
specific market. There are 33 different environments in Tekla Structures. By
choosing a specific environment when starting Tekla Structures you will get the
settings for that market. When installing Tekla Structures, you can select the
environments that you want to use. You can add missing environments later.
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The blank project listed in the environments is an empty platform for your
own environment or project settings. It includes standard parametric profiles,
undefined bolt, material and rebar grades, basic drawing layouts and so on,
which you can complement from your own firm or project folders and Tekla
Warehouse.

Some environments give you the opportunity to select a role when logging in.
The role is independent from the licenses that are used. The purpose of the
roles is to make the user interface and settings clearer, easier and faster for
the user's tasks.

In practice, this means that settings, filters, reports and the user interface is
set up for the role the user has. For example, preloaded settings in a property
dialog box that are not relevant for the role, are not shown making the list of
options shorter and clearer.

Role selection is primarily meant to be configured by Trimble and reseller
localization personnel, and be part of the Tekla Structures installation package.
However, advanced users and Tekla Structures system administrators can also
create their own roles inside their company organization. Additional
environment offering is available in the Tekla Warehouse offline and online
collections. Note that you need to have a Trimble Identity for downloading or
installing from the online collections. For more information, see Trimble
Identity for Tekla Online services
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Folder structure
Tekla Structures software and environments are separated into different
locations due to the requirements for Windows certification. By default, the
files are installed in the following folders:

• Software is installed under the \Program Files\Tekla Structures
folder.

• Environments and extensions are installed under the \ProgramData
\Tekla Structures folder.

• User settings are installed under the \Users\<username>\AppData
\Local\Tekla Structures folder.

NOTE If you have an earlier version of Tekla Structures installed on your computer
before installing Tekla Structures 2017i, the files will be installed according to
the existing structure.

Project and firm folders
Project and firm folders are meant for storing the customized files. For any
company, we strongly recommend setting up firm and/or project folders on a
shared file server accessible to all users. Having the hierarchy of project and
firm folders will make updating company settings, ensuring that everyone uses
the same settings in a project, and upgrading to a newer version of Tekla
Structures much easier.

All the settings that are used on the company level (for example, company logo
and drawing standards) should be stored in a firm folder and all the settings
used on a specific project should be stored in the corresponding project folder.
Property files are always saved in the \attributes folder under the current
model folder, like, \TeklaStructuresModels\<my_building>
\attributes. These files should then be copied to the project or the firm
folder.

To use the saved settings in a firm and a project folder, set the path to the
folder by using the XS_PROJECT and XS_FIRM advanced options. These
advanced options should be put in the initialization, .ini, files. You can have
several different .ini files. You can define in the Tekla Structures shortcut
which .ini files to run and which settings to apply.
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One of the most important advantages of using firm and project folders is that
Tekla Structures does not replace files in the project and firm folders when you
install a new version. This means that you retain your customized files without
having to cut and paste, or export and import from previous versions. This
makes upgrading to a newer version of Tekla Structures easier. When you
store files in one place, it is also easier to update the settings and ensure that
everyone in a project uses the same settings.

Example:

In the current project, 123_project_ABC, you have set up the properties for the
concrete column, and saved them as column_ABC. To make these saved
settings available for everyone working in the 123_project_ABC project, copy
column_ABC.ccl from the \attributes folder under the model folder to
the \123_project_ABC project folder on your file server. Ensure that
everyone in the project has the correct path for the XS_PROJECT advanced
option in the .ini file.

For more information, see Create project and firm folders (page 225) and Files
and folders in Tekla Structures (page 224).

Folder search order
When you open a model, Tekla Structures searches for the associated files in
specific folders in a set order. It is important that you place the files in the
correct folders. Once Tekla Structures finds the associated files, it stops
searching. This means that the files that have the same name but are located
lower down the search order are ignored.

The basic folder search order is the following:

Folder Defined by
Model folder Currently open model
Project XS_PROJECT
Firm XS_FIRM
System XS_SYSTEM

You can define more than one system folder. To do this, enter the file paths of
the folders separated by semicolons as the value for the XS_SYSTEM advanced
option, for example: set XS_SYSTEM=%XSDATADIR%environments\usimp
\system_steel;%XSDATADIR%environments\usimp\system_common.

There are some exceptions to this search order. The exceptions are listed in
Folder search order (page 307).

NOTE Do not store customized files in the system folder. Tekla Structures replaces
these files when you install a new version.
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Initialization files
Initialization files (page 226) (.ini) are used for launching Tekla Structures.
They can contain many advanced options that you can use to configure Tekla
Structures for different standards and your own style of working. Tekla
Structures automatically creates the necessary .ini files during installation.
The number of .ini files it creates depends on how many country-specific
environments you choose to install.

Why are .ini files needed?

There are numerous settings to be made when Tekla Structures starts.
Advanced options are used to determine the appearance and the behavior of
Tekla Structures, for example, the language used, behavior of part marks on
drawings, and the location of your model folder. Advanced options are set
through the .ini files. The different .ini files and what they do, and how
they are related to each other are described below.

Different types of .ini files

The default reading order (page 226) of the .ini files is as shown in the image
below:

1. teklastructures.ini
Initializes the settings needed for Tekla Structures to run.

The teklastructures.ini file in the \bin folder starts Tekla Structures.
We recommend that you do not make any changes to this file.
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2. env_global_default.ini
Sets the global default settings.

The env_<your_environment>.ini file is located in the
\Environments subfolder and it contains all the environment-specific
settings. These files are set by your area office or reseller.

3. environment.ini
Sets the environment-specific settings.

4. role.ini
Sets the settings defined for a role.

The role_<role>.ini file is located in the \Environments subfolder
and it contains the settings specific for a chosen role. For example, the
role_Engineer.ini file in the \Environments\uk folder contains all
the settings for the Engineering role in the UK environment.

5. user.ini
Sets the settings specified by the user.

The user.ini file contains your personal settings. The advanced options
in user.ini override those in other .ini files. For example, if you have
set the same advanced option in an .ini file, in a file in the environments
subfolder and the user.ini file, Tekla Structures uses the value in the
user.ini file. The user.ini is located in the C:\Users\<user_name>
\AppData\Local\Tekla Structures\<version>\UserSettings
folder.

6. options.ini
Sets the settings specified for the company/project/model.

If there are several settings for the same advanced option, the later setting in
the reading order overrules the previous one. This means that the settings in
user.ini overrule the settings in env_global_default.ini, and the
settings in user.in can be overruled by the settings in options.ini.

The lang_enu.ini is the initialization file for the English language settings.
The file is located with the other installed languages in the \Tekla
Structures\<version>\nt\bin folder.

We recommend that you make all your customizations in the options.ini
file under the model folder, or in the user.ini file. This way the
customizations are kept when you install the next version of Tekla Structures.
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Setting advanced options in .ini files
Tekla Structures contains three kinds of advanced options: user-specific
advanced options, system-specific advanced options, and model-specific
advanced options.

NOTE Changing an advanced option value in .ini files located outside the model
folder does not affect the existing models. You can only update the advanced
options in the Advanced options dialog box or in the options.ini file
located in the model folder, not from an options.ini file located in folders
defined for the XS_FIRM or XS_PROJECT advanced option. The .ini files are
also read when you open an existing model, but only new advanced options
that do not exist in options_model.db or options_drawings.db are
inserted, for example, such options that are not yet in the Advanced Options
dialog box, but have been added in the software.

User-specific advanced options set your personal preferences, for example
the appearance of the Tekla Structures window. Tekla Structures saves user-
specific advanced option settings in the options_<your_username>.ini
file, located in the C:\Users\<user_name>\AppData\Local\Tekla
Structures\<version>\UserSettings folder.

The options.ini file contains the settings for model-specific advanced
options. It is located in the current model folder. To share your settings with
other people, copy the options.ini file to the system, project or firm folder.

The system-specific advanced options are stored in all other .ini files.

Setting advanced options

There are two methods for setting advanced options:

• The advanced options are grouped in different categories according to
their usage in the Advanced Options dialog box. To access the dialog box,
click File --> Settings --> Advanced options. See more in Advanced options
reference.

• The .ini files are plain text files that can be edited with a text editor, for
example Notepad. The settings will then be saved in the options.ini file
under the model folder for the model that you have open. The settings can
then easily be copy-pasted into another .ini file. See more in File storing
options and advanced options (page 234).

We recommend that you only use one of these methods to set advanced
options. The settings in the Advanced Options dialog box override those in
the .ini files. Some advanced options need a Tekla Structures restart to
activate the new setting.

To set an advanced option in the user.ini file:

1. Locate the user.ini file in the C:\Users\<user_name>\AppData
\Local\Tekla Structures\<version>\UserSettings folder.
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2. Select and right-click the user.ini file in Windows Explorer and click
Open with. You can open the file in any standard text editor.

3. Check that the advanced option is set to the value you want. If it is, you
can stop here.

4. To change or add the advanced option, on a new line, type set, add a
space and the name of the advanced option followed by its value in a
single line.

Tekla Structures only reads lines in the initialization file that start with set,
for example, set %XS_DIR%=C:\TeklaStructures\2017i

5. Save the user.ini file.

Creating shortcuts
To use the correct .ini files for a specific project, the easiest way is to create a
shortcut for the project on the desktop. Shortcuts are used to start
teklastructures.exe with the defined initializations.

1. Make a copy of the default shortcut: In the Windows Start menu or Start
screen, find Tekla Structures <version>, then right-click the Tekla
Structures <version>.

2. Select Copy from the pop-up menu.

3. Paste the shortcut to your desktop.

4. Select the shortcut and right-click.

5. Select Properties from the pop-up menu.

6. Modify the Target of the shortcut by adding the required project
initializations to it.
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For example, you can use the following parameters in shortcuts:

• -i InitializationFile: Initialization file to be read during startup, for
example: -i \\MyServer\MyProject\Project1.ini. You can repeat
this parameter as many times as you need.

• ModelToBeOpened: Full path to the model to be opened automatically.

.ini files tell where things can be found and in which order, depending on the
folder structure that the company has set up. See more in Create startup
shortcuts with customized initializations (page 21).
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Bypassing the login screen
You can bypass the login screen by using a separate .ini file where you set
the following three advanced options:

• XS_DEFAULT_LICENSE to set the default license for a user role.

• XS_DEFAULT_ENVIRONMENT points to the environment-specific .ini file,
for example %XSDATADIR%\environments\usimp\env_usimp.ini

• XS_DEFAULT_ROLE points to the role-specific .ini file, for example
%XSDATADIR%\environments\usimp\role_Steel_Detailer.ini

Define the startup shortcut using the parameter -I (capital i), for example, -I
%XSDATADIR%\environments\usimp\Bypass.ini. When you do this, an
additional initialization file is read BEFORE the environment .ini.

The content of such a file could be, for example:

set XS_DEFAULT_LICENSE=FULL
  set XS_DEFAULT_ENVIRONMENT=%XSDATADIR%\environments\usimp
\env_US_imperial.ini 
        set XS_DEFAULT_ROLE=%XSDATADIR%\environments\usimp\role_Steel_ 
Detailer.ini 
        

See more in Create startup shortcuts with customized initializations (page 21).

User-defined attributes
User-defined attributes are attributes set to an object in a model or a drawing.
These user-defined attributes can be used for many purposes, such as in
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filters, drawings, reports, export, import, fabrication, erection, and revision
handling.

You can create your own user-defined attributes (page 261) that you need in
your company, or for a specific project. The user-defined attributes can be
numbers, text, lists, or dates. They can be set to be unique for an object or
allowed to be copied; they can also be ignored by numbering or affect
numbering.

The user-defined attributes are defined in objects.inp files. These files are
located in different folders following the Tekla Structures folder setup, and
they are merged together during startup. The objects.inp file reads the
user-defined attributes in order from the folders listed below, starting from
the model folder:

Folder defined by
advanced option

Advanced option

Model Current model folder
Project XS_PROJECT (your defined project folder)
Firm XS_FIRM (your defined firm folder)
System XS_SYSTEM (your defined system folder)
inp XS_INP (your defined inp folder)

The files are merged so that if there are user-defined attributes in any of the
files, they are displayed in the user interface. Tekla Structures merges the files
so that duplicate attributes are removed. If Tekla Structures encounters the
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same attribute name in different objects.inp files, the attribute from the
first read objects.inp file will be used.

If you need to have several objects.inp files in the same folder, you can use
a suffix in the file name to use all the files. This enables having several
objects_<suffix>.inp files in the same folder. The file name could be
objects_precast.inp, for example.

4.2 Environment, company and project settings for
administrators

Environment settings

Common settings

All settings and files that are the same in all environments are located in the
\Tekla Structures\<version>\Environments\common folder. Files and
settings that are specific to an environment are located in separate
environment folders.

The env_global_default.ini file is also located in the \common folder. The
file determines the standard settings, and it is the first file that is read. Other
initialization files (page 226) are read after this file, and if the other files
contain the same settings, they will override the previous settings.

Country-specific settings

The country-specific settings are located in the environments folders, and they
are localized by your local Trimble office/reseller. The folder structure of the
environments can vary, but the same kind of settings exist. For example, the
settings that are localized include profile database, material database, reports,
selection filters, view filters, components and custom components, macros,
user-defined attributes, and drawings settings.

Company settings
Company-level settings are mainly settings that are used throughout the
company for all projects. These settings are set using XS_SYSTEM and 
XS_FIRM.

For a larger company with subsidiaries, the settings could be used as follows:

• XS_SYSTEM may contain multiple paths, and it points to general settings
inside the company. These can be company logo, reports, printer settings,
drawing settings, templates, for example. These are settings that very
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seldom change, and are stored on a server available for all. For example, if
the company logo is updated, it only has to be replaced in one place.

• XS_FIRM points to the firm folder set up by the company, or a subsidiary.
The folder contains all the company settings used at the particular office.
These can be logos, drawing settings, templates, reports, or printer
settings, for example.

• XS_PROJECT points to the project folder. The folder contains project
settings, such as logos for contractors and fabricators, or drawing settings,
for example.

For more information on the folder search order, see Folder search order
(page 307).

You can also use the Tekla Warehouse company-specific collections online or
offline, in your own network. Use Trimble Identity for downloading or installing
from the online collections. See also Trimble Identity for Tekla Online services.

The offline collection access is managed with folder rights in your network,
and on the collection level in the collections.json file on each user's
computer.

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
        

The collections.json file can be shared to selected persons by copying it
to the C:\Users\Public\Documents\Tekla\Tekla Warehouse\ folder.

Model templates

You can save the desired settings in a model and use the model as a template
when you create new models. This can be very useful if your company has
different kinds of projects, such as, parking garages, office buildings, bridges,
and industrial.

When you create a model template, always start by creating a new empty
model. This is because old models that have been used in live projects cannot
be completely cleaned. They may contain excess information that increases
the size of the model even if you delete all objects and drawings from the
model.

To create a model template:

1. Create a new model and give it a unique name.

2. Add in the model the desired profiles, custom components, and other
necessary items.

3. On the File menu, click Save as --> Save as model template.

4. Move the whole model folder to the location pointed by the 
XS_MODEL_TEMPLATE_DIRECTORY advanced option . By default, the
advanced option points to the folder \TeklaStructures\<version>
\Environments\default\model_templates\.
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5. In the new model template folder, open the
TeklaStructuresModel.xml file using any standard text editor.

6. Set the <IsTemplate> element to TRUE. The default value is FALSE.

7. Save the file.

You can also search for model templates in Tekla Warehouse. The image below
shows an example of a model template in Tekla Warehouse.

The Insert into model button installs the model template directly in the folder
pointed by XS_MODEL_TEMPLATE_DIRECTORY. You can immediately use the
template when creating a new model.

NOTE We strongly recommend that you update your model templates in the
Tekla Structures version upgrade. See Administrator's release notes:
Model templates in version update for more detailed instructions.

Customizing reports and drawings

If your company already has graphical templates in the DXF, DWG, or DGN
format, you can convert these templates to Tekla Structures templates. For
detailed instructions on how to do this, see the information on AutoCAD and
Microstation files in the Template Editor Help.

For information on how to create your own templates and reports, see the
Template Editor Help, and Reports and Templates (page 311).

Cloning templates for drawings

You should consider cloning drawings when:
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• There are several similar parts, assemblies, or cast units in the model.

• You need to produce single-part, assembly, or cast-unit drawings of similar
parts, assemblies, or cast units.

• The drawings need a lot of manual editing.

For example, you can create a drawing for one truss, edit the drawing, and
then clone it for similar trusses. Then you only need to modify the cloned
drawings where the trusses differ.

The cloned drawing may contain more parts than the original drawing. Part
properties, marks, associative notes and related text objects are cloned from a
similar part in the original drawing.

Clone templates in Master Drawing Catalog

You can clone drawings by using the Master Drawing Catalog templates. A
cloning template in the Master Drawing Catalog can also be used in other
models. They can be used in projects that have the same kind of drawings.

To create cloning templates:

1. Select a drawing in the Drawing List.

2. Right-click and select Add to Master Drawing Catalog, and then fill in the
required properties.

The cloning template can be found under Cloning templates in the Master
Drawing Catalog. To use cloning templates in other models, open the Master

Drawing Catalog in the model, click the  button on the toolbar, and add
the model where the templates are saved.

For more information on the Master Drawing Catalog and cloning templates,
see Create drawings in Master Drawing Catalog.

Project settings

Create your own component folder

Usually, only a few different connections and components are used in a
project. To ensure that everyone in the project uses the same components and
finds the components faster, we recommend that you create a component
folder of your own.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Create a new group for the project: Right-click in the catalog and select
New group.

3. Add components to the group: Select the components in the catalog,
right-click and select Add to group. Then select the group to which the
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components are added. You can also drag the selected components to
another group.

4. Hide the groups that you do not need: Select the group, right-click and
select Hide/Unhide.

TIP In the Applications & components catalog, use the commands in

Access advanced features  > Catalog management to modify
catalog definitions. For more information, see Applications &
components catalog for administrators and
XS_COMPONENT_CATALOG_ALLOW_SYSTEM_EDIT.

For more information on the Applications & components catalog, see
How to use the Applications & components catalog.

Define project properties

Project information is needed many times during a project. Define the project
information at the beginning of a project to make reports and drawings display
the correct information automatically. You can also update the project
properties during the project.

1. On the File menu, click Project properties.

2. Select Edit.

3. Define the project properties and click Apply to save your changes.

Create and modify templates and reports

You can modify existing reports and templates, or create your own templates
(page 311) by using Template Editor. To open Template Editor, click File -->
Editors --> Template editor, or double-click an existing table in an open
drawing to open the tool. For more information, see Template Editor User's
Guide.

Note that if your templates are located in a protected folder, the templates are
read-only, and you cannot save a modified template in a protected folder. In
this case, run Tekla Structures as an administrator.

Set up printers

Tekla Structures uses Windows drivers to write the print data directly to the
Windows print device interface. You can print drawings as PDF files, save them
as plot files ( .plt ) for printing with printer/plotter, or print them on a
selected printer. To print to several paper sizes, you need to modify the
drawingsizes.dat file, see more in Configuration files used in printing. You
can also change the line width of the printed drawings, see more in Print to
a .pdf file, plot file (.plt) or printer and Line thickness in drawings.

You can affect the way Tekla Structures automatically names the .pdf files and
plot files by using certain drawing-type-specific advanced options, see more in
Customize print output file names.
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4.3 Distribute custom ribbons using a firm or
environment folder
You can distribute customized ribbon files to other users in the company by
placing the ribbon files in a firm or environment folder (not in the project
folder). For example, the administrator can create company ribbons and save
them in the firm folder. These ribbons will be displayed in the Tekla Structures
user interface for all users who use the same firm folder.

Add ribbons to the firm or environment folder
1. In the customization tool, create the modeling and drawing ribbons that

you want to share. 

The ribbons are saved in the ..\Users\<user>\AppData\Local
\Trimble\TeklaStructures\<version>\UI\Ribbons folder.

2. Copy the entire \Ribbons folder either to your company's firm folder or
to the \system folder, which is located under the environment folder: ..
\ProgramData\Tekla Structures\<version>\Environments
\<environment>\system.

3. If the ribbon contains user-defined commands, create a subfolder named
\Commands on the same level as the \Ribbons folder, and copy the
UserDefined.xml file from the ..\Users\<user>\AppData\Local
\Trimble\TeklaStructures\<version>\UI\Commands folder to the
\Commands folder you just created.

4. Restart Tekla Structures.

Loading order of custom ribbons
Tekla Structures loads the ribbons in the following order:

1. Tekla Structures default ribbon

2. Company ribbons in the environment folders

3. Company ribbons in the firm folder

4. User-defined ribbons under %localappdata%
Note that the ribbons which are loaded later will override previously loaded
ribbons that have the same configuration + editing mode combination. For
example, a ribbon defined in the firm folder will take precedence over the
ribbons in the environment folders.

If you have a customized ribbon in the ..\Users\<user>\AppData\Local
\Trimble\TeklaStructures\<version>\UI\Ribbons folder, it will take
precedence over company ribbons. To override this, open the ribbon
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customization tool and click Reset to defaults. The ribbon in the environment
or firm folder will now be used. Alternatively, you can remove or rename your
own customized ribbons.

Naming convention for ribbon files
The customization tool saves the custom ribbons as .xml files. The naming
convention for these files is:

<Tekla-Structures-configuration_identifier>--<Tekla-
Structures-editing-mode>.xml
The name consists of an internal configuration name, a separator of two dash
characters (--), an internal editing mode name, and the file name
extension .xml. For example, the Full license modeling ribbon is called
albl_up_Full--main_menu.xml.

Configuration identifier Name
albl_up_Construction_Modeling Construction Modeling
albl_up_Developer Developer
albl_up_Drafter Drafter
albl_up_Educational Educational
albl_up_Engineering Engineering
albl_up_Full Full
albl_up_PC_Detailing Precast Concrete Detailing
albl_up_Rebar_Detailing Rebar Detailing
albl_up_Steel_Detailing Steel Detailing
albl_up_Tekla_Structures_Prim
ary

Primary

albl_up_Viewer Project Viewer

Editing mode Purpose
main_menu Modeling ribbon
edit_draw_menu Drawing ribbon
plan_main_menu Importing ribbon

4.4 Distribute custom tabs using a firm or environment
folder
As an alternative to customized ribbon files, which override the existing
ribbon, you can import external custom tabs to the ribbon. The custom tabs
are automatically appended to the end of the ribbon for all users who use the
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same firm or environment folder. This means that an administrator can
distribute customizations to all users in the company while still allowing
individual users to customize their ribbons as well.

Note that these custom tabs do not appear in the customization tool, so the
users are not able to edit them. If the administrator has updated the contents
of a custom tab, the users will receive an update when they restart Tekla
Structures. Tabs are not configuration specific, so they are imported regardless
of the user's Tekla Structures license. If the tab contains commands that are
not available in the user's configuration, they will appear dimmed on the
ribbon.

1. Create the following folder structure in your company's firm folder or in
the \system folder, which is located under your environment folder: ..
\ProgramData\Tekla Structures\<version>\Environments
\<environment>\system. 

2. In the ribbon customization tool, create a custom tab and add some
commands to it.

3. Save the ribbon.

4. Go to the ..\Users\<user>\AppData\Local\Trimble
\TeklaStructures\<version>\UI\Ribbons folder.

5. In a text editor, open the ribbon file which contains the tab you wish to
share with other users.

6. Remove all the other content from the ribbon file except the first row and
the description of the tab you wish to share. 

For example:

<Tab Header="My Tab" IsCollapsed="false" IsUserDefined="true">
    <SimpleButton X="0" Y="0" Width="3" Height="4" 
Command="Common.Interrupt" Text="command:ShortText" 
Icon="command:BigIcon" ShowText="true" ShowIcon="true" />
  </Tab>
7. Save the file with a new name in the ..\CustomTabs\Modeling or ..

\CustomTabs\Drawing folder. 

Tab files have the file name extension *.xml. We recommend that you
use the same name as for the tab. For example, MyTab.xml. The file
name is not case sensitive.

The tab will be added to either the modeling or drawing mode ribbons,
depending on the folder it is located in. Note that there can be several
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custom tab files in the same folder. They are added to the ribbon one
after the other. Note that if the same tab file exists in both the
environment and firm folders, the firm version overrides the environment
version.

NOTE To avoid file name conflicts, we recommend that administrators
prefix all custom tab files with the company name, and that
extension developers prefix all custom tab files with the name of
the extension (for example, MyExtension_TabName.xml).

8. If the tab contains user-defined commands, copy the UserDefined.xml
file from the ..\Users\<user>\AppData\Local\Trimble
\TeklaStructures\<version>\UI\Commands folder to the \Commands
folder created in step 1.

9. Restart Tekla Structures. 

The custom tab now appears at the end of the ribbon.

4.5 Distribute customized property pane layouts using a
project, firm, or environment folder
Company administrators can distribute the customized property pane layouts
to other users in the company by placing the property pane layout file
PropertyTemplates.xml in a folder called PropertyRepository
\Templates in a project, firm, or environment folder. For example, company
administrators can create company property pane layouts and save them in
the firm folder. These property panes are available in the Tekla Structures user
interface for all users who use the same firm folder.

NOTE If you use a firm folder to distribute the PropertyTemplates.xml file, you
need to set the firm folder path in an .ini file. If you set the firm folder path
in the advanced option XS_FIRM, the PropertyTemplates.xml file does not
work correctly.

Add a property pane layout file to a project, firm, or
environment folder
1. In the customization tool, create the property pane layouts that you want

to share. 

The property pane layouts are saved in the PropertyTemplates.xml
file, in the ..\Users\<user>\AppData\Local\Trimble
\TeklaStructures\<version>\UI\PropertyTemplates folder.
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2. Create a folder called PropertyRepository\Templates either in your
company's project folder, firm folder, or in the \system folder, which is
located under the environment folder: ..\ProgramData\Tekla
Structures\<version>\Environments\<environment>\system.

3. Copy the PropertyTemplates.xml file to the PropertyRepository
\Templates folder. 

For example: ..\ProgramData\Tekla Structures\<version>
\Environments\<environment>\system\PropertyRepository
\Templates\PropertyTemplates.xml.

4. Restart Tekla Structures.

Search order of the customized property pane layout files
The PropertyTemplates.xml file contains all the property pane layouts for
different object types. Note that the property pane layouts for different object
types are treated separately. For example, Tekla Structures can read the
property pane layout for steel beam from a different location than the
property pane layout for steel column.

If different object types are defined in different folder locations, the definitions
are combined. If the same object type is defined differently in different folder
locations, the definition that is higher in the search order is used.

The property pane layout in the ..\Users\<user>\AppData\Local
\Trimble\TeklaStructures\<version>\UI\PropertyTemplates\ folder
has the highest priority, and after that Tekla Structures uses the default search
order.

4.6 Customize the material catalog
The material catalog contains information on material types and grades. In the
material catalog, materials are displayed in a hierarchical tree grouped
according to their types. Each material type has material grades listed under
them.

The following material types are available in Tekla Structures:

• Steel

• Concrete

• Reinforcing bar

• Timber

• Miscellaneous

Create and distribute customized configurations 138 Customize the material catalog



By default, the material catalog contains standard, environment-specific
materials. You can add, modify, and delete material grades.

Tekla Structures stores the material information in the matdb.bin file.

See also

Important buttons in the material catalog (page 139)

Add a material grade (page 140)

Copy a material grade (page 140)

Modify a material grade (page 141)

Delete a material grade (page 142)

Add user attributes to material grades (page 142)

Create user-defined material definitions (page 143)

Import and export material grades (page 144)

Important buttons in the material catalog
When you work with the material grades, note the usage of the following
buttons in the Modify Material Catalog dialog box:

Button Description
Saves the changes of a single edited material grade to the
computer’s memory until you click OK.
Saves the changes in the model folder.

Tekla Structures saves the modified catalog on the hard disk when
you click OK to close the dialog box and then click OK in the Save
confirmation dialog box.
Closes the Modify Material Catalog dialog box without saving the
changes.

Note that all changes made to the catalog will be lost even if you
have clicked Update, because the changes have not been saved on
the hard disk. The changes made to the catalog are visible during
one session, because the catalog is using the computer’s memory.
When you start Tekla Structures the next time, the previous data is
restored from the hard disk.

Tekla Structures stores the material information in the matdb.bin file. When
you first open a model, Tekla Structures reads the data from the hard disk and
stores it in the computer’s memory.

When you select a material, Tekla Structures reads the data from the
computer’s memory and displays it in the Modify Material Catalog dialog
box. This is faster than accessing the data from the hard disk.
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See also

Customize the material catalog (page 138)

Add a material grade
1. On the File menu, click Catalogs --> Material catalog to open the Modify

Material Catalog dialog box.

2. Select a material type, for example, steel.

3. Right-click and select Add Grade. 

A new material grade is added under to the material type you selected.

4. Change the material grade name by clicking the grade and entering a new
name for it.

5. Enter the material grade properties.

6. Click OK to save the material grade and close the Modify Material
Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.

See also

Copy a material grade (page 140)

Modify a material grade (page 141)

Delete a material grade (page 142)

Import and export material grades (page 144)

Copy a material grade
You can add new material grades by modifying a copy of an existing, similar
material grade.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Select a material grade that is similar to the one you wish to create.

3. Right-click and select Copy Grade. 

A copy of the material grade with the name COPY is added to the material
tree.

4. Change the material grade name by clicking the grade and entering a new
name for it.

5. Modify the material grade properties.
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6. Click OK to save the material grade and close the Modify Material
Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.

See also

Add a material grade (page 140)

Modify a material grade (page 141)

Delete a material grade (page 142)

Modify a material grade
You can modify existing material grades using the material catalog.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Select a material grade in the tree and modify its properties. 

• Use the General tab for entering three alternative names for the
material. The names are usually the material names used in different
countries or standards. The tab also contains the profile and plate
density values.

• Use the Analysis tab for entering information on the properties used
in structural analysis.

• Use the Design tab for entering information on the design-specific
properties, such as strengths and partial safety factors.

• Use the User attributes tab for creating your own attributes for
material grades.

For example, you can define a paint layer thickness, or the maximum
grain size of concrete using a user-defined attribute.

3. When you have finished modifying the material grade, click Update.

4. Click OK to close the Modify Material Catalog dialog box. 

Tekla Structures asks if you want to save the changes to the model folder.

5. Click OK in the Save confirmation dialog box to save the changes. 

The modified material catalog is saved in the current model folder and is
available only for that model. To make the modified catalog available for
all the other models, use export and import.

See also

Add a material grade (page 140)

Copy a material grade (page 140)
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Delete a material grade (page 142)

Delete a material grade
1. On the File menu, click Catalogs --> Material catalog to open the Modify

Material Catalog dialog box.

2. Select the material grade that you want to delete.

3. Right-click and select Delete Grade.

4. Click OK to close the Modify Material Catalog dialog box.

5. Click OK in the Save confirmation dialog box to save the changes.

See also

Add a material grade (page 140)

Copy a material grade (page 140)

Modify a material grade (page 141)

Add user attributes to material grades
You can add user attributes and their values to the material grades. The user
attributes can then be used, for example, in filtering.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. On the User attributes tab, click Definitions to open the Modify
Material Properties dialog box.

3. Click Add to add a new row.

4. To define a user attribute, click each item on a row.

a. In the Category list, select a material category to which the user
attribute is applied.

b. In the Design code list, select a design code to which the attribute is
added.

c. In the Material type list, select a material type for the attribute.

d. In the Quantity type list, select the type of information that the user
attribute contains, for example, weight, area, ratio, or string.

e. In the Order column, define the order in which the user attributes are
shown in the dialog box. Smaller values are shown first.

f. In the Property name column, define a name for the property. 

The name is saved in the catalog and can be used in reports and
templates. When Property name is used in a template, 
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MATERIAL.PROPERTY_NAME indicates where the property name
appears.

g. In the Label column, define a label for the attribute.

5. Click Update.

6. Click OK to close the Modify Material Properties dialog box.

See also

Modify a material grade (page 141)

Create user-defined material definitions
You can replace the existing material definitions with your own definitions and
use them, for example, in drawing part marks. Material definitions can contain
text, numbers and symbols.

1. Save the symbol file user_material_symbols.sym in the symbol folder
(usually the folder ..\ProgramData\Tekla Structures\<version>
\environments\common\symbols\).

2. Create a text file that contains your material definitions. 

Create the file using a text editor, for example Microsoft Notepad.

Each row in the file defines a material. Use the following syntax: 
material_name symbol_file_name@n, where

• material_name is the name of the material used in the material
catalog

• symbol_file_name is the symbol file name to be used

• n is the number of the symbol.

For example:

WARNING The order of material names in the definition file is relevant
to the conversion. Materials with more specific names need
to be listed before the ones with similar, but simpler names,
for example, S235JRG1 must be listed before S235JR.
Otherwise they both get the same symbol.
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3. Save the file for example with the name
user_material_definitions.txt. 

All the named materials in the material catalog will be replaced with the
ones defined in this file.

4. Set the name of the file as a value for the advanced option 
XS_MATERIAL_SYMBOL_REPRESENTATION_FILE in File menu -->
Settings --> Advanced options --> Drawing Properties as follows: 

set
XS_MATERIAL_SYMBOL_REPRESENTATION_FILE=user_material_defi
nitions.txt
You can also enter a full path to the material definition file. Without the
path Tekla Structures searches for the file in the model, firm, project, and
system folders.

See also

Customize the material catalog (page 138)

Import and export material grades
Use importing and exporting for merging material catalogs. Material catalogs
are imported and exported as .lis files.

Importing and exporting is useful when you:

• upgrade to a newer version of Tekla Structures and want to use a
customized material catalog from a previous version

• want to combine material catalogs that are stored in different locations

• want to share material catalog information with other users

• want to combine material catalogs across different environments.

TIP You can also download or share material grades using Tekla Warehouse.

See also

Import a material catalog (page 144)

Export an entire material catalog (page 145)

Export a part of the material catalog (page 146)

Units used in import and export (page 159)
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Import a material catalog
Material catalogs are imported to Tekla Structures models as .lis files. You
can move an exported .lis file to any model folder and import it to an
existing material catalog.

1. Open the model to which you want to import a material catalog.

2. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

3. Click Import.

4. Browse for the folder that contains the import file, and select the file.

5. Click OK. 

If a material with a same name as the material being imported already
exists, the Import confirmation dialog box appears and you have three
options:

• Replace: The existing material is replaced with the imported material.

• Merge: Material properties that are different in the import file are
added to the existing material. All the other properties remain
unchanged.

Use this option to import only certain elements of the material catalog,
such as user attributes.

• Leave: The existing material is not replaced and the material
definitions in the import file are ignored.

If you select the Apply for all check box, Tekla Structures uses the same
option (Replace, Merge, or Leave) for all the existing materials that have
the same name as the one being imported.

If a user attribute with a different definition already exists, you are
prompted to Replace or Leave the existing attribute.

6. Click OK to close the Modify Material Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.

See also

Export an entire material catalog (page 145)

Export a part of the material catalog (page 146)

Units used in import and export (page 159)

Export an entire material catalog
Exporting and importing are used to merge material catalogs. Material
catalogs are exported from Tekla Structures models as .lis files. Note that
the Export command exports the entire catalog.
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1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Click Export.

3. Browse for the folder where you want to save the exported file. 

By default, the file is saved to the current model folder.

4. Enter a name for the file and click OK.

5. Click OK to close the Modify Material Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

See also

Import a material catalog (page 144)

Units used in import and export (page 159)

Export a part of the material catalog
If you do not want to export the whole material catalog, you can export a
branch of the material tree, meaning all the material grades grouped under
one material type, or a single material grade. Material catalogs are exported
from Tekla Structures models as .lis files.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Select material grades to be exported. 

• To export a branch of the material tree, right-click the branch and
select Export Grades.

• To export a single material grade, right-click the material grade and
select Export Grade.

3. Browse for the folder where you want to save the export files. 

By default, the file is saved to the current model folder.

4. Enter a name for the file and click OK.

5. Click OK to close the Modify Material Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

See also

Export an entire material catalog (page 145)

Import a material catalog (page 144)

Units used in import and export (page 159)
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4.7 Customize the profile catalog
The profile catalog contains information on profiles, their rules and types, and
the analysis and design properties of the profiles. Profiles are displayed in a
hierarchical tree grouped according to rules.

By default, the profile catalog contains standard, environment-specific profiles
and generic parametric profiles. You can add, modify, import, export, and
delete profiles.

You can define your own user-defined profiles, which can be either fixed or
parametric. Use the profile catalog to create new fixed profiles, either from
scratch or by copying an existing one. Use the sketch editor or .clb files to
create new parametric profiles.

Tekla Structures stores the profile catalog information in the profdb.bin file.

See also

Important buttons in the profile catalog (page 147)

Group profiles together (page 148)

Add user attributes to profiles (page 150)

Associate profile types with a certain material (page 153)

Delete a profile from the profile catalog (page 154)

Import and export profiles (page 155)

Create your own profiles (page 162)

Define standardized values for parametric profiles (page 199)

Create an image of a profile (page 199)

Customize the shape catalog (page 200)

Important buttons in the profile catalog
When you work with the profiles, note the usage of the following buttons in
the Modify Profile Catalog dialog box:

Button Description
Saves the changes of a single edited profile to the computer’s
memory until you click OK.
Saves the changes in the model folder.

Tekla Structures saves the modified catalog on the hard disk when
you click OK to close the dialog box and then click OK in the Save
confirmation dialog box.
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Button Description
Closes the Modify Profile Catalog dialog box without saving the
changes.

Note that all changes made to the catalog will be lost even if you
have clicked Update, because the changes have not been saved on
the hard disk. The changes made to the catalog are visible during
one session, because the catalog is using the computer’s memory.
When you start Tekla Structures the next time, the previous data is
restored from the hard disk.

Tekla Structures stores the information of fixed profiles in the profdb.bin
file. When you first open a model, Tekla Structures reads the data from the
hard disk and stores it in the computer’s memory.

When you select a profile, Tekla Structures reads the data from the computer’s
memory and displays it in the Modify Profile Catalog dialog box. This is faster
than accessing the data from the hard disk.

See also

Customize the profile catalog (page 146)

Group profiles together
In the profile catalog, the profiles are displayed in a hierarchical tree and they
are grouped according to rules , such as the profile type (for example, I
profiles) and the profile subtype (for example, HEA). To change how the
profiles are grouped in the profile tree, you need to modify the rules.

The order in which you create the rules does not matter, only the location of
the rules in the profile tree.

Tekla Structures reads the rules from top to bottom in the profile tree. Profiles
are in the highest group where they meet the criteria defined in the rule. For
example, a rule that collects All profiles overrides all rules that are below it in
the profile tree.

See also

Add a rule to the profile catalog (page 148)

Modify a rule in the profile catalog (page 149)

Add a rule to the profile catalog
1. On the File menu, click Catalogs --> Profile catalog to open the Modify

Profile Catalog dialog box.
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2. Right-click any existing rule and select Add Rule. 

The Profile manager rules dialog box appears.

3. Define the rule properties.

a. Enter a rule name in the Rule name box.

b. Select the Profile type to which the rule is applied.

c. Enter the Name filter string that defines the new rule. 

By default, the wildcard symbol (*) is entered, meaning “all entries”.

For example, to group all catalog entries with names beginning with
A, enter A* in the Name filter string box, or to group all catalog
entries with names containing 100, enter *100*. Tekla Structures
groups the catalog entries that meet your criteria under the new rule.

4. Click OK to close the Profile manager rules dialog box.

5. Click OK to close the Modify Profile Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes. 

TIP You can add a next level rule that creates a subgroup under an
existing rule. Use the Add Next Level Rule command to add the
next level rule.

See also

Modify a rule in the profile catalog (page 149)

Modify a rule in the profile catalog
1. On the File menu, click Catalogs --> Profile catalog to open the Modify

Profile Catalog dialog box.

2. Right-click any existing rule and select Edit Rule. 

The Profile manager rules dialog box appears.

3. Modify the rule properties.

4. Click OK to close the Profile manager rules dialog box.

5. Click OK to close the Modify Profile Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

Profiles in the profile tree are listed in an alphabetical order, and rules are
listed in the order you specify. To change the order in which the rules appear,
use the Move up and Move down commands.

TIP If you want to delete a rule, right-click an existing rule and select Delete Rule.
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See also

Add a rule to the profile catalog (page 148)

Add user attributes to profiles
You can add your own attributes to profiles. For example, you can specify paint
layer thickness, define the maximum grain size of concrete, sort out different
profile types by material, or create profile aliases for converting imperial
profiles to metric and vice versa.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. On the User attributes tab, click Definitions. 

The Modify Profile Properties dialog box appears.

3. Click Add to add a new row.

4. To define a user attribute, click each item on a row.

a. In the Profile type list, select a profile type to which the user attribute
is applied.

b. In the Quantity type list, select the type of information that the user
attribute contains, for example, weight, area, ratio, or string.

c. In the Order list, define the order in which the user attributes are
shown in the dialog box. Larger values are shown first.

d. In the Property name list, define a name for the property. 

The name is saved in the catalog and can be used in reports and
templates. When Property name is used in a template, 
PROFILE.PROPERTY_NAME indicates where the property name
appears. For example, PAINT_LAYER_THICKNESS.

e. In the Symbol column, define an abbreviation that can be used for
the property, such as Ix or ct.

f. In the Label column, define a label for the attribute.

5. Click Update.

6. Click OK to close the Modify Profile Properties dialog box.

See also

Example: Add a user attribute to a profile and use it in a rule (page 150)
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Example: Add a user attribute to a profile and use it in a rule
You can add your own attributes and their values to profiles. The user
attributes can then be used, for example, in profile filtering.

In this example, you will add a user attribute for I profiles’ rule.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. On the User attributes tab, click Definitions. 

The Modify Profile Properties dialog box appears.

3. Click Add to add a new row.

4. Select the row that was created and modify the properties as follows: 

• Set Profile type to I profiles.

• Set Quantity type to String.

• Set Property name to HISTORICAL_PROFILE.

• Set Symbol to Hist.

• Set Label to Historical profile.

5. Click Update and OK.

6. In the profile tree, select I profiles and then HEA.

7. Right-click and select Add Next Level Rule.

8. In the Profile manager rules dialog box, set the rule properties as
follows: 

• Set Rule name to Historical profiles.

• In Profile type, clear the All profiles check box and select the I
profiles check box.

• Enter HEA* in the Name filter string box.
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• Set User attribute to HISTORICAL_PROFILE and Equals, and enter
Yes in the box next to the two other boxes.

9. Click OK. 

Historical profiles appears in the profile tree.

10. Select the required historical profile, for example HEA120, in the profile
tree.

11. Go to the User attributes tab and set Value of Historical profile to Yes. 

12. Click Update.

13. Repeat the steps 10 and 11 for any other required profiles.
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14. Click OK to close the Modify Profile Catalog dialog box.

15. Click OK in the Save confirmation dialog box to save the changes.

Next time you open the profile catalog, the profiles appear under Historical
profiles in the profile tree.

See also

Add user attributes to profiles (page 150)

Add a rule to the profile catalog (page 148)

Associate profile types with a certain material
You can define which profiles are available for steel parts, concrete parts, or
both. This affects which profile types are shown in the Select Profile dialog
box when you change the material of a part.

To define the material of a profile type:

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a profile type, for example, L profiles.

3. To associate the profiles with steel, right-click and select Material -->
Steel . 
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A check mark next to Steel indicates that the profiles are available for
steel parts.

4. To make the selected profiles available also for concrete parts, right-click
and select Material --> Concrete . 

If needed, you can remove the check mark by clicking the material again.

5. Click OK to close the Modify Profile Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

Delete a profile from the profile catalog
1. On the File menu, click Catalogs --> Profile catalog to open the Modify

Profile Catalog dialog box.

2. Select the profile that you want to delete.

3. Right-click and select Delete Profile.

4. Click OK to close the Modify Profile Catalog dialog box.

5. Click OK in the Save confirmation dialog box to save the changes.

Tekla Structures will continue showing parts in model views using the deleted
profiles until you modify the parts or reopen the model. After that, the parts
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having profiles that are not available in the profile catalog, are shown as sticks
without a profile.

See also

Customize the profile catalog (page 146)

Import and export profiles
Use importing and exporting for merging profiles across profile catalogs.
Profile catalogs are imported and exported as .lis files, sketched profiles
as .uel files, and user-defined parametric profiles as .clb files.

When you export an entire profile catalog, Tekla Structures creates three
separate files: profiles.clb, profiles.lis and rules.lis. The .clb file
contains parametric profile definitions, if they are used in the profiles in the
catalog, otherwise it is empty. The profiles.lis file includes the actual
profile definitions and the rules.lis file the branch rules. When you export a
branch of a profile catalog, the branch name is attached as prefix to the file
names.

Importing and exporting is useful when you:

• upgrade to a newer version of Tekla Structures and want to use a
customized profile catalog from a previous version

• want to combine profile catalogs that are stored in different locations

• want to share profile catalog information with other users

• want to combine profile catalogs across different environments.

Limitations

• You cannot import or export hard-coded profiles such as PROFILE_ZZ,
PROFILE_CC, and PROFILE_CW.

• You cannot import profiles that do not have a defined cross section.

• If you have used a sketched profile or a user-defined parametric profile as
the cross section for a fixed profile, you also need to import the sketched
profile or the user-defined parametric profile to the new model.

TIP You can also download or share profiles using Tekla Warehouse.

See also

Export an entire profile catalog (page 157)

Export a part of the profile catalog (page 157)

Import profile catalog items (page 156)

Import and export sketched profiles (page 161)
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Import profile catalog items
Tekla Structures has five types of profile catalog items: fixed profiles, hard-
coded parametric profiles, sketched profiles, user-defined parametric profiles,
and rule sets. Profiles and rule sets are imported to Tekla Structures models
as .lis files, sketched profiles as .uel files, and user-defined parametric
profiles as .clb files.

If you are importing an entire profile catalog or a branch, we recommend that
you save the related files in a separate folder. This makes the import process
faster.

1. Open the model to which you want to import profile catalog items.

2. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

3. Click Import to import a single file, or Import Directory to import the
contents of a file folder.

4. Select the import file or the import folder.

5. Click OK. 

If a profile item with the same name as the profile item being imported
already exists, the Review import items dialog box appears, and you
have four options:

• Leave: The existing profile item is not replaced and the profile
definitions in the import file are ignored.

• Merge: Profile properties that are different in the import file are added
to the existing profile. All the other properties remain unchanged.

Use this option to import only certain elements of the profile catalog,
such as user attributes.

• Replace: The existing profile item is replaced with the imported profile
item.

• Continue: The dialog box closes and the actions you selected take
place. If an import item has Unknown as the action, it is not imported.

You can select more than one profile item at a time by using the Shift and
Ctrl keys.

NOTE Each cross section definition has a unique name and ID number.
If, during an import, a cross section with the same name but
different properties is found in the existing profile catalog, the
cross section being imported is renamed by adding an
incremental number at the end of the existing name.

6. Click OK to close the Modify Profile Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.
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See also

Import and export profiles (page 155)

Export an entire profile catalog (page 157)

Export a part of the profile catalog (page 157)

Import sketched profiles (page 161)

Units used in import and export (page 159)

Export an entire profile catalog
Profile catalogs are exported from Tekla Structures models as .lis, .uel,
and .clb files.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Click Export.

3. Browse for the folder where you want to save the export files. 

By default, the files are saved to the current model folder. For faster
profile catalog import, we recommend that you create a separate
subfolder for the catalog files.

4. Click OK to close the Modify Profile Catalog dialog box.

See also

Import and export profiles (page 155)

Export a part of the profile catalog (page 157)

Example of profile export file (page 158)

Import profile catalog items (page 156)

Units used in import and export (page 159)

Export a part of the profile catalog
If you do not want to export an entire profile catalog, you can export a branch
of the profile tree, meaning all the profiles grouped under one rule, or a single
profile. Profiles and rule sets are exported from Tekla Structures models
as .lis files, sketched profiles as .uel files, and user-defined parametric
profiles as .clb files.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select profiles to be exported. 

• To export a branch of the profile tree, right-click the branch and select
Export Profiles.
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• To export a single profile, right-click the profile and select Export
Profile.

3. Browse for the folder where you want to save the export files. 

By default, the files are saved to the current model folder.

If you are exporting a single profile, enter a name for the file.

4. Click OK.

5. Click OK to close the Modify Profile Catalog dialog box.

See also

Export an entire profile catalog (page 157)

Example of profile export file (page 158)

Import profile catalog items (page 156)

Units used in import and export (page 159)

Example of profile export file

The export .lis file is divided into specific sections.

The first row in the file is PROFILE CATALOG EXPORT VERSION = n, where n
is the version number.

WARNING Do not delete this row. If the row does not appear in the file, the
import is canceled.

The next section defines the hierarchical tree structure that is used to display
the contents of the catalog.

The next section contains the profiles.

Fixed profiles

Fixed user-defined profiles

Fixed user-defined profiles can have more than one cross section. The profile
type for fixed user-defined profiles is 998. SUB_TYPE refers to the name of the
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cross section definition. When importing fixed user-defined profiles, the
relevant cross section definitions must be in the same import file as the
profile.

Cross section definitions

See also

Export an entire profile catalog (page 157)

Export a part of the profile catalog (page 157)

Units used in import and export

The table below lists the units Tekla Structures uses when importing and
exporting profile catalogs and material catalogs.

Type Unit (if blank, no unit)
Boolean  
Integer  
String  
Ratio  
Strain  
Angle degree
Length mm
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Type Unit (if blank, no unit)
Deformation mm
Dimension mm
Radius of inertia mm
Area mm2

Reinforcement area mm2

Transverse reinforcement area mm2/m
Area/unit length mm2/m
Volume mm3

Section modulus mm3

Moment of inertia mm4

Torsion constant mm4

Warping constant mm6

Force N
Weight kg
Distributed load N/m
Spring constant N/m
Mass/length kg/m
Surface load N/m2

Strength N/m2

Stress N/m2

Modulus N/m2

Density kg/m3

Moment Nm
Distributed moment Nm/m
Rotation spring constant Nm/rad
Temperature K (oC)
Thermal dilation coefficient 1/K (1/oC)
Factor  

See also

Import profile catalog items (page 156)

Import a material catalog (page 144)

Export an entire profile catalog (page 157)

Export an entire material catalog (page 145)
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Import and export sketched profiles
To use a sketched profile in other Tekla Structures models, you have to export
the profile to a file (*.uel), and then import the file into another Tekla
Structures model.

We recommend that you use the profile catalog to import and export sketched
profiles. You can also use the Applications & components catalog to import
sketched profiles together with related custom components.

See also

Import sketched profiles (page 161)

Export sketched profiles (page 161)

Import sketched profiles
After you have exported sketched profiles to a file, you can import them to
another Tekla Structures model.

1. Open the Tekla Structures model you want to import to.

2. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

3. Click Import.

4. In the Import Profile Catalog dialog box, select *.uel from the Filter list.

5. Select the file to import.

6. Click OK.

7. Click OK to close the Modify Profile Catalog dialog box.

8. Click OK in the Save confirmation dialog box to save the changes.

TIP To automatically import all *.uel files from a folder when creating a new model,
use the advanced option XS_UEL_IMPORT_FOLDER.

See also

Export sketched profiles (page 161)

Export sketched profiles

1. Open the Tekla Structures model you want to export from.

2. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

3. Right-click the profile you want to export and select Export Profile.

4. In the Export Profile Catalog dialog box, enter a name for the export file
in the Selection box.
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5. If you want to save the export file to a specific location, browse for the
folder. 

By default, Tekla Structures saves the export file in the current model
folder.

6. Click OK.

See also

Import sketched profiles (page 161)

Create your own profiles
You can create your own profiles and save them in the profile catalog.

Use any of the following methods to create user-defined profiles in Tekla
Structures:

Profile type Creation methods
Fixed profile • Create user-defined cross sections

(page 162)

• Create a fixed profile (page 168)

• Create a fixed profile by copying (page 170)

• Create a fixed profile based on a
parametric profile (page 171)

Parametric profile •

• Create parametric profiles by sketching
(page 172)

Parametric profile with variable
cross sections

• Create parametric profiles with variable
cross sections (page 195)

Create user-defined cross sections
User-defined cross sections can be used for creating fixed profiles. Define the
needed cross sections before creating the profile.

Use any of the following methods to define a cross section:

• Define a cross section using polygon (page 163)

Use this method to create a cross section with fixed dimensions.

• Define a cross section using a plate (page 164)

Use this method if you have a contour plate in the model.

• Define a cross section using a DWG file (page 166)

Use this method if you have a .dwg file of the profile you want to define.
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See also

Create fixed profiles (page 168)

Define a cross section using polygon
Define a cross section by picking the shape of the cross section.

1. On the File menu, click Catalogs --> Define profiles --> Define cross
section using polygon.

2. Define a cross section without or with inner contours. 

• To create a cross section with no inner contours:

a. Pick the corner points of the cross section to define the shape.
Start at the bottom-right corner and pick the points counter
clockwise.

b. Pick the start point and click the middle mouse button to close the
shape.

c. Pick the center point of the cross section.

TIP To make it easier to define the shape, insert a reference
model of the cross section in the model, and use the
reference model as a basis for picking the cross section
shape.

Alternatively, you can create a few construction lines or
points in the model and use them to define the cross section
shape.

If you do not have any actual points to pick, picking the
center point of the cross section becomes difficult. This is
because the cross section shape disappears after you have
clicked the middle mouse button to close the shape.
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• To create a cross section with inner contours:

a. Pick the corner points of the cross section to define the shape.

b. Pick the start point to close the shape.

c. Pick the corner points of the cross section inner contour.

d. Pick the start point to close the shape

e. Repeat until you have picked all inner contours.

f. Click the middle mouse button.

g. Pick the center point of the cross section.

3. When the User Profile Cross Section dialog box appears, enter a name
for the cross section.

4. Click OK to close the User Profile Cross Section dialog box.

5. Click OK in the Save confirmation dialog box to save the changes. 

You can now use the cross section in the profile catalog to create a new
profile. The Profile type will be User-defined, fixed.

See also

Create a fixed profile (page 168)

Modify a user-defined cross section (page 167)

Define a cross section using a plate (page 164)

Define a cross section using a DWG file (page 166)

Define a cross section using a plate
You can define a cross section using a contour plate.

1. Create a contour plate that includes all the chamfers.
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2. On the File menu, click Catalogs --> Define profiles --> Define cross
section using plate. 

The Profile Cross-Section from Plate (10) dialog box appears.

3. On the Parameters tab, enter a name in the Section name and Profile
name boxes. 

Other properties are optional.

4. Click OK.

5. Select the contour plate. 

Tekla Structures creates the cross section with the shape of the contour
plate.

You can now use the cross section in the profile catalog to create a new
profile. The Profile type will be User-defined, fixed.

See also

Create a fixed profile (page 168)

Properties: Profile cross-section from plate (10) (page 165)

Define a cross section using polygon (page 163)

Define a cross section using a DWG file (page 166)

Properties: Profile cross-section from plate (10)
Use the Parameters tab to define the profile properties in the Profile cross-
section from plate (10) component.

Option Description
Section name Name of the cross section shown in the Modify Profile

Catalog dialog box.

If you leave this box empty, no profile is created.
Profile name Name of the profile shown in the Beam Properties dialog box,

and in the Modify Profile Catalog dialog box.

If you leave this box empty, no profile is created.
Save to The location of the profile catalog.

Select one of the following options:

• Model directory: The current model folder.

• Global directory: ..\ProgramData\Tekla Structures
\<version>\environments\<environment>\profil

• Don’t save: Does not save the profile. This is useful for
testing.
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Option Description
Min distance
between
points

The minimum distance between the corner points of the cross
section.

To create simpler drawings of complicated cross sections,
increase this value.

Center point
offset

The origin of the plate defines the location of the profile
reference line.

Enter an offset value to move the reference line, relative to the
cross section.

See also

Define a cross section using a plate (page 164)

Define a cross section using a DWG file
If a cross section is available in DWG format, you can import the cross section
and add it as a DWG profile to the profile catalog.

Tekla Structures supports DWG files that have been created using version
ACAD2012 or earlier.

Before you start defining a cross section using a DWG file:

• Save the outline of the cross section as a DWG file. Ensure that the DWG file
only contains the outline of the profile.

• Make sure that the cross section is created as a closed polyline.

• Make sure that the outline consists of only one closed polyline. You cannot,
for example, define holes to your cross section with this method. If you
need holes or openings, use the polygon or the plate creation method.

• Remove hatching and unnecessary lines from the DWG file. Tekla
Structures imports all the lines it finds in the DWG file.

• If there are blocks in the DWG file, they must be exploded.

1. Open a model.

2. On the File menu, click Catalogs --> Define profiles --> Define cross
section using DWG file. 

The DWG Profile to Library (6) dialog box appears.

3. Define the cross section properties and click OK.

4. In the model, pick the start and the end points of the cross section to be
imported. 

Tekla Structures imports the cross section and places the profile reference
line at the origin of the DWG file.

You can now use the cross section in the profile catalog to create a new
profile. The Profile type will be User-defined, fixed.
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See also

Create a fixed profile (page 168)

Properties: DWG Profile to Library (6) (page 167)

Define a cross section using polygon (page 163)

Define a cross section using a plate (page 164)

Properties: DWG Profile to Library (6)
Use the Parameters tab to define the profile properties in the DWG profile to
library (6) component.

Option Description
Input file Browse for the DWG file to be imported.
Section name Name of the cross section shown in the Modify Profile

Catalog dialog box.
Profile name Name of the profile shown in the Modify Profile Catalog

dialog box.
Save to The location of the profile catalog.

Select one of the following options:

• Model directory: The current model folder.

• Global directory: ..\ProgramData\Tekla Structures
\<version>\environments\<environment>\profil

• Don’t save: Does not save the profile. This is useful for
testing.

Min distance
between
points

The minimum distance between the corner points of the cross
section.

To create simpler drawings of complicated cross sections,
increase this value.

Center point
offset

The origin of the plate defines the location of the profile
reference line.

Enter an offset value to move the reference line, relative to the
cross section.

See also

Define a cross section using a DWG file (page 166)

Modify a user-defined cross section
You can modify cross sections that have been defined using a polygon, a plate,
or a DWG file.
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1. Go to Quick Launch, start typing edit polygon cross section, and
select the Edit Polygon Cross Section command from the list that
appears. 

The Modify Cross Section dialog box appears.

2. Select the cross section you want to modify.

3. Modify the cross section point properties. 

• Number refers to each point picked when the cross section was
created, in numerical order. The first point picked is 1, the second 2,
and so on.

• Chamfer refers to the chamfer shape.

• x: and y: apply to the chamfer type. For example, if you want the
chamfer to be equal on both sides of the angle, only enter a value for
x:.

For an uneven chamfer, enter values for x: and y:.

4. Click Update.

5. Click OK to close the Modify Cross Section dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

TIP If you want to delete a cross section, select the cross section and click Delete.

See also

Define a cross section using polygon (page 163)

Define a cross section using a plate (page 164)

Define a cross section using a DWG file (page 166)

Create fixed profiles
You can create new fixed profiles either from scratch or by copying an existing
one. You can also convert a parametric profile into a fixed one.

Click the links below to find out more:

Create a fixed profile (page 168)

Create a fixed profile by copying (page 170)

Create a fixed profile based on a parametric profile (page 171)

Modify a fixed profile (page 171)

Create a fixed profile
You can create fixed profiles with a single cross section or with multiple cross
sections. Note that cross sections affect the total weight of the profile.
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WARNING If you create a profile with multiple cross sections, create the
cross sections with the same number of corner points and in the
same order.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Right-click anywhere in the profile tree and select Add Profile. 

A new fixed profile with the name PROFILE1 is created.

3. Change the profile name by entering a new name in the Profile name
box. 

The profile name must be in upper case letters, with no spaces. Tekla
Structures automatically converts lower case letters to upper case letters.

4. In the Profile type list, select User-defined, fixed.

5. In the Profile subtype list, select the cross section you want to use. 

If you have created your own user-defined cross sections (page 162), you
can use one of them.

6. Under Equivalent type, select a profile type that matches the new cross
section as closely as possible. This is important because some
connections only work for certain types of profiles. 

The equivalent type and the profile dimensions, such as height and width,
affect which connections can be applied to the profile. An unsuitable
equivalent type or missing dimension values may result in problems with
connections.

7. Click Update.

8. Modify the dimension values. 

Always enter values for the dimensions Height h and Width b, as these
values affect how Tekla Structures displays the profiles. If the values are 0,
the part is drawn as a line.

9. Under Cross section, define a relative location for each cross section:

a. In the Number list, select the number of the cross section.

b. In the Relative location box, enter the location of the cross section. 

This value indicates the location of the cross section along the axis:
0.0 for the start end and 1.0 for the second end. If you only have a
single cross section, select 1 for Number and enter 0.000 for
Relative location.

c. Click Update after defining each cross section.

10. Click Add to add more cross sections, if needed.

11. If you want to use a different cross section in the profile, select a new one
from the Profile subtype list.
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12. If you want to remove a cross section, select the cross section from the
Number list and click Remove.

13. Click OK to close the Modify Profile Catalog dialog box.

14. Click OK in the Save confirmation dialog box to save the changes.

Example

For a pitched profile, you need two cross sections with the same center point
height. The Relative location value is 0.0 for the first cross section, 0.5 for
the second cross section, and 1.0 for the third cross section.

See also

Create a fixed profile by copying (page 170)

Modify a fixed profile (page 171)

Delete a profile from the profile catalog (page 154)

Create a fixed profile by copying
You can create new fixed profiles by modifying a copy of an existing, similar
profile.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a fixed profile that is similar to the one you wish to create.

3. Right-click and select Copy Profile. 

A new profile with the name <existing_profile_name COPY> is created.

Create and distribute customized configurations 170 Customize the profile catalog



4. Change the profile name by entering a new name in the Profile name
box. 

The profile name must be in upper case letters, with no spaces. Tekla
Structures automatically converts lower case letters to upper case letters.

5. Modify the profile properties on the General, Analysis, and User
attributes tabs. 

WARNING Under Equivalent type, select a profile type that matches
the new cross section as closely as possible. This is important
because some connections only work for certain types of
profiles.

Always enter values for the dimensions Height h and Width
b, as these values affect how Tekla Structures displays the
profiles. If the values are 0, the part is drawn as a line.

The equivalent type and the profile dimensions, such as
height and width, affect which connections can be applied to
the profile. An unsuitable equivalent type or missing
dimension values may result in problems with connections.

6. Click Update.

7. Click OK to close the Modify Profile Catalog dialog box.

8. Click OK in the Save confirmation dialog box to save the changes.

See also

Create a fixed profile (page 168)

Modify a fixed profile (page 171)

Create a fixed profile based on a parametric profile

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a parametric profile from the list.

3. Right-click and select Add Profile. 

A new standard fixed profile is created, and it has the profile values of the
parametric profile.

See also

Create fixed profiles (page 168)
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Modify a fixed profile
If necessary, you can modify existing fixed profiles using the profile catalog.
Note that the fixed profiles conform to industry standards, and you should not
modify them unless you are an administrator.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a fixed profile  in the tree and modify its properties. 

• The General tab contains information on profile types and
dimensions.

• The Analysis tab contains information on the properties used in
structural analysis. The structure can be analyzed with different
analysis software.

• The User attributes tab is for viewing or entering user attributes for
profiles.

3. When you have finished modifying the profile, click Update.

4. Click OK to close the Modify Profile Catalog dialog box. 

Tekla Structures asks if you want to save the changes to the model folder.

5. Click OK in the Save confirmation dialog box to save the changes.

See also

Create a fixed profile (page 168)

Create a fixed profile by copying (page 170)

Create parametric profiles by sketching
This section explains how to create parametric user-defined profiles by
sketching. You can change the dimensions of parametric profiles each time
you use them in a model.

Click the links below to find out more:

Open the sketch editor (page 173)

Sketch the outline of a profile (page 175)

Refine the shape of a sketched profile (page 177)

Add dimensions to a sketched profile (page 182)

Define positioning planes for a sketched profile (page 186)

Check a sketched profile (page 191)

Save a sketched profile (page 191)

Modify a sketched cross section (page 192)
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Use sketched profiles in a model (page 195)

(page 0 )

Open the sketch editor
Use the sketch editor to create and modify sketched profiles.

1. Open a Tekla Structures model.

2. On the File menu, click Editors --> Define cross section in sketch editor.

Tekla Structures opens the sketch editor, the Sketch Browser, and the
Variables dialog box.

When you first open the sketch editor, the view is empty. The grid
coordinates and labels that you see in the sketch editor depend on the
grid properties of your actual Tekla Structures model.

See also

Sketch Browser (page 174)
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Variables in sketched profiles (page 175)

Sketch Browser
The Sketch Browser shows the objects (lines, arcs, circles, constraints,
dimensions, and chamfers) of a sketched profile in a hierarchical, tree-like
structure. The Sketch Browser automatically opens when you open the sketch
editor.

When you click an object in the sketch editor, Tekla Structures highlights the
object in the Sketch Browser, and vice versa.

The Sketch Browser displays the following information about a sketched
profile:

• Extrusion type (0, 1, or 2) and thickness of the sketched profile

• Lines, arcs, and circles

• Constraints

• Distances and dimensions and their values

• Chamfers and their type (0=None, 1=Line ... 7=Line and arc) and
dimensions.

See also

Open the sketch editor (page 173)
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Extrusion types (page 194)

Variables in sketched profiles
Use the Variables dialog box to define the properties of a sketched profile.
Variables can define fixed properties, or they can include formulas, so that
Tekla Structures calculates the property value each time you use the profile in
a model.

The Variables dialog box automatically opens when you open the sketch
editor.

NOTE The Variables dialog box functions the same way as the
corresponding dialog box in the custom component editor. For more
information on how to use variables, see Add variables to a custom
component.

See also

Open the sketch editor (page 173)

Sketch the outline of a profile
When you create a new sketched profile, start by sketching the outline and the
holes of the profile using lines, arcs, and circles.

Ensure that you create a closed shape, unless you are creating a profile of a
consistent thickness, such as a cold-rolled profile.

See also

Sketch a polyline (page 176)

Sketch an arc (page 176)

Sketch a circle (page 177)
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Sketch a polyline
You can create line segments in the sketch editor by picking points. Tekla
Structures automatically creates coincident constraints between the line
segments and displays a chamfer symbol where line segments meet.

1. Open the sketch editor.

2. Click the Sketch polyline button: .

3. Pick points to create each line segment.

4. Click the middle mouse button to create the polyline. 

See also

Sketch the outline of a profile (page 175)

Sketch an arc
You can create an arc in the sketch editor by picking three points.

1. Open the sketch editor.

2. Click the Sketch arc button: .

3. Pick three points to define the arc. 
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TIP You can use the advanced option XS_CS_CHAMFER_DIVIDE_ANGLE to define the
smoothness of the arc.

See also

Sketch the outline of a profile (page 175)

Sketch a circle
You can create a circle in the sketch editor by picking two points.

1. Open the sketch editor.

2. Click the Sketch circle button: .

3. Pick a point to indicate the center of the circle (1).

4. Pick a point to indicate the radius of the circle (2). 

See also

Sketch the outline of a profile (page 175)

Refine the shape of a sketched profile
After you have sketched the outline of a profile, use constraints to refine your
sketch and lock the shape. For example, you can straighten lines, create 90
degree angles, force lines to meet, close the shape, and add chamfers in
corners.

To straighten the entire profile, use horizontal and vertical constraints in
conjunction with other constraints. Although the shape is locked, you can still
rotate the profile in the model.

See also

Add a parallel constraint (page 178)

Add a perpendicular constraint (page 178)
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Add a coincident constraint (page 179)

Add a fixed constraint (page 180)

Add a horizontal constraint (page 180)

Add a vertical constraint (page 181)

Delete a constraint (page 181)

Add a parallel constraint
You can force two lines in a sketched profile to be parallel to each other.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Parallel constraint button: .

2. Select a line in the sketch (1).

3. Select another line in the sketch (2). 

See also

Refine the shape of a sketched profile (page 177)

Add a perpendicular constraint
You can force a line in a sketched profile to be at a 90 degree angle to another
line you select. The lines do not have to intersect.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Perpendicular constraint button: .

2. Select a line in the sketch (1).

3. Select another line in the sketch (2). 
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See also

Refine the shape of a sketched profile (page 177)

Add a coincident constraint
You can force two lines in a sketched profile to start or end at the same point,
by extending or shortening one or both lines. The lines do not have to
intersect.

NOTE Tekla Structures automatically creates coincident constraints:

• Where two lines meet.

• Between line segments when you draw them with the Sketch
polyline tool.

• Between the start of the first line segment and the end of the last
line segment in a shape, if they are within a certain distance of
each other.

Before you start, sketch the outline of the profile in the sketch editor.

1. Ensure that the Snap to end points  snap switch is active.

2. Click the Coincident constraint button: .

3. Pick the end of the first line (1).

4. Pick the end of the second line. (2) 
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See also

Refine the shape of a sketched profile (page 177)

Add a fixed constraint
You can lock the position and angle of a line in a sketched profile so that other
constraints do not affect it.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Fixed constraint button: .

2. Select a line in the sketch.

See also

Refine the shape of a sketched profile (page 177)

Add a horizontal constraint
Use horizontal constraints to force a line in a sketched profile to be parallel to
the local x axis. Tekla Structures automatically creates horizontal constraints
when you create lines that are nearly horizontal.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Horizontal constraint button: .

2. Select the lines you want to straighten (1, 2). 
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See also

Refine the shape of a sketched profile (page 177)

Add a vertical constraint
Use vertical constraints to force a line in a sketched profile to be parallel to the
local y axis. Tekla Structures automatically creates vertical constraints when
you create lines that are nearly vertical.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Vertical constraint button: 

2. Select the lines you want to straighten (1, 2). 

See also

Refine the shape of a sketched profile (page 177)

Delete a constraint
You can delete constraints from sketched profiles.

1. Click  to open the Sketch Browser.

2. Select the constraint you want to delete.

3. Right-click and select Delete.
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4. Click Refresh.

See also

Refine the shape of a sketched profile (page 177)

Add dimensions to a sketched profile
After you have sketched a profile, use dimensions to make different distances
in the profile parametric. You can use these dimensions to define the size of
the profile when you use it in a model.

Tekla Structures also adds the dimensions you create to the list of variables
that you can use in calculations.

NOTE Do not create too many dimensions in a sketch, or the dimensions will not be
able to adjust when the values are changed.

In the following example, if you create the dimension marked in red, the
dimension b1 will no longer work:

See also

Add a radial dimension to a sketch (page 182)

Add an angle dimension to a sketch (page 183)

Add a dimension between two points in a sketch (page 184)

Add a horizontal dimension to a sketch (page 184)

Add a vertical dimension to a sketch (page 185)

Delete a dimension from a sketch (page 185)
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Add a radial dimension to a sketch
You can create a radial dimension for an arc or a circle in a sketched profile.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Sketch radial dimension button: .

2. Select the arc or circle. 

See also

Add dimensions to a sketched profile (page 182)

Add an angle dimension to a sketch
You can create an angle dimension between two lines in a sketched profile.
The angle is calculated counter clockwise from the first line you select.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Sketch angle dimension button: .

2. Select the first line (1).

3. Select the second line (2). 

TIP If you are unable to see the angle symbol, scroll with the mouse
wheel to zoom in.
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See also

Add dimensions to a sketched profile (page 182)

Add a dimension between two points in a sketch
You can add a dimension to a sketched profile, between two points you pick.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Sketch free dimension button: 

2. Pick a point to indicate the start point of the dimension (1).

3. Pick a point to indicate the end point of the dimension (2).

4. Pick a point to indicate the location of the dimension lines and text. 

See also

Add dimensions to a sketched profile (page 182)

Add a horizontal dimension to a sketch
You can add a horizontal dimension to a sketched profile, between two points
you pick.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Sketch horizontal dimension button: .

2. Pick a point to indicate the start point of the dimension (1).

3. Pick a point to indicate the end point of the dimension (2).

4. Pick a point to indicate the location of the dimension lines and text. 
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See also

Add dimensions to a sketched profile (page 182)

Add a vertical dimension to a sketch
You can add a vertical dimension to a sketched profile, between two points
you pick.

Before you start, sketch the outline of the profile in the sketch editor.

1. Click the Sketch vertical dimension button: .

2. Pick a point to indicate the start point of the dimension (1).

3. Pick a point to indicate the end point of the dimension (2).

4. Pick a point to indicate the location of the dimension lines and text. 

See also

Add dimensions to a sketched profile (page 182)

Delete a dimension from a sketch
When you want to delete a dimension from a sketch, you can do it in the
sketch editor view, in the Variables dialog box, or in the Sketch browser.

1. Select the dimension you want to delete.
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2. Do one of the following: 

• In the sketch editor view or in the Sketch browser, right-click and
select Delete.

• In the Variables dialog box, click the Delete button.

See also

Add dimensions to a sketched profile (page 182)

Define positioning planes for a sketched profile
When you sketch a profile, you can define positioning planes for it. With
positioning planes you can determine the planes Tekla Structures will use for
positioning parts and components.

See also

Part positioning planes (page 186)

Connection positioning planes (page 187)

Show and hide positioning planes (page 188)

Move positioning planes (page 189)

Revert to default positioning planes (page 190)

Part positioning planes
With part positioning planes you can determine how Tekla Structures positions
parts that have a sketched profile. These planes are used for the On plane
and At depth settings for parts, and also when placing custom components
that are bound to boundary planes.

The part positioning planes are displayed in blue:

The On plane options Left and Right are set according to the vertical blue
planes, and the Middle option is halfway between them.
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The same principle applies to the At depth setting: the Front and Behind
options are set according to the horizontal blue planes, and the Middle option
is halfway between them.

Example

You can define part positioning planes so that an asymmetric profile will be
positioned according to its web only. In the following example, the Middle
option is illustrated in gray dotted lines:

Middle option

See also

Define positioning planes for a sketched profile (page 186)

Connection positioning planes
With connection positioning planes you can determine how Tekla Structures
positions components in relation to the component main part that has a
sketched profile.
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The connection positioning planes are displayed in green:

Example

The following image shows the default connection positioning planes of a
double tee slab that was created as a sketched profile. The green line
illustrates the default connection positioning planes.

To place connections according to the location of the stems of the double tee,
move the connection positioning planes as shown below.

See also

Define positioning planes for a sketched profile (page 186)

Show and hide positioning planes

To show or hide the positioning planes, do one of the following:

To Do this
Show or hide part positioning planes

Click .
Show or hide connection positioning planes

Click .
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See also

Define positioning planes for a sketched profile (page 186)

Move positioning planes
You can move the positioning planes by moving their handles. Note that if you
move the handles away from the outmost corners of the sketched profile, you
must bind them by adding a dimension to each handle. Otherwise the
positioning will not function correctly in the model.

1. Click the positioning plane to display the handles. 

The handles are displayed in pink. By default, the handles are at the
outmost corners of the sketched profile. For example:

2. Click a handle to select it. 

NOTE The same handle controls both the vertical and horizontal plane,
so you can move them both at the same time.

3. Move the handle like any other object in Tekla Structures. 

For example, right-click and select Move.

4. If the handle is not at the outmost corner of the profile, add a dimension
between the handle and the corner.

Example

In the following examples, the left handle of the positioning plane has been
bound by using a horizontal dimension (b1):
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See also

Define positioning planes for a sketched profile (page 186)

Show and hide positioning planes (page 188)

Revert to default positioning planes
You can revert back to the default positioning planes of a sketched profile if
you have moved the planes.

To revert to the default positioning planes, do one of the following:

To Do this
Revert to the default part
positioning planes

1.
Click  to show the part positioning
planes.

2. Select the part positioning planes.

3. Right-click and select Delete.

4.
Click  again to check that the planes have
reverted back to the default.

Revert to the default
connection positioning
planes

1.
Click  to show the connection positioning
planes.

2. Select the connection positioning planes.

3. Right-click and select Delete.

4.
Click  again to check that the planes have
reverted back to the default.
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See also

Define positioning planes for a sketched profile (page 186)

Check a sketched profile
You can check that the constraints and dimensions in a sketched profile work
correctly.

1. Double-click a dimension line to open the Distance Properties dialog
box.

2. Change the Value box.

3. Click Modify. 

Tekla Structures updates the profile in the sketch editor.

4. Check that the shape of the profile does not change and that the
dimensions adjust correctly.

5. Click Cancel to close the Distance Properties dialog box.

See also

Use sketched profiles in a model (page 195)

Save a sketched profile
Tekla Structures saves the sketched profiles in the current model folder, in the
xslib.db1 file, which is a library file containing custom components and
sketches. Sketched profiles are available in the Others section in the profile
catalog.

NOTE Note the following limitations when naming sketched profiles:

• You cannot use the name of a fixed profile.

• You cannot include numbers, special characters, or blank spaces in
the profile name.

• Lower case letters are automatically converted into upper case
letters.

To save a sketched profile, do one of the following:

To Do this
Save a new profile 1.

Click Save sketch .

2. Enter a name in the Prefix box, and then click
OK.

Update an existing profile 1.
Click Save sketch .

Create and distribute customized configurations 191 Customize the profile catalog



To Do this
2. Click Yes when prompted to update the

existing cross section.
Save a copy of the profile
under a different name

1.
Click Save sketch as .

2. Enter a new name in the Prefix box, and then
click OK.

See also

Import and export sketched profiles (page 161)

Modify a sketched cross section
You can modify existing sketched profiles, for example, by modifying chamfers
or dimensions. You can also move corners or holes by moving the handles.
The chamfers are moved automatically when you move the handles.

NOTE • You cannot change dimensions that have been calculated using
formulas in the Variables dialog box.

• Constraints may also prevent you from changing dimensions.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Open the Others branch at the end of the profile tree.

3. Right-click a sketched profile, and then select Edit profile to open the
profile in the sketch editor.

4. Double-click a sketch object to modify its properties. 

The sketch objects you can modify appear in yellow.

5. Modify the properties and then click Modify.

6. Close the sketch object properties dialog box.

7. Click the Save sketch as icon  to save the changes.

See also

Modify chamfers in a sketch (page 192)

Set the sketch thickness (page 193)

Modify chamfers in a sketch
You can change the shape and dimensions of chamfers in a sketched profile.
For example, you can create rounded profile corners.

1. Double-click a chamfer symbol  in the sketch editor.
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2. In the Chamfer Properties dialog box, change the shape and dimensions
of the chamfer.

3. Click Modify.

4. Click OK to close the dialog box.

5. Click the Save sketch as icon  to save the changes.

See also

Modify a sketched cross section (page 192)

Set the sketch thickness
If you have sketched an open shape, such as a cold-rolled section, you must
define the extrusion type and thickness of the sketch in the Sketch Browser.
The thickness can be either fixed or parametric.

1. In the sketch editor, sketch an open polyline.

2. Do one of the following: 

• To set a fixed thickness:

a. In the Sketch Browser, right-click Thickness and select Add
Equation.

b. Enter the value of the thickness after =.

• To define a parametric thickness:

a. In the Variables dialog box, add a new parameter variable for
Length (for example, P1).

b. In the Formula column, define the default value for the parameter
variable.

c. In the Sketch Browser, right-click Thickness and select Add
Equation.

d. Enter the name of the parameter variable (for example, P1) after
=.
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3. To define the extrusion type:

a. In the Sketch Browser, right-click Extrusion Type and select Add
Equation.

b. Enter the extrusion type number (0, 1, or 2) after =.

4. Click the Save sketch as icon  to save the changes.

See also

Modify a sketched cross section (page 192)

Extrusion types (page 194)

Extrusion types
The extrusion type defines how a sketched profile of a consistent thickness is
extruded. When you change the thickness, the profile grows inwards,
outwards, or symmetrically in both directions, depending on the extrusion
type. You must define the extrusion type for sketches that consist of an open
polyline.

The extrusion types are:

Type Description Image
0 The sketch is extruded

symmetrically to the outside
and inside of the polyline.

(Default)

1 The sketch is extruded to the
outside of the polyline.

2 The sketch is extruded to the
inside of the polyline.
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See also

Set the sketch thickness (page 193)

Use sketched profiles in a model
Once you have created a sketched profile and saved it, you are ready to use it
in the model. If you have applied constraints correctly, the shape of the profile
will be maintained when you change its dimensions.

To use a sketched profile for a new part in a model:

1. Open the part properties in the property pane. 

For example, to open the beam properties, on the Steel tab, hold down

Shift and click .

2. Click the ... button next to the Profile box. 

The Select Profile dialog box appears.

3. Open the Others branch at the end of the profile tree.

4. Select a sketched profile.

5. If the profile is parametric, you can define its dimensions in the Value
column on the General tab.

6. Click OK to close the Select Profile dialog box.

7. Pick points to place the part in the model.

See also

Create an image of a profile (page 199)

Create parametric profiles with variable cross sections
You can create parametric user-defined profiles with variable cross sections
using the Profile Editor. You can use a profile with variable cross sections like
any other parametric profile.

You can:

• Use a cross section with different dimensions at different locations in a
profile.

• Modify the variables of the cross sections and the profile.

• Save the profile and use it as a parametric profile through the profile
catalog.
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• Import and export variable cross section profiles.

NOTE When you use this method, only the dimensions of a variable cross
section can vary, not the actual shape of the cross section. If you want
to use several different cross section shapes in the profile, create a
fixed profile with multiple cross sections instead.

See also

Create a profile with variable cross sections (page 196)

Modify a profile with variable cross sections (page 198)

Create a fixed profile (page 168)

Create a profile with variable cross sections

Before you start:

• Create a sketched profile using the sketch editor.

• In the Variables dialog box in the sketch editor, set Visibility to Show for
the dimensions that you want to change when using the profile in a model.

1. Go to Quick Launch, start typing define profile with variable
cross section, and select the Define Profile with Variable Cross
Section command from the list that appears. 

The Define Profile with Variable Cross Section dialog box opens.

2. Select the sketch you want to use as the start and end cross section of the
profile.
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3. Click OK. 

The Profile Editor and the Profile preview view appear.

4. Under Cross sections of the profile, add cross sections or remove
selected cross sections by clicking Add or Remove. 

When you click Add, Tekla Structures adds a new cross section at the end
of the profile, at the location 1.0., and moves the existing cross sections
towards the start of the profile. By default, cross sections are located at
0.1 intervals in the profile.

5. Under Cross section variables, define the following: 

• The relative location of each cross section in the profile.

Use the *.Location variables. For example, start=0.00, middle=0.5,
end=1.00.

• How the cross sections are aligned in the horizontal and vertical
direction.

Use the *.HorPos and *.VerPos variables.

• How much the cross sections are offset from the alignment.

Use the *.HorOffset and *.VerOffset variables.
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6. If you have added new cross sections, check that they do not overlap any
existing cross sections.

7. Set Visibility to Show for the dimensions that you want to change when
using the profile in a model.

8. If you want to use parameter variables and equations to define the cross
section dimension, click Add variable and define the variable values.

9. Save the profile.

a. Click Save.

b. In the Save profile as dialog box, enter a unique name for the profile.

You cannot include numbers in the profile name, or use the name of
a standard profile.

c. Click OK. 

Tekla Structures saves the profile in the current model folder.

See also

Create parametric profiles with variable cross sections (page 195)

Modify a profile with variable cross sections (page 198)

Create parametric profiles by sketching (page 172)

Modify a profile with variable cross sections

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Open the Others branch at the end of the profile tree.

3. Right-click a profile with variable cross sections, and then select Edit
profile to open the profile in the Profile Editor.
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4. Modify the profile properties.

5. Click Save.

See also

Create a profile with variable cross sections (page 196)

Define standardized values for parametric profiles
You can define standardized values for the dimensions of parametric profiles.
The standardized values are visible in the profile catalog where you can select
suitable dimension values for the profiles.

1. Go to the ..\ProgramData\Tekla Structures\<version>
\environments\<environment>\system folder.

2. Open the industry_standard_profiles.inp file using any standard
text editor, for example, Microsoft Notepad.

3. Modify the file. 

The file has the following format:

• profile and profile subtype

• parameters separated by spaces

• units for each parameter

• standardized values for each parameter.

Each dimension combination has its own row.

4. Save the file.

Example

For example, the standardized combinations of dimension values for a C
profile are as follows:
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Create an image of a profile
To illustrate the shape and dimensions of a profile you have created, you can
create an image of it. Tekla Structures displays the image when you browse for
profiles in the profile catalog. The image must be in Windows bitmap (.bmp)
format and can be created with any bitmap editor, for example Microsoft
Paint.

1. Take a screenshot of the profile you have drawn or sketched. 

For example, press the Print Screen (Prt Scr) key to take a screenshot of
your entire desktop. To take a screenshot of an active window, press Alt
+Print Screen. The screenshot is placed on the clipboard.

2. Open the screenshot in any bitmap editor (for example, Microsoft Paint)
and modify the image if necessary.

3. Save the image in .bmp format in the ..\ProgramData\Tekla
Structures\<version>\Bitmaps folder. 

The file name must match the actual profile name. For example, if the
profile name is mysketch, the image must be named mysketch.bmp.

4. Restart Tekla Structures. 

The image is now shown in the profile catalog.
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4.8 Customize the shape catalog
The Shape Catalog dialog box contains information on shapes. It is used for
viewing shape properties, and for importing and exporting shapes.

The shapes you download from Tekla Warehouse are also displayed in the
Shape Catalog dialog box.

The catalog includes two default shapes: Default and Concrete_Default.
Shapes are used in defining items. In Tekla Structures, items are similar to
other parts, such as beams and columns. The main difference between items
and other types of parts is that a 3D shape defines the geometry of an item,
whereas a part has a 2D profile that is extruded to create the length of the
part.

The shapes you import to the shape catalog are stored in the current model
folder. There are two files for each shape: one .xml file stored in the \Shapes
folder and one .tez or .xml file in the \ShapeGeometries folder.

If you have shapes that you would like to have available in the Shape Catalog
dialog box for all new models that are created in your project or company,
copy the corresponding .tez and .xml files to the correct subfolders
(\Shapes and \ShapeGeometries) in the \profil folder under your project
or firm folder.

NOTE If your project, company, or environment uses a common location for shapes
that are used in several Tekla Structures versions including 2017i and older,
use .xml format for shape geometry files. The compressed .tez files do not
work in Tekla Structures 2017i or older versions.

See also

Import a shape (page 201)

Compress shape geometry files (page 202)

Export a shape (page 203)

Delete a shape (page 204)

Import a shape
You can import the following types of shape files: dgn, tsc, skp, dxf, dwg, ifc,
ifcZIP, ifcXML, igs, iges, stp, and step.

When using other modeling software to model shapes that you want to import
into Tekla Structures, we recommend that you center parts around the origin
and direct the parts along the x axis.

1. On the File menu, click Catalogs --> Shape catalog . 

The Shape Catalog dialog box opens.

2. Click Import.
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3. Select the shape file to import. 

To select multiple shape files, hold down Ctrl or Shift.

4. Click OK. 

Importing a large file can take several minutes.

Shape import has three possible results:

• Tekla Structures imports the shape as a watertight solid shape. All solid
operations are available.

• Tekla Structures imports the shape as a non-solid shape. A non-solid shape
means that the object may not be watertight. For example, it has holes, or
is missing a face or an edge.

• Import fails. This can happen, for example, if the shape is very complex or
has no volume. There may also be a tolerance difference between Tekla
Structures and the original software that was used to create the shape. To
find out why the import failed, check the session history log by clicking File
menu --> Logs --> Session history log .

When you import a shape into the Shape Catalog, Tekla Structures creates
two files: one .xml file for shape attributes, such as name and GUID, and
one .tez file for geometric properties, such as coordinates. The files are saved
in the current model folder under the \Shapes and \ShapeGeometries
subfolders.

TIP You can also download shapes from Tekla Warehouse.

See also

Example: Import a shape from SketchUp Pro (page 204)

Compress shape geometry files (page 202)

Export a shape (page 203)

Delete a shape (page 204)

Customize the shape catalog (page 200)

Compress shape geometry files
You can compress shape geometry files by converting the files from .xml
format to compressed format .tez. Using the .tez format saves disk space.

You can compress the shape geometry files that are stored in the
\ShapeGeometries subfolder in the current model folder. The files in the
\Shapes subfolder will not be compressed.

If you have already used any of the shapes for items in the model, they will
work the same way even after compression.
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NOTE Compression is a permanent action, and you cannot undo it even if you do
not save the model.

Do not compress shape geometry files if you need them in models that you
will open using Tekla Structures 2017i or an older version. The .tez files do
not work in those versions.

If your project, company, or environment uses a common location for shapes
that are used in several Tekla Structures versions including 2017i and older,
do not convert those shape geometry files to .tez format. Otherwise the
shapes will not work in all versions.

How to compress shape geometry files
To compress existing shape geometry files, either re-import the original shape
files (page 201), or use the Compress shape geometries application as
follows:

1. Open the model whose shape geometry files you want to compress.

2. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

3. Search for the Compress shape geometries application, and then
double-click to open it.

4. In the Compress shape XML files to TEZ format dialog box, click
Compress.

5. Re-open the model.

Export a shape
1. On the File menu, click Catalogs --> Shape catalog . 

The Shape Catalog dialog box opens.

2. Select the shape to export. 

To select multiple shapes, hold down Ctrl or Shift.

3. Click Export.

4. If you are exporting only one shape, select the folder where you want to
export the shape, and enter a name for the export file in the Selection
box.

5. If you are exporting multiple shapes, select the folder where you want to
export the shapes. 

Tekla Structures will create a separate export file for each shape using the
shape name as the file name.
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6. Click OK.

The shapes are saved in the destination folder as .tsc files.

TIP You can also upload shapes to Tekla Warehouse.

See also

Import a shape (page 201)

Delete a shape (page 204)

Customize the shape catalog (page 200)

Delete a shape

Before you start, ensure that the shape you want to delete is not used in your
Tekla Structures model. When you delete a shape from the Shape Catalog, the
shape is no longer available anywhere in the model. If a model includes a
deleted shape, it is only shown as a straight line between its original reference
points.

1. On the File menu, click Catalogs --> Shape catalog . 

The Shape Catalog dialog box opens.

2. Right-click the name of the shape.

3. Click Delete.

Tekla Structures deletes the shape.

See also

Import a shape (page 201)

Export a shape (page 203)

Customize the shape catalog (page 200)

Example: Import a shape from SketchUp Pro
In this example, you import a solid 3D shape from Trimble SketchUp Pro to a
Tekla Structures model.

1. Create an empty model in SketchUp Pro. 

Delete any extra entities, such as the default person on the drawing area.

2. Create a group of entities. 
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Although Tekla Structures supports importing separate individual entities,
we recommend you create a group of entities or a component in
SketchUp.

All SketchUp groups and components should form watertight solids.
Select the group or component and open Entity Info to check that the
selection is a solid. SketchUp solids have a volume. If there is no volume
listed, the selection is not a solid.

3. Select the group and click Solid Tools --> Union to make the group of
entities into a union of solids. 

Your group becomes a single solid volume: a solid.

4. Place the solid in SketchUp so that it lies along the positive x axis (red),
and halfway on both y (green) and z axes (blue). In Tekla Structures, the
yellow and magenta part handles will align with the x axis used in
SketchUp. 

The location and rotation of the solid in SketchUp are important, since
they determine how an item is inserted and positioned in Tekla Structures.
Different positioning in SketchUp causes an offset in Tekla Structures.

5. Save the SketchUp file.

6. In your Tekla Structures model, open the Shape Catalog and click Import.

7. Select the SketchUp file.

8. Click OK.

Tekla Structures imports the shape to the Shape Catalog and you can use it to
define the shape of an item or a concrete item.

See also

Customize the shape catalog (page 200)

Import a shape (page 201)
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4.9 Customize the bolt catalog
The individual bolt assembly elements, such as bolts of different sizes and
lengths, nuts and washers, are listed in the bolt catalog. Each bolt assembly
then consists of these bolt assembly elements. You cannot use a bolt if it does
not belong to a bolt assembly. The bolt assemblies are listed in the bolt
assembly catalog.

Tekla Structures stores the bolt catalog information in the screwdb.db file
and the bolt assembly catalog information in the assdb.db file.

See also

How the bolt catalog and bolt assembly catalogs work together (page 206)

Manage bolts and bolt assemblies (page 207)

Import and export bolts and bolt assemblies (page 212)

Bolt length calculation (page 216)

How the bolt catalog and bolt assembly catalogs work
together

(1) The Bolt standard options are read from the bolt assembly catalog.
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(2) The bolt assembly catalog defines which bolt standard is used in the bolt
assembly.

(3) The bolt catalog contains the different bolt diameters, lengths, and other
properties used in the bolt standard.

(4) The Bolt size options are read from the bolt catalog depending on the
selected Bolt standard option.

See also

Customize the bolt catalog (page 205)

Bolt catalog properties (page 220)

Bolt assembly catalog properties (page 221)

Manage bolts and bolt assemblies
This section describes how to manage bolts and bolt assemblies using the bolt
catalog and the bolt assembly catalog. You can add, modify, and delete bolts
and bolt assemblies.

Click the links below to find out more:

Add a bolt to the catalog (page 207)

Add a stud bolt to the catalog (page 208)

Modify bolt information in the catalog (page 209)

Delete a bolt from the catalog (page 210)

Add a bolt assembly to the catalog (page 210)

Modify bolt assembly information in the catalog (page 211)

Delete a bolt assembly from the catalog (page 211)

Add a bolt to the catalog
You need to add individual bolt elements, such as bolts, nuts, and washers, to
the bolt catalog before you can define bolt assemblies and use them in a
model.

The following steps are for adding bolts, but they also apply to adding nuts
and washers.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. Enter the name of the bolt in the following box: 
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You can enter a maximum of 40 characters in the name box.

3. In the Type list, select an option to define the bolt element type.

4. Define the other properties of the new bolt. 

You can enter a maximum of 25 characters in the Standard box.

Use different names for bolt, nut, washer, and stud standards to
distinguish bolt element types from each other when defining bolt
assemblies.

5. Click Add to add the bolt to the bolt catalog. 

You cannot use a bolt if it does not belong to a bolt assembly. Therefore,
we recommend checking that the catalog also includes nuts and washers
that work with the new bolt so that you can create a bolt assembly. If the
catalog does not include suitable nuts and washers, add them the same
way as you added the new bolt.

6. Click OK. 

The Save confirmation dialog box appears.

7. Select Save changes to model folder to save the changes in the
screwdb.db file in the current model folder, and then click OK.

TIP You can also add bolts by importing them to the bolt catalog.

See also

Import bolts to the catalog (page 212)

Add a stud bolt to the catalog (page 208)

Modify bolt information in the catalog (page 209)

Delete a bolt from the catalog (page 210)

Bolt length calculation (page 216)

Bolt catalog properties (page 220)

Add a bolt assembly to the catalog (page 210)

Add a stud bolt to the catalog
A stud is special type of bolt that is welded to steel parts to transfer loads
between steel and concrete. You cannot use studs unless you have defined a
stud assembly that contains the assembly's name and material.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.
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2. Enter values for the following properties: 

• Name: Name for the stud bolt.

• Type: 

• Standard: This name is needed when creating a bolt assembly for the
stud.

• Diameter: Shank diameter.

• Length: Stud length.

• Weight: Stud weight.

• top thick: Head thickness.

• top diameter: Head diameter.

The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals.

3. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

4. Select the standard for the stud bolt.

5. Set all the other bolt assembly elements to None. 

6. To create studs in the model, create bolts and select the stud assembly
standard.

See also

Bolt catalog properties (page 220)

Modify bolt information in the catalog
1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt

Catalog dialog box.

2. Select a bolt from the list.
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3. Modify the properties.

4. Click Update.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
screwdb.db file in the current model folder, and then click OK.

See also

Add a bolt to the catalog (page 207)

Delete a bolt from the catalog (page 210)

Bolt catalog properties (page 220)

Delete a bolt from the catalog
1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt

Catalog dialog box.

2. Select a bolt from the list. 

Use the Shift and Ctrl keys to select multiple bolts.

3. Click Delete.

4. Click OK. 

The Save confirmation dialog box appears.

5. Select Save changes to model folder to save the changes in the
screwdb.db file in the current model folder, and then click OK.

See also

Add a bolt to the catalog (page 207)

Modify bolt information in the catalog (page 209)

Add a bolt assembly to the catalog
You can add new bolt assemblies to the bolt assembly catalog. Note that the
bolt assembly can contain only bolts or studs, not both of them.

1. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

2. Enter the name of the bolt assembly in the following box: 
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3. Define the other properties of the new bolt assembly. 

You can enter a maximum of 30 characters in the Standard box. For all
the other properties, you can enter a maximum of 25 characters.

4. Click Add to add the bolt assembly to the catalog.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
assdb.db file in the current model folder, and then click OK.

See also

Import bolt assemblies to the catalog (page 214)

Modify bolt assembly information in the catalog (page 211)

Delete a bolt assembly from the catalog (page 211)

Bolt assembly catalog properties (page 221)

Modify bolt assembly information in the catalog
1. On the File menu, click Catalogs --> Bolt assembly catalog to open the

Bolt Assembly Catalog dialog box.

2. Select a bolt assembly from the list.

3. Modify the properties.

4. Click Update.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
assdb.db file in the current model folder, and then click OK.

See also

Add a bolt assembly to the catalog (page 210)

Delete a bolt assembly from the catalog (page 211)

Delete a bolt assembly from the catalog
1. On the File menu, click Catalogs --> Bolt assembly catalog to open the

Bolt Assembly Catalog dialog box.

2. Select a bolt assembly from the list.

3. Click Delete.
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4. Click OK. 

The Save confirmation dialog box appears.

5. Select Save changes to model folder to save the changes in the
assdb.db file in the current model folder, and then click OK.

See also

Add a bolt assembly to the catalog (page 210)

Modify bolt assembly information in the catalog (page 211)

Import and export bolts and bolt assemblies
Use importing and exporting for merging bolts and bolt assemblies across
catalogs. Bolts are imported and exported as .bolts files, bolt assemblies
as .bass files, and bolt catalogs as .lis files.

When you export single bolts or bolt assemblies, you can select the bolts or
bolt assemblies you want to include in the .bolts or .bass file. When you
import and export bolt assemblies, also the related bolts are included in
the .bass file.

You can import and export an entire bolt catalog. You can also import a part of
an exported bolt catalog.

Importing and exporting bolt catalogs is useful, when you:

• Upgrade to newer version of Tekla Structures and you want to use a
customized bolt catalog from a previous version.

• Want to combine bolt catalogs that are stored in different locations.

• Want to share bolt catalog information with other users.

TIP You can also download or share bolt assemblies using Tekla Warehouse.

See also

Import bolts to the catalog (page 212)

Export bolts from the catalog (page 213)

Import bolt assemblies to the catalog (page 214)

Export bolt assemblies from the catalog (page 214)

Import a bolt catalog (page 215)

Import a part of the bolt catalog (page 215)

Export an entire bolt catalog (page 216)
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Import bolts to the catalog

Bolts are imported and exported as .bolts files. A .bolts file can include
one bolt or several bolts.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. Right-click in the Bolts list and select Import.

3. Select the import file.

4. Click OK. 

The bolts are displayed on the Bolts list by their original names.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
screwdb.db file in the current model folder, and then click OK.

See also

Add a bolt to the catalog (page 207)

Import a bolt catalog (page 215)

Import a part of the bolt catalog (page 215)

Import bolt assemblies to the catalog (page 214)

Export bolts from the catalog (page 213)

Export bolts from the catalog

Bolts are imported and exported as .bolts files. A .bolts file can include
one bolt or several bolts.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. Select bolts from the Bolts list. 

Use the Shift and Ctrl keys to select multiple bolts.

3. Right-click in the Bolts list and select Export.

4. Browse for the folder where you want to save the export file.

5. Enter a name for the file in the Selection box.

6. Click OK.

See also

Export bolt assemblies from the catalog (page 214)
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Export an entire bolt catalog (page 216)

Import bolts to the catalog (page 212)

Import bolt assemblies to the catalog

Bolt assemblies are imported and exported as .bass files. A .bass file can
include one bolt assembly or several bolt assemblies.

1. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

2. Right-click in the Bolt assemblies list and select Import.

3. Select the import file.

4. Click OK. 

The bolt assemblies are displayed on the Bolt assemblies list by their
original names.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
assdb.db file in the current model folder, and then click OK.

See also

Add a bolt assembly to the catalog (page 210)

Import a bolt catalog (page 215)

Import bolts to the catalog (page 212)

Export bolt assemblies from the catalog (page 214)

Export bolt assemblies from the catalog

Bolt assemblies are imported and exported as .bass files. A .bass file can
include one bolt assembly or several bolt assemblies.

1. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

2. Select bolt assemblies from the Bolt assemblies list. 

Use the Shift and Ctrl keys to select multiple bolt assemblies.

3. Right-click in the Bolt assemblies list and select Export.

4. Browse for the folder where you want to save the export file.

5. Enter a name for the file in the Selection box.

6. Click OK.
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See also

Export an entire bolt catalog (page 216)

Export bolts from the catalog (page 213)

Import bolt assemblies to the catalog (page 214)

Import a bolt catalog
Bolt catalogs are imported to Tekla Structures models as .lis files.

1. Open the model to which you want to import a bolt catalog.

2. Copy the screwdb.lis file that you want to import to the current model
folder.

3. To import the bolt catalog file screwdb.lis from the current model
folder, go to Quick Launch, start typing import bolt catalog, and
select the Import Bolt Catalog command from the list that appears. 

Tekla Structures does not replace the entries that have the same names
as the entries in the import file.

4. Check the status bar for error messages. 

To view errors, go to the File menu and click Logs --> Session history log .

See also

Import a part of the bolt catalog (page 215)

Export an entire bolt catalog (page 216)

Import a part of the bolt catalog
If you do not want to import the entire bolt catalog, you can select the parts to
be imported.

TIP If you only want to import a few bolts or bolt assemblies, use the import
and export commands of the corresponding catalogs.

1. Open the model that contains the bolt catalog you want to use.

2. Go to Quick Launch, start typing export bolt catalog, and select the
Export Bolt Catalog command from the list that appears. 

The bolt catalog is saved as the screwdb.lis file in the current model
folder.

3. Open the screwdb.lis file using a text editor, for example, Microsoft
Notepad. 

Each entry is listed on a separate row.

4. Delete the unwanted rows from the file. 
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WARNING Do not delete the STARTLIST and ENDLIST rows.

5. Save the file with the name screwdb.lis.

6. Open the model to which you want to import the bolt catalog.

7. Copy the screwdb.lis file that you want to import to the current model
folder.

8. To import the bolt catalog file screwdb.lis from the current model
folder, go to Quick Launch, start typing import bolt catalog, and
select the Import Bolt Catalog command from the list that appears.

See also

Import bolts to the catalog (page 212)

Import bolt assemblies to the catalog (page 214)

Import a bolt catalog (page 215)

Export an entire bolt catalog (page 216)

Export an entire bolt catalog
Bolt catalogs are exported from Tekla Structures models as .lis files.

1. Open the model that contains the bolt catalog you want to export.

2. Go to Quick Launch, start typing export bolt catalog, and select the
Export Bolt Catalog command from the list that appears. 

The exported bolt catalog is the screwdb.lis file in the current model
folder.

TIP The Export Bolt Catalog command exports the entire bolt catalog.
To export only part of the bolt catalog, modify the export file to
contain only the required elements. You can also export bolts from
the Bolt Catalog dialog box or bolt assemblies from the Bolt
Assembly Catalog dialog box.

See also

Export bolt assemblies from the catalog (page 214)

Export bolts from the catalog (page 213)

Import a bolt catalog (page 215)

Import a part of the bolt catalog (page 215)
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Bolt length calculation
Tekla Structures uses values from the bolt catalog and the bolt assembly
catalog when calculating the bolt length. If the bolt catalog does not contain
long enough bolts for your purposes, you need to add them to the bolt
catalog.

The following settings in the Bolt Properties dialog box affect the bolt length
calculation process. If the check box is selected, the part is used in the bolt
assembly.

Washer (1)

Washer (2)

Washer (3)

Nut (1)

Nut (2)

If the check box is clear, only a hole is
created

The chart and the detailed steps below explain the process of bolt length
calculation.
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1. Tekla Structures calculates the minimum possible length of the bolt as
follows:

washer (1) thickness (if the check box is selected) +

material thickness +

washer (2) thickness (if the check box is selected) +

washer (3) thickness (if the check box is selected) +

nut (1) thickness +

nut (2) thickness +

extra length

2. Tekla Structures searches for the closest match in the bolt catalog.

3. Tekla Structures calculates the number of washers required (must not
exceed 10) so that the length of the shaft is less than:

nut (1) thickness +

material thickness +

nut (2) thickness +

washer (1) thickness +

washer (2) thickness +

(number of washers*washer (3) thickness)

4. Tekla Structures checks that the bolt found in step 2 is longer than:

extra length +

nut (1) thickness +
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material thickness +

nut (2) thickness +

add. dist (from the bolt catalog) +

washer (1) thickness +

washer (2) thickness +

(number of fitting washers * washer (3) thickness)

5. If the selected bolt does not fulfill the criteria in step 4, Tekla Structures
returns to step 2, otherwise it continues on to step 6.

6. Tekla Structures checks that the selected bolt fulfills all the following
conditions:

• Can the thread be inside the material to be connected? Even if this is
not allowed, the calculation always allows 3 or 4 mm of thread to be
inside the material, depending on the bolt diameter. If the bolt
diameter is ≥ 24 mm, it allows 4 mm, otherwise it allows 3 mm.

• Shaft length must be more than:

material thickness +

extra length +

washer (1) thickness (if checked) -

maximum thread in material allowed (if thread in material = no) =
3 mm or 4 mm

• Shaft length is calculated as:

Screw length - screw thread length - thread end.

• Thread end is the part of the bolt between the shaft and the thread. It
is calculated as follows:

Diameter of bolt (mm) Thread end (mm)
>33.0 10.0
>27.0 8.0
>22.0 7.0
>16.0 6.0
>12.0 5.0
>7.0 4.0
>4.0 2.5
≤4 1.5

7. If the selected bolt does not fulfill all the above conditions, Tekla
Structures returns to step 2 and tries the next longest bolt.
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8. If the advanced option XS_BOLT_LENGTH_EPSILON is set, the epsilon
thickness is added to, or subtracted from, the material thickness to avoid
inaccurate bolt length calculation.

For example, if this value is not taken into account, and the calculated
length is 38.001 mm, a 39 mm bolt might be selected.

See also

How the bolt catalog and bolt assembly catalogs work together (page 206)

Add a bolt to the catalog (page 207)

Bolt catalog properties
Use the Bolt Catalog dialog box to view and modify the properties of
individual bolt elements, such as bolts, washers, and nuts. The units depend
on the settings in File menu --> Settings --> Options --> Units and decimals.

Option Description
Type The type of the bolt element. The options are:

 (Nut)

 (Washer)

 (Stud)
Standard The name of the bolt element standard.

Used in the Bolt Assembly Catalog dialog box for defining bolt
elements in a bolt assembly.

Use different names for bolt, nut, washer, and stud standards to
distinguish bolt element types from each other.

Diameter The diameter of the bolt element.
Length The length of the bolt element.
Weight The weight of the bolt element.
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Option Description
add. dist The length of the part of the bolt that protrudes from the nut.

The value is used in bolt length calculation.
top thick The thickness of the bolt head.
thread len The length of the threaded part of the bolt shaft.

The value is not used in bolt length calculation (value is 0) if the
bolt is fully-threaded.

washer tol The tolerance between the washer inner diameter and the bolt
diameter.

The value is used when searching for the correct-sized washer
for the bolt. Not used in bolt length calculation.

span size The size of the wrench needed.
calc thick The calculation thickness of a nut or a washer.

This value is used in bolt length calculation.
real thick The true thickness of a nut or a washer.

This is for information only.
inner diam The inner diameter of a nut or a washer.

This is for information only.
outer diam The outer diameter of a nut or a washer.

This is for information only.
top diam The diameter of the hexagon.

This is for information only.

See also

Add a bolt to the catalog (page 207)

How the bolt catalog and bolt assembly catalogs work together (page 206)

Bolt assembly catalog properties
Use the Bolt Assembly Catalog dialog box to view and modify the properties
of bolt assemblies. The units depend on the settings in File menu --> Settings
--> Options --> Units and decimals.

Option Description
Short name This name is used in drawings and reports. It is usually the

commercial name for a specific bolt.
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Option Description
Standard This name is the full name which is shown in the bolt

assemblies list in the Bolt Assembly Catalog dialog box, and
in the Bolt standard list in the Bolt Properties dialog box.

The value is used in bolt length calculation.
Material The material of the bolt assembly.
Finish The type of the finish.
Grade The grade of the bolt assembly.
Tolerance The tolerances of the bolt assembly.

Additional length for bolt calculation

Option Description
Add. dist... The Additional Distance option controls how much of the bolt

protrudes from the nut.

Additional Distance updates the Additional Distance values
of all bolts that use the selected bolt standard and have the
selected diameter.

The value is used in bolt length calculation.

Select whether the value of the additional length affects
all or individual diameters of one bolt assembly.

Enter the additional length value.

Select whether the value is absolute or relative to the
diameter.
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See also

Add a bolt assembly to the catalog (page 210)
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5 Files and folders in Tekla
Structures

Sometimes you need to know where Tekla Structures stores information, and
the types of files that Tekla Structures contains, where the files are located,
and how the files should be should be used.

Tekla Structures contains a large amount of files that affect the way the
software works. It is important to know which file controls which functionality,
and also which files we do not recommend that you touch.

The initialization file reading order is also very important. You need to know
the order in which the files are read when you open Tekla Structures, so that
you do not modify the files unnecessarily.

See also

Initialization files (.ini files) (page 226)

Input files (.inp files) (page 256)

File storing options and advanced options (page 234)

Data files (.dat files) (page 269)

Message files (page 270)

Standard files (page 271)

Property files (page 273)

Catalog files (page 273)

Font files and font conversion files (page 275)

Symbol files (page 276)

Image files (page 277)

Files related to templates, reports and drawings (page 276)

Log files (page 278)

Model folder files and file name extensions (page 284)

Files and folders in Tekla Structures 224 Customize the bolt catalog



Check and change Tekla Structures file and folder locations in Directory
browser (page 306)

Folder search order (page 307)

Create project and firm folders (page 225)

Location of certain files in hidden folders (page 309)

5.1 Create project and firm folders
Use project and firm folders for customized files. These can be custom
ribbons, drawing styles, profile and material catalogs, or any other settings you
want to store for future use. You can use the same files each time you start a
new model or install a new version of Tekla Structures. This also means you
can easily revert back to the default settings, because you have not
overwritten any of the system files.

Use the project folder for customized files that are only used in a particular
project. A project may consist of several models done by separate teams, all
spread out in different locations. You can save project-specific files and
settings in the project folder, so that everyone in the project can use them.
Project may also consist of one model that is shared by different companies.

Use the firm folder to store customized files for the entire organization or
company. These settings and files are meant to be used in all projects within
the company. For example, let's say you regularly work for a company that has
specific drawing layout standards it expects you to use. Customize the drawing
templates once for the company and save them in a sub-folder located under
the firm folder. You can then use the customized drawing templates for all
future projects for that company.

When working within one company, the firm and project folders are usually
located in network folders so that everyone can access them. They are defined
by XS_FIRM and XS_PROJECT. When working in a model sharing project, each
company needs to have its own firm settings in a folder defined by XS_FIRM,
and a common project folder for project settings defined by XS_PROJECT. It
may be useful to create a startup shortcut (page 21) on your desktop for each
project containing all necessary folders.

WARNING Changing an advanced option value in .ini files located outside the
model folder does not affect the existing models. You can only update
advanced options in the Advanced Options dialog box or in the
options.ini file located in model folder; not from an options.ini file
located in folders defined for the advanced options XS_FIRM or
XS_PROJECT. The .ini files are read also when you open an existing
model, but only new advanced options that do not exist in
options_model.db or options_drawings.db are inserted, for
example, such options that are not yet in the Advanced Options dialog
box but have been added in the software.
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Create a project or firm folder
1. Create an empty folder in a shared location, for example on a network

drive.

2. Name the folder appropriately.

3. In Tekla Structures, go to the File menu and click Settings --> Advanced
options.

4. In the File Locations category, define the path to the firm or project
folder you created in step 1 for the advanced option XS_FIRM or 
XS_PROJECT.

5. Restart Tekla Structures for the change to take effect.

See also

Folder search order (page 307)

Typical initialization files (.ini files) and their reading order (page 226)

5.2 Initialization files (.ini files)
Initialization files are used for defining Tekla Structures start-up parameters
and default settings. They contain advanced options that are used for
configuring Tekla Structures for different standards, and for your or your
company’s style of working.

Tekla Structures automatically creates the necessary initialization files
(page 226) during installation. The number of initialization files it creates
depends on how many Tekla Structures environments you have installed.

See also

Global default environment settings - env_global_default.ini (page 231)

Local environment settings - env_<environment>.ini (page 232)

Role settings - role_<role>.ini (page 232)

Typical initialization files (.ini files) and their reading order

Below is a list of all the typical initialization files that are read when Tekla
Structures is started. The numbers indicate their reading order at startup. If
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there are conflicting settings, the ones read later override the ones read
earlier.

WARNING Changing an advanced option value in .ini files located outside
the model folder does not affect the existing models. You can
only update advanced options in the Advanced Options dialog
box or in the options.ini file located in model folder; not from
an options.ini file located in folders defined for the advanced
options XS_FIRM or XS_PROJECT. The .ini files are read also
when you open an existing model, but only new advanced
options that do not exist in options_model.db or
options_drawings.db are inserted, for example, such options
that are not yet in the Advanced Options dialog box but have
been added in the software.

To check the files that have been read and their reading order, go to File
menu --> Logs --> Session history log .

File and reading order Description
1. fonts_<lang>.ini This file is optional, and it is only

needed for languages using special
characters. One example is the
fonts_jpn.ini file for the Japanese
language.

This file is read from Tekla
Structures\<version>\nt\bin\ if
it is available. It is installed to the ..
\nt\bin folder when Tekla Structures
is installed.

NOTE: Do not change these settings.
2. teklastructures.ini The file teklastructures.ini

starts Tekla Structures. It is read
from ..\Program Files\Tekla
Structures\<version>\nt\bin\.

This file contains basic system
settings, such as the location of
software and environment files. This
file is installed to the ..\nt\bin
folder when Tekla Structures is
installed. It is always read at Tekla
Structures startup.

NOTE: Do not change these settings.
3. lang_<lang>.ini This file contains the language

settings. It is read from ..\Program
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File and reading order Description
Files\Tekla Structures
\<version>\nt\bin\.

This file is installed to the ..\nt\bin
folder when Tekla Structures is
installed.

Which lang_<lang>.ini files exist
in the ..\nt\bin folder depends on
which languages you have selected to
install during the software
installation.

The language that is read depends on
the language you have selected in File
menu --> Settings --> Change
language in the previous Tekla
Structures session.

NOTE: Do not change these settings.
4. env_global_default.ini This file is used as a default for all

environments and contains the global
settings. The settings in the
env_global_default.ini file
provide the basics for all environment
settings globally. The settings in this
file can be localized and specified
differently in an environment-specific
initialization file that is read later than
this file.

This file is always read at Tekla
Structures startup from ..
\ProgramData\Tekla Structures
\<version>\environments
\common\ and is installed there from
the common environment installation
package.

NOTE: Do not change these settings.
5. All .ini files defined in shortcut/
command line with -I <name>.ini

Usually none.

6. env_<environment>.ini The env_<environment>.ini files
contain all the advanced options that
have environment-specific settings.
They are read from ..\ProgramData
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File and reading order Description
\Tekla Structures\<version>
\environments\<environment>\.

The env_<environment>.ini files
that exist on your computer depends
on which environment packages you
have installed. Which
env_<environment>.ini file is read
depends on the environment that you
select in the Tekla Structures startup
dialog box.

For example, this file defines that the
US imperial environment uses
imperial units, shows the fractions
correctly, and understands input as
imperial. In metric environments
metric units are used.

NOTE: Do not change these settings.
7. role_<role>.ini The role_<role>.ini files contain

all the advanced options that have
typical role-specific settings. They are
read from ..\ProgramData\Tekla
Structures\<version>
\environments\<environment>\.

The available roles depend on the
environments you have installed.

You can select the role in the Tekla
Structures startup dialog box.

NOTE: Do not change these settings.
8. All .ini files defined in shortcut/
command line with -i <name>.ini

Usually none.

9. company.ini The company.ini file is useful
especially for big companies that
want to unify certain enterprise-level
settings. This file is read from a folder
specified with the advanced option
XS_COMPANY_SETTINGS_DIRECTORY.
This file is read only if the advanced
option 
XS_COMPANY_SETTINGS_DIRECTORY
is set.

This file is created by the system
administrator when necessary, it is
not created by the installation.
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File and reading order Description
10. user.ini The user.ini file is where you can

save your personal user settings.

This file is located in the same
location as the user-specific
options.bin file, for example, C:
\Users\<user>\AppData\Local
\Tekla Structures\<version>
\UserSettings.

The user.ini is created in the above
mentioned location when you start
Tekla Structures for the first time and
create and save a model using the
current version. It is read when you
start Tekla Structures.

The changes you make in the
advanced options in the Advanced
Options dialog box override the
settings in all other initialization files,
if the advanced option exists in both
locations.

If user.ini has system options they
are read always when Tekla
Structures is opened.

If user.ini has model-specific
options they are used when new
model is created.

If user.ini has user-specific options
they are used when Tekla Structures
is used for the first time.

11. options.ini in system folder The folder is specified with the
advanced option XS_SYSTEM.

12. options.ini, firm-specific, if any
exist

13. options.ini, project-specific, if
any exist

The option.ini files containing
firm- or project-specific model
settings are saved in and read from
user-defined locations specified with
the advanced options XS_FIRM and
XS_PROJECT. They work in the
specified way for the firm in question,
or for the specified project if the
model has been set up to read
settings from these locations, and if
the user has manually moved the
options.ini file to these locations.
An options.ini is created in the
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File and reading order Description
firm or project folder when you copy
or move it there.

Updating of model-specific and user-
specific advanced options can only be
done from the Advanced Options
dialog box or options.ini located in
model folder, not from the firm- or
project-specific options.ini files.

The options.ini in the firm or
project folder is read when you start
Tekla Structures or open the model.

14. options.ini, model-specific The options.ini in the model
folder.

See also

Create startup shortcuts with customized initializations (page 21)

Settings defined by advanced options (page 253)

Global default environment settings - env_global_default.ini
The env_global_default.ini file defines the global defaults for advanced
options. The file is read from ..\ProgramData\Tekla Structures
\<version>\environments\common\.

WARNING Do not modify the env_global_default.ini file. If you need to
modify some environment settings, copy the needed advanced
options from this file to your user.ini (page 232) file and modify
the settings there, or modify the settings in the Advanced
Options dialog box.

For advanced options that are set according to your local standards, see the
environment settings file env_<environment name>.ini (page 232) and the role
settings file role_<role name>.ini (page 232). The local files override the
advanced options set in env_global_default.ini.

If the advanced option in the env_global_default.ini file is preceded by
rem, the software defaults are used and shown as the value. The outdated
advanced options are listed at the end of the file.

See also

Typical initialization files (.ini files) and their reading order (page 226)

Files and folders in Tekla Structures 231 Initialization files (.ini files)



Local environment settings - env_<environment>.ini
The env_<environment>.ini file contains advanced options that are set
according to local standards and are different from the global defaults. The file
is read from ..\ProgramData\Tekla Structures\<version>
\environments\<environment>\.

WARNING Do not modify the env_<environment>.ini file. If you need to
modify some settings, copy the needed advanced options from
this file to your user.ini (page 232) file and modify the settings
there, or modify the settings in the Advanced Options dialog
box.

The global default environment settings file env_global_default.ini (page 231)
contains a complete listing of advanced options. The local files override the
advanced options set in env_global_default.ini.

See also

Typical initialization files (.ini files) and their reading order (page 226)

Role settings - role_<role>.ini
The role_<role>.ini files contain all the advanced options that have typical
role-specific settings. The file is read from ..\ProgramData\Tekla
Structures\<version>\environments\<environment>\.

WARNING Do not modify the role_<role>.ini file. If you need to modify
some settings, copy the needed advanced options from this file to
your user.ini (page 232) file and modify the settings there, or
modify the settings in the Advanced Options dialog box.

The role_<role>.ini file contains advanced options that are set according
to typical role requirements in your local area. These settings are different
from your environment settings in env_<environment name>.ini (page 232).
The global default environment settings file env_global_default.ini (page 231)
contains a complete listing of advanced options. The advanced option settings
in role_<role>.ini override the ones in env_<environment>.ini

See also

Typical initialization files (.ini files) and their reading order (page 226)
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Add an advanced option to the user.ini file
You can save your personal user settings to the user.ini file. The user.ini
file is located in the same location as the user-specific options.bin file, for
example, ..\Users\<user>\AppData\Local\Tekla Structures
\<version>\UserSettings.

NOTE We recommend that you add only system-specific (page 253)
advanced options to the user.ini file. You can also add model-
specific (page 253) advanced options, but the model-specific advanced
options only affect new models that you create. Adding user-specific
advanced options in user.ini may not work as desired as
options.bin is loaded after user.ini and may override the value.

1. Right-click the user.ini file in Windows Explorer and select Open with.
Select a standard text editor from the list of available programs.

2. On a new line, enter set, then a space, then the name of the advanced
option followed by an equal sign, and then the value in a single line.

Tekla Structures only reads lines in the initialization file that start with set.

3. Save user.ini.

4. Restart Tekla Structures for the changes to take effect.

Possible values Example
TRUE
FALSE

set XS_DISABLE_WELD_PREP_SOLID=TRUE
set
XS_UNDERLINE_AFTER_POSITION_NUMBER_IN_HARDSTA
MP=FALSE

1 set XS_SINGLE_CLOSE_DIMENSIONS=1
0 set XS_SINGLE_USE_WORKING_POINTS=0
string value set

XS_USER_DEFINED_BOLT_SYMBOL_TABLE=bolt_symbol
_table.txt

switches set
XS_ASSEMBLY_FAMILY_POSITION_NUMBER_FORMAT_STR
ING=%%TPL:PROJECT.NUMBER%%
Use two switches.

TIP When you are moving to a new version of Tekla Structures, you can use
the Migration Wizard to automatically copy your user.ini file to the
new version. The Migration Wizard appears once you start Tekla
Structures for the first time after installation.
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See also

Location of certain files in hidden folders (page 309)

Typical initialization files (.ini files) and their reading order (page 226)

5.3 File storing options and advanced options

WARNING Changing an advanced option value in .ini files located outside
the model folder does not affect the existing models. You can
only update advanced options in the Advanced Options dialog
box or in the options.ini file located in model folder; not from
an options.ini file located in folders defined for the advanced
options XS_FIRM or XS_PROJECT. The .ini files are read also
when you open an existing model, but only new advanced
options that do not exist in options_model.db or
options_drawings.db are inserted, for example, such options
that are not yet in the Advanced Options dialog box but have
been added in the software.

What happens at model creation

When a new model is created, Tekla Structures reads model-specific option
and advanced option values from the standard.opt file, and from the .ini
files in a certain reading order (page 226), and creates the databases
options_model.db and options_drawings.db, and the options.ini file
under the model folder.

Changing a model-specific options or advanced options

• When you change a model-specific (page 253) option or advanced option
and press OK or Apply in the Options or Advanced Options dialog box,
the settings are taken into use (otherwise you will get a warning message).

• The updated model-specific option or advanced option settings are saved
in options_model.db and options_drawings.db under model folder
when the model is saved.

• In addition, there are also some special model-specific advanced options
that can be updated from the options.ini file located in the model
folder, for example, new advanced options that are not yet in the
Advanced Options dialog box.

• You can change model-specific advanced options only in the Advanced
Options dialog box or in the options.ini file that is located in model
folder.

• You can change model-specific options only in the Options dialog box
manually or by loading standard.opt file values in the dialog box.

Changing a user-specific options or advanced options
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• When you change a user-specific (page 253) option or advanced option,
and press OK or Apply in the Options or Advanced Options dialog box,
the settings are saved in options.bin in ..\Users\<user>\AppData
\Local\Tekla Structures\<version>\UserSettings.

• You can change user-specific advanced options only in the Advanced
Options dialog box.

• You can change user-specific options only in the Options dialog box
manually or by loading standard.opt file values in the dialog box.

Saving customized settings in the Options dialog box

• You can save your own model-specific settings in the Options dialog box by
using the Save button. Then the standard.opt file is saved in the
\attributes folder under the model folder.

Creating a list of advanced options and their values

• You can create a complete list of advanced options in a text file by clicking
Write to file in the Advanced Options dialog box. The list shows the name
of the advanced option, current value and type.

For more information about the standard.opt file, see Standard.opt settings

Settings in the Options dialog box
The Options dialog box (File menu > Settings > Options) contains the current
values for a number of Tekla Structures settings.

Check the settings before you start modeling and change them, if necessary.

The model-specific (page 253) settings in this dialog box are saved in the
options_model.db and options_drawings.db databases in the model
folder, and the user-specific (page 253) settings in options.bin in your local
<user> folder. Changing user- or model-specific options in the Options dialog
box does not require Tekla Structures restart.

You can also save your own settings by using the Save button. Then the
standard.opt file is saved in the \attributes folder under model folder.
You may want to copy this file to your firm folder. When you create a model,
the standard.opt is read from the firm folder.

The options in the Options dialog box are described below.

Clash check settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Depending on how the objects selected for clash checking have been modeled,
different clash check settings are used. For example, if you have modeled
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embeds as studs, steel parts, or reinforcing bars, respectively either bolt
settings, part settings, or reinforcement settings are relevant.

For more information about clash check, see Detect clashes.

Option Description
Allowed penetration volume Defines the allowed clash check

tolerance if small collisions are
acceptable and can be ignored.

If the clashing volume is smaller than
the given value, for example 1 mm3,
then the clash is not reported.

Enter the value in the current volume
units.

Clash check between bolt and
bolted part

Defines whether the model is checked
for clashes that occur between bolts
and the related bolted parts.

If you select Yes, Tekla Structures will
check the bolts against the real
geometry of the bolted part profiles
including roundings, and using the
real bolt dimensions.

Define the clash check clearance
area for bolts

Use to check if bolts collide with parts
and if there is enough space to fix the
bolts.

Enter the clearance dimensions in
relation to the bolt head or nut
diameter d (the larger value), and the
nut thickness t. The clearance in front
of the bolted parts is the same as the
bolt length.

If you do not enter a value, Tekla
Structures uses the default value.

If you clear the check boxes, the
clearance will be zero.

If Tekla Structures cannot find the bolt
head or nut diameter in the bolt
catalog, it uses the shank diameter
instead.

Reinforcing bar vs steel part
clearance (negative value to allow
overlap)

Defines the minimum clearance or
the allowed overlap for reinforcing
bars when they are checked against
steel parts.

To allow reinforcing bars to overlap
steel parts and to ignore the ribs of
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Option Description
bars, enter a negative value. The
maximum overlap is the actual bar
radius.

Tekla Structures only checks the
distance from bar side to part. Tekla
Structures does not check the
distance from bar end to part.

If you clear the check box, Tekla
Structures will not check the
clearance.

Reinforcing bar clearance (negative
value to allow overlap)

Defines the minimum clearance or
the allowed overlap for reinforcing
bars when they are checked against
other reinforcing bars.

To allow reinforcing bars to overlap,
enter a negative value.

If you clear the check box, Tekla
Structures will not check the
clearance.

Reinforcing bar cover thickness Defines the reinforcing bar cover
thickness.

Tekla Structures checks the cover
thickness against the part that the
reinforcing bar belongs to. Tekla
Structures only checks the distance
from bar side to part surface. Tekla
Structures does not check the
distance from bar end to part surface.
If the bar penetrates a part surface, a
clash is reported, even if the bar is
completely inside a cast unit or pour.

If you clear the check box, Tekla
Structures will not check the cover
thickness.

Components settings
Tekla Structures uses the information on the Components tab when it creates
parts using components.

Component properties defined in component dialog boxes override these
settings. Tekla Structures only uses these settings if the corresponding boxes
in the component dialog boxes are empty.
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If you change settings here, Tekla Structures only applies the new settings to
components you subsequently create. Components you created prior to
changing the preferences are not affected.

NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Option Description
Profile names Defines parametric profile prefixes for

plates. It is important that profile
names are set up correctly so that
you can use filters and wizards
effectively.

Profile names must exist in the profile
catalog. If you want to use a
parametric profile that does not have
a name in the catalog, first add it to
the Profile Catalog, then enter it
here. Tekla Structures uses the
Folded plate prefix when you use the
folded plates in components.

Bolts In components, Tekla Structures uses
Factor of bolt edge distance and
Compare edge distance to to check
that the bolts it creates are not too
close to the edge of a part, and warns
you if they are. Check that Factor of
bolt edge distance is set according to
the standard you are using. The
default edge distance setting depends
on your environment.

Compare edge distance defines
whether the edge distance checks are
based on bolt or hole diameter.

To define the default bolt properties
to use in connections, select a Bolt
standard and Bolt size.

Parts Part material defines the default
part material grade.

Part start numbers defines start
numbers for parts that are Welded to
primary and Welded to secondary,
Loose parts, and Assembly loose
parts.

Cross-check these settings against the
numbering series you define to make

Files and folders in Tekla Structures 238 File storing options and advanced options



Option Description
sure they do not overlap. If they
overlap, Tekla Structures may create
two non-identical parts with the same
part number. This generates an error
in the Numbering history log file
(page 281).

Drawing dimensions settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

For more information about dimension settings, see Automatic dimensioning

Option Description
Exaggeration This setting defines the default values

for Exaggeration limit and
Exaggeration scaling.

When you enable the exaggeration of
the dimensions, a drawing dimension
that is narrower than the defined limit
is expanded. Exaggeration limit
defines the default value for this limit.

Exaggeration scaling defines
whether you are using Paper or
Model as the exaggeration scaling
method:

• If you select Paper, the
exaggeration limit is multiplied by
the view scale.

• If you select Model, and the scale
is 1:10, all the dimensions smaller
than 10 mm are exaggerated
regardless of the drawing scale.

For more information about
exaggerated dimensions, see Create
exaggerated dimensions.

Absolute dimensions Show zero in absolute dimensions
--> Yes shows zero at the zero points
in absolute dimensions.

Draw absolute dimension values
parallel to dimension line --> Yes
shows dimensions parallel to
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Option Description
dimension lines in absolute
dimensions.

For more information, see Change the
appearance of absolute dimensions

Dimensions in tags Units, Format and Precision define
the default unit, format and precision
used in dimension tags.

Available units: mm, cm, m, foot -
inch, cm / m, inch, feet.

Available formats: ###, ###[.#],
###.#, ###[.##], ###.##, ###[.###],
###.###, ### #/# and ###/##.###.

Available precision: 0.00, 0.50, 0.33,
0.25, 1/8, 1/16, 1/32, 1/10, 1/100,
1/1000

Show dimension in middle tag of
automatic dimension defines
whether you want to create dual
dimension tags in assembly, single-
part, cast unit, or general
arrangement drawings.

For more information about
automatic dual dimensions, see
Automatic view-level dimensions.

For more information about manual
dual dimensions, see Add dual
dimensions manually

When Tekla Structures creates the
drawing, it adds the lower dimension
tag in the selected unit, format and
precision.

Add mark to reinforcement Dimension Marks settings and
Tagged Dimension Mark settings
define the predefined property files
used for dimension marks and tagged
dimension marks files.

Using the option Dimension line
settings you can save the dimension
properties file in the Dimension
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Option Description
Properties dialog box and take it into
use in rebar dimensioning.

For more information about adding
dimensions and tags, see Add
dimensions to reinforcement .

Dimension line Dimension line extension length
for line arrow defines the length of
the line extension for dimensions that
have line arrows.

Note that line extensions are not
applied to dimensions that have
different arrows from line arrows, and
certain knock-off dimension types.

For the option Tapered skewed
reinforcement group, you can select
skewed or horizontal presentation.

Below is an example of tapered
skewed reinforcement group
dimensions that are shown skewed:

For the option Tapered curved
reinforcement group you can select,
curved or horizontal presentation.

Below is an example of tapered
curved reinforcement group
dimensions that are shown curved:
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Option Description

Drawing objects settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Option Description
Edge chamfer Line color defines the default line

color of the edge chamfers in
drawings.

Line type defines the default line
type of the edge chamfers in
drawings.

These values are overridden by the
values set in the Edge Chamfer
Properties dialog box.

For more information about edge
chamfers, see Edge chamfers in
drawings

General settings
NOTE: On this page, Autosave settings are user specific. All other settings are
model specific. Changing the settings does not require Tekla Structures restart.

Option Description
Autosave Autosave interval: Autosave after

every xx modeling or editing
commands defines how often Tekla
Structures automatically saves a
model and a drawing.

This number represents the number
of commands you have given. For
example, if you create many objects
without interrupting (Esc), it counts as
one command.

Autosave after creating every xx
drawings defines the number of
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Option Description
drawings after which Tekla Structures
automatically saves your work.

For more information, see:

Save a model

Autosaving in multi-user mode
Default adaptivity Off means that adaptivity is not

defined.

Relative defines that handles retain
their relative distances to the nearest
part faces in relation to the part’s
overall size.

Fixed defines that handles retain
their absolute distances to the
nearest part faces.

You can also modify the adaptivity
settings for each part separately.
These modifications override the
default settings in the Options dialog
box.

For more information about
reinforcement and adaptivity, see Use
adaptivity to modify a reinforcement

Load modeling settings
Use the settings on the Arrow size tab to scale loads in model views.

Use the settings on the other tabs of this page to define the building code and
safety factors Tekla Structures uses in load combination.

NOTES:

• Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

• You should not need to change the building code or safety factors during
the project. If you change these settings, you will also need to change the
load group types and check the load combinations.
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Numbering settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Option Description
Position number separator Defines the default position number

separator. The options are dot (.),
comma (,), slash (/), and hyphen (-).

Rebar position number separator Defines the default reinforcing bar
position number separator. The
options are dot (.), comma (,), slash (/),
and hyphen (-).

Part number type Defines the default part number type.
The options are Part number and
Combined assembly / part number.

Orientation marks settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

For details of what affects the part orientation and how, see Indicate part
orientation.

Option Description
North direction Project north (degrees counter

clockwise from global x) defines
which direction is north in the model.
Enter the value in degrees counter-
clockwise from the global x axis.

Part viewing direction Defines which direction parts are
viewed from in drawings.

Beam skew limit

Column skew limit

Tekla Structures uses limit angles to
determine whether a part is a beam
or a column when creating
orientation marks. Tekla Structures
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Option Description
treats parts outside these limits as
braces.

Parts skewed more than 80° are
columns.

Parts skewed less than 10° are
beams.

Preferred location for mark Defines the location of part marks in
drawings, to the left or right end of
the part.

Mark always to center of column This setting only affects columns.

Yes places part marks in the center of
columns in plan views. To indicate
part orientation, include compass
direction (Face direction) in the part
mark instead.

No places part marks on the same
flange in general arrangement and
assembly drawings.

Reinforcement settings
NOTE: Settings on this page are model specific and apply only to rebar sets,
not to single reinforcing bars, reinforcing bar groups, or reinforcement
meshes. Changing the settings does not require Tekla Structures restart, but
you need to use the Rebar set --> Regenerate rebar sets command on the
Concrete tab to apply the changes to existing rebar sets in the model.

Option Description
Concrete cover Define the default concrete cover

thickness between the bars in rebar
sets and the following faces of
concrete parts or pour objects:

• Top

• Bottom

• Sides
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Option Description
Concrete cover on object sides follows
the global coordinate system of the
model, not the current work plane.

You can also define concrete cover
settings for each part separately using
user-defined attributes. These
modifications override the default
settings in the Options dialog box.
For more information, see Define the
reinforcement cover thickness.

Minimum lengths to be created Define Minimum bar length to
prevent Tekla Structures from
creating reinforcing bars that are too
short. This setting is primarily for
straight bars. Enter the minimum bar
length as Distance or as Coefficient
of bar diameter.

Define Minimum straight start/end
leg length for bent reinforcing bars.
Enter the minimum leg length as
Distance or as Coefficient of bar
diameter.

Units and decimals settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

The number located to the right of each option indicates the number of
decimals. The number of decimals affects the input and storage accuracy.
Always use a sufficient number of decimals.

For more information on unit and decimal settings, see Change units and
decimals.

Option Description
Length mm, cm, m, in (decimal), ft

(decimal), ft-in
Angle o, rad
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Option Description
Spring constant

Rot. spring constant

Factor Enter a value using the arrow buttons.
Force
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Option Description
Distributed load

Surface load

Moment

Distributed moment

Temperature oC, oF, K
Deformation
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Option Description
Section dimension

Angle o, rad
Area

Section modulus

Moment of inertia mm4, cm4, in4
Radius of inertia

Torsion constant mm4, cm4, in4
Warping constant mm6, cm6, in6
Cover area
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Option Description
Strength

Modulus

Density
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Option Description
Weight

Strain o/oo, %
Thermal dilat. coeff. 1/oC, 1/oF, 1/K
Ratio o/oo, %
Volume

Length mm, cm, m, in (decimal), ft
(decimal), ft-in

Angle o, rad
Reinforcement area

Transverse reinforc.

Weight

Mass/Length
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Option Description
Volume

Force

Distributed load

Surface load

Moment

Temperature oC, oF, K
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Option Description
Stress

Deformation

See also

File storing options and advanced options (page 234)

Settings defined by advanced options

Advanced options can be user-, model-, system or role-specific:

• User-specific advanced options are saved in your local options.bin file,
which is by default located in C:\Users\<user>\AppData\Local\Tekla
Structures\<version>\UserSettings, and work in the specified way
in all models that you have. The folder can be changed using the advanced
option XS_USER_SETTINGS_DIRECTORY. In the Advanced Options dialog
box, the type is USER. Some user-specific advanced options require
restarting of Tekla Structures after changing the value.

• Model-specific advanced options work in the specified way only in the
current model. They are saved to options_model.db and
options_drawings.db under model folder. In the Advanced Options
dialog box, the type is MODEL or DRAWING. Some special model-specific

Files and folders in Tekla Structures 253 File storing options and advanced options



options that are not visible in the Advanced Options dialog box can be
changed from options.ini file under the model folder.

• System-specific advanced options are general to all sessions of Tekla
Structures, and work in the specified way for all users and in all models. In
the Advanced Options dialog box, the type is SYSTEM. A system-specific
advanced option can be stored to options.ini under model folder by
clicking SYSTEM next to the option and changing it to MODEL(SYSTEM).
Note that the changed value only works for the current model. A
MODEL(SYSTEM) advanced option can be changed back to SYSTEM by
changing it to SYSTEM, and in this case it will be removed from the
options.ini file under model folder. Some system-specific advanced
options require restarting of Tekla Structures after changing the value.

The system-specific advanced options are read from environment .ini
files:

• Global system settings are read from common env_global_default.ini
(page 231) in ..\ProgramData\Tekla Structures\<version>
\environments\common\. These settings are used in all environments.

• Environment-specific system settings are read from
env_<environment>.ini (page 232) in your environment folder. They
override any settings that are defined on a global level in
env_global_default.ini.

• Role-specific system settings are read from role_<role>.ini (page 232)
in environment folder. They override any settings that are defined on a
global and environment level in env_global_default.ini and
env_<environment>.ini.

• Company level system-specific system settings override all other
system-specific advanced options. You can save them in the firm or
project folders by setting the folders for the advanced options XS_FIRM
and XS_PROJECT .

• SYSTEM(ROLE) options are typically role specific. The settings are read
from .ini files and are not saved to the databases. When changed or if the
type is changed, the option will become model specific and be saved to the
databases. MODEL/DRAWING(ROLE) options are SYSTEM(ROLE) options
whose type and/or setting has been changed. The change would be used
when you want the SYSTEM(ROLE) option to be saved with the model to
options_model.db and options_drawings.db under model folder.
These settings can be set back to SYSTEM(ROLE), which will then take into
use the default value.

See also

Typical initialization files (.ini files) and their reading order (page 226)
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Change the advanced option values in the Advanced
Options dialog box
Use advanced options to configure Tekla Structures to suit the way you work,
or to comply with specific project requirements or industry standards. Change
the advanced options only in the Advanced Options dialog box. The settings
in the Advanced Options dialog override the settings in any other
initialization file.

1. On the File menu, click Settings --> Advanced options to open the
Advanced Options dialog box, or press Ctrl+E.

2. Browse the categories to find the advanced option you want to set. 

You can also enter a search term in the Search box. To search the search
term in all categories, select In all categories. You can also use wildcards.
For example, to find all advanced options that have the words anchor and
filter and that have any characters between these two words, enter
anchor*filter.

3. Set the advanced option to the desired value by entering the value or by
selecting the value from the list. 

• You can change the type of the role-specific advanced options from
SYSTEM (ROLE) to MODEL (ROLE) or DRAWING(ROLE) and vice versa
from the list next to the option type. When you change the option type
to SYSTEM(ROLE), the value automatically changes to the default
value. When you enter a value for a SYSTEM (ROLE) option, it changes
to MODEL (ROLE) or DRAWING(ROLE).

• You can change the type of system-specific advanced options from
SYSTEM to MODEL(SYSTEM), in which case the value is saved in the
options.ini file in the model folder. If you reset the advanced option
back to SYSTEM, it will be removed from the options.ini file.

• You can use switches with some advanced options, for example, to
define the contents of marks: %TPL:PROJECT.NUMBER%.

• If you need to enter a folder path, you can type a backslash at the end
of the folder path or leave it out.

4. Click Apply or OK. 

TIP To create a complete list of advanced options in a text file, click
Write to file. The list shows the name of the advanced option
together with its current value and type. Note that writing to a file is
only an export of the current settings, it is not another way of
changing the advanced options.

See also

Settings defined by advanced options (page 253)
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5.4 Input files (.inp files)
Tekla Structures uses input files to manage dialog boxes and for defining how
components work. All input files have the extension .inp.

Input files that you can use, for example, for customizing Tekla Structures are
listed below.

File Description
analysis_design_conf
ig.inp

Contains settings for analysis and design.

fltprops.inp Includes materials and dimensions of available
flat bars (page 265).

objects.inp Used to manage user-defined attributes
(page 259).

pop_mark_parts.inp Contains settings for pop-marking.
privileges.inp Used to control access rights.
profitab.inp Contains available parametric profiles (page 162).
rebar_config.inp Contains settings for reinforcement marks.
rebar_schedule_confi
g.inp

Contains internal bending types of reinforcing
bars and their mapping to area specific bending
codes.

Rebar Shape Manager is a more versatile way to
define reinforcing bar bending shapes.

See also

Environment database file (page 260)

Properties of the objects.inp file

The example below shows the main properties of objects.inp.

Property In the example Description
attribute or 
unique_attribute

attribute attribute is a regular
attribute, which is
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Property In the example Description
copied with other part
properties.

unique_attribute is a
non-copyable attribute.
The value of the
attribute is never copied
to another part. For
example part checking
status attributes usually
cannot be copied.

attribute_name MY_INFO_1 Attribute name, used to
find the attribute value.

Ensure that Tekla
Structures does not
already use the attribute
name you use. Consider
using a prefix that
ensures the name is
unique, for example,
your initials, or an
abbreviation of your
company name.

The attribute name is
case-sensitive. Do not
use spaces or reserved
characters in attribute
names. The maximum
length of the name can
be 19 characters.

To include the attribute
in a report or template,
add the name of the
attribute to your layout
in the Template Editor.
When you run a report
or create a drawing,
Tekla Structures displays
the current value of the
attribute.

label_text My Info 1 Label that Tekla
Structures displays in
the dialog box.

Some default attributes
have prompts like 
j_comment, meaning
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Property In the example Description
that the prompt comes
from the joints.ail
message file.

value_type string integer or float for
numbers

string for text

string_not_modifiab
le for text whose
modification is
prevented. A field with
the 
string_not_modifiab
le property is always
displayed as dimmed
and it cannot be
switched on or off. The
value in the field is not
saved when clicking the
Apply button or
modified when clicking
the Modify button.

option for lists

date for date with small
calendar

date_time_min for
date and time [12:00]
with small calendar

date_time_sec for
date and time [12:00:00]
with small calendar

field_format %s Definition of the field
format in the dialog box

• %s for strings

• %d for numbers
special_flag no no or yes

For parts: consider in
numbering
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Property In the example Description
For drawings: display the
attribute value in
drawing list

For other elements: no
effect

check_switch none none
This option is not used.

attribute_value_max 0.0 0.0
This option is not used.

attribute_value_min 0.0 0.0
This option is not used.

Define and update user-defined attributes (UDAs)
The property pane and many dialog boxes contain user-defined attributes
(UDAs) for various objects, including beams, columns, bolts and drawings.
Tekla Structures displays these fields when you click the More button in the
property pane or the User-defined attributes button in a dialog box. For
example, comment, locked, and erection status are user-defined attributes.

When you define new user-defined attributes

The user-defined attributes are managed in the objects.inp (page 256) file. To
define new user-defined attributes, create your own objects.inp file in the
model, project or firm folder. After adding your own user-defined attributes,
you need to run the Diagnose and change attribute definitions command
to update the definitions (page 260) in the model.

When you define new user-defined attribute (page 261), make the definition of
the user-defined attribute unique. This is because a user-defined attribute
cannot have different definitions for different object types, such as beams and
columns.

The object.inp files are merged so that if there are user-defined attributes
in any of the files, they are displayed in the user interface. Tekla Structures
merges the files in a way that eliminates duplicate attributes. If Tekla
Structures encounters the same attribute name in different objects.inp
files, the attribute from the first read objects.inp file will be used.

If you need to have several objects.inp files in the same folder, you can use
a suffix in the file name to use all the files. This enables having several
objects_<suffix> .inp files in the same folder. The file name could be
objects_precast.inp, for example.
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WARNING Do not copy the objects.inp file in the ..\environments\common
\inp\ folder. Copying the file creates unnecessary duplicates and later
objects.inp updates by Tekla Structures can be lost.

Tekla Structures reads the objects.inp files from the following folders in the
following order:

1. model folder

2. project folder

3. firm folder

4. system folder

5. inp folder

See also

Environment database file (page 260)

Update definitions of user-defined attributes (UDAs) in a model
When you have changed definitions of a user-defined attribute by modifying
the objects.inp file, you need to update the definitions in the model.

1. Open the model.

2. On the File menu, click Diagnose & repair and in the Utilities area, click
Diagnose and change attribute definitions. 

The Diagnose & Change Attribute Definitions dialog box opens.

3. Select an attribute from the list on left side to see the comparison of
current definitions and objects.inp definitions.

4. Select the definitions you want to update in the Object classes with
Objects.inp differences compared to current settings list.

5. Click Change current settings to selected Objects.inp settings.

See also

Define and update user-defined attributes (UDAs) (page 259)

Environment database file (page 260)

Properties of the objects.inp file (page 256)

Example: Create and update a user-defined attribute (UDA) (page 261)

Environment database file
To guarantee consistent model behavior when a model is used with different
roles, the environment database file (environment.db) contains the
definitions of the user-defined attributes (UDAs) used in the model.
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When you create a new model, Tekla Structures merges the definitions from
your objects.inp (page 256) files to the environment.db file. Later, when you
add new user-defined attributes in the objects.inp file, the definitions are
saved in environment.db as you open the model.

You can modify your user-defined attributes (page 259) in an objects.inp
file but the changed definitions do not come into effect automatically. If there
are conflicts, the definitions in environment.db win. You need to run the
Diagnose and change attribute definitions command to see the conflicts
between environment.db and objects.inp, and select the attribute
definitions that you want to update.

See also

Update definitions of user-defined attributes (UDAs) in a model (page 260)

Example: Create and update a user-defined attribute (UDA) (page 261)

Example: Create and update a user-defined attribute (UDA)
This example shows how to create your own user-defined attribute (UDA) and
update the model to use the changed attribute definition.

Create a user-defined attribute

1. Create a new model and save it.

The user-defined attributes in the model are merged from objects.inp
(page 259) files and Tekla Structures saves the attribute definitions in the
environment.db (page 260) file in the model folder.

2. Close the model.

3. Create an input file called objects.inp in the model folder by using a
standard text editor.

4. Enter the following information in objects.inp. For details about the
properties in the attribute string, see objects.inp (page 259).

/
*********************************************************
******************/
/* Part attributes */
/
*********************************************************
******************/
part(0,"Part")
{
/* User defined tab page */
tab_page("My UDA tab")
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{
/* User defined attribute */
attribute("MY UDA", "My UDA", string,"%s", no, none,
"0,0", "0,0")
{
value("", 0)
}
}
tab_page("My UDA tab", "My UDA tab", 19)
modify (1)
}
/
*********************************************************
******************/
/* Column attributes */
/
*********************************************************
******************/
column(0,"j_column")
{
/* Reference to the user defined tab page that is defined
above in */
/* the part() section: */
tab_page("My UDA tab", "My UDA tab", 19)
modify (1)
To see the example text file, click objects.inp - example 1.

NOTE If you want to create a user-defined attribute that also affects
numbering, set the special_flag (page 256) property of the
attribute to yes (it is no in the example above). Also, just like in
the example above, the definition of the tab_page must be in the 
part section, and the column (beam, etc.) section must have only
a reference to it.

5. Save objects.inp.

Test the user-defined attribute

1. Open the model.

2. Create a steel column.
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3. Double-click the steel column to open its properties in the property pane.

4. Click the More button.

5. Go to My UDA tab.

6. Enter a value in the My UDA box.

7. Click Modify.

8. Copy the steel column.

9. Check the My UDA box of the new steel column.

The attribute value was also copied.

10. Close the model.

Modify the user-defined attribute to make it unique

1. Open the objects.inp file in the model folder by using a standard text
editor.

2. Enter unique_ before the user-defined attribute.

/
*********************************************************
******************/
/* User-defined attributes */
/
*********************************************************
******************/
part(0,"Part")
{
/* Common tab pages for part attributes */
tab_page("My UDA tab")
{
unique_attribute("MY UDA", "My UDA", string,"%s", no,
none, "0,0", "0,0")
{
value("", 0)
}
}
tab_page("My UDA tab", "My UDA tab", 19)
modify (1)
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}
/
*********************************************************
******************/
/* Column attributes */
/
*********************************************************
******************/
column(0,"j_column")
{
tab_page("My UDA tab", "My UDA tab", 19)
modify (1)
}
This makes the user-defined attribute unique, meaning that the value of
the user-defined attribute will not be copied to another part.

3. Save objects.inp.

To see the example text file, click objects.inp - example 2.

Test the unique user-defined attribute

1. Open the model.

2. Enter a value in the My UDA box for a steel column and click Modify.

3. Copy the steel column.

4. Check the My UDA box of the new column.

5. The value was copied, so the user-defined attribute in the model is not
unique. There is a conflict between the environment.db and
objects.inp definitions.

Update the definitions of user-defined attributes

1. On the File menu, click Diagnose & repair and in the Utilities area, click
Diagnose and change attribute definitions.

The Diagnose & Change Attribute Definitions dialog box opens.

2. Select My UDA in the Attribute area on the left.

You can see that My UDA is not unique in the current setting, but it is set
to unique in objects.inp.
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3. Select the definition in the area on the right.

4. Click Change current settings to selected Objects.inp settings.

Now the definition of the user-defined attribute is updated in the model.

If you now copy a steel column that has a value for My UDA, the value is
not copied to the new column.

See also

Update definitions of user-defined attributes (UDAs) in a model (page 260)

Define and update user-defined attributes (UDAs) (page 259)

Properties of the objects.inp file (page 256)

Show plates as flat bars in drawings and reports
Tekla Structures can show plates as the equivalent flat bars for manufacturing.
Tekla Structures displays the plates as flat bars in reports and drawings.

1. Set the advanced option XS_USE_FLAT_DESIGNATION to TRUE.

2. Indicate the prefix you want to use for flat bars using the advanced option
XS_FLAT_PREFIX. 

For example, XS_FLAT_PREFIX=FLAT.

3. Set other platework-related advanced options as required.

4. Define materials, thickness, and width of available flat bars in the
Fltprops.inp (page 265) file.

TIP • To prevent Tekla Structures from displaying the profile in metric units in the
US Imperial version, add the flat bar prefix to the profitab.inp file as a
parametric profile.

• See also page Platework in the Advanced Options dialog box for
information about advanced options related to platework.

Define flat bar sizes with the Fltprops.inp file
Use the Fltprops.inp file, located in ..\ProgramData\TeklaStructures
\<version>\environments\<environment>\profil, to define flat bar
thickness, width and material.

NOTE Copy the Fltprops.inp file to a model, project or firm folder and then
modify the file in the new location as required.

The first row in the file contains flat bar material definitions (enclosed in
quotes " ") followed by plate thicknesses. If you do not define a material, you
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can use all materials for all flat bars. The following rows define the widths of
available flat bars.

The units are millimeters.

Example

Fltprops.inp contains the following data:

With the above data, Tekla Structures displays the following plates as flat bars:

Plate Material
5x40, 5x45, 6x50, 6x55 All materials
8x60, 8x65, 10x70, 10x75 S235
10x100, 10x110, 15x200, 15x220 S275J0

The flat bars get the prefix that is set in the XS_FLAT_PREFIX advanced option.

See also

Show plates as flat bars in drawings and reports (page 265)

Define unfolding parameters in the
unfold_corner_ratios.inp file
The unfolding parameters define the location of the neutral axis when a profile
is unfolded. The neutral axis is a line which runs along the length of a profile
where stress and strain are equal to zero. Tekla Structures uses these
parameters to create NC files and to display unfolded profiles in single-part
drawings.

To define unfolding parameters, modify the unfold_corner_ratios.inp
file, located in ..\ProgramData\Tekla Structures\<version>
\environments\common\system, using a standard text editor. You can copy
the unfold_corner_ratios.inp file to a model, project or firm folder and
then modify the file in the new location as required. Tekla Structures searches
for this file in the default search order.

After modifying the unfold_corner_ratios.inp file, restart Tekla Structures
for the changes to take effect.
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NOTE The settings in the unfold_corner_ratios.inp file have no effect
in the following cases:

• If the advanced option
XS_USE_OLD_POLYBEAM_LENGTH_CALCULATION is set to TRUE.

• If the advanced option
XS_CALCULATE_POLYBEAM_LENGTH_ALONG_REFERENCE_LINE is
set to TRUE. This only applies to polybeams with straight sections.

Unfold parameter properties

See below for an example of unfolding parameters in the
unfold_corner_ratios.inp file and the descriptions of the parameters.

1 HE300A S235JR 0 180 2 0 1000 .7

Property In the example Description
Type 1 1 is polybeams

2 is plates modeled as
polybeams (for example,
PLT)

3 is for parts which are
not unfolded and follow
the old polybeam
calculation (for example,
the line 3 L* * disables
unfolding of L profiles)

Profile HE300A You can also use
wildcards with profile,
for example, HE300*.

Material S235JR You can also use
wildcards with material,
for example, S235*.

Rotation / thickness min 0 For polybeams: the
minimum angle when
the profile is rotated
around its longitudinal
axis

For plates: the minimum
thickness of plate

Rotation / thickness max 180 For polybeams: the
maximum angle when
the profile is rotated
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Property In the example Description
around its longitudinal
axis

For plates: the maximum
thickness of plate

Flag 2 This property defines
what kind of parts are
affected by the next two
properties.

1 is sharp folds. Only
polybeams with straight
chamfers are affected.

2 is curved bends. Only
polybeams with curved
chamfers are affected.

Angle / radius min 0 For sharp folds: the
minimum angle

For curved bends: the
minimum radius

Angle / radius max 1000 For sharp folds: the
maximum angle

For curved bends: the
maximum radius

Ratio .7 Defines how much the
profile stretches or
shrinks when unfolded.

Ratio = (1 - the relative
location of the neutral
axis).

If only the inner surface
of the profile shrinks, the
ratio is 1. If only the
outer surface of the
profile stretches, the
ratio is 0. By default, the
ratio is 0.5 for length
calculation and 0.0 for
bending radius
calculation.

Tekla Structures applies
the unfolding ratio if the
profile properties are
within the range
indicated by the
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Property In the example Description
minimum and maximum
values.

See also

Folder search order (page 307)

5.5 Data files (.dat files)
Data files contain information used by certain components, or Rebar shape
manager, for example.

WARNING These files affect the operation of components or Rebar shape
manager. Do not modify the files listed here unless you are an
administrator.

File Description
joints.dat Contains data used in Handrailing (1024) and

Stanchions (S76) components. Used in the
Stanchion connection type option.

railings.dat Contains data used in Handrailing (1024). Used in
the Stanchion connection type option.

steps.dat Contains the data for Stairs (S82) and Stairs
(S71). Used in the Step profile and Catalogue
step options.

std_flange_plates.d
at

Contains data for Tapered column (S99). Used in
the options:

• Outer flange profile

• Inner flange profile

• Top plate profile
std_stiffener_plate
s.dat

Contains data used in Tapered column (S99).
Used in the Horizontal stiffener profile box.

marketsize.dat Contains available market sizes for certain
material grade. Can be used with fMarketSize()
function in the custom component editor.

import_macro_data_t
ypes.dat

Contains the user-defined attributes that you can
include in an input file in attribute import.

RebarShapeManager.C
ustomProperties.dat

Contains the custom properties, template
attributes, and user-defined attributes that you
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File Description
can use in bending shape rules in Rebar shape
manager.

Note that default data files are read from the environment's \system folder,
but user-defined data files are stored in the model’s \attributes folder.

See also

Define flat bar sizes with the Fltprops.inp file (page 265)

5.6 Message files
Tekla Structures uses the information in the message files to display messages
in the user interface. Message files include, for example, texts used in dialog
boxes.

• Message files with the .ail extension are located in the folder ..\Tekla
Structures\<version>\messages.

• Message files with the .xml extension are located in the folder ..\Tekla
Structures\<version>\messages\DotAppsStrings.

The files include texts in languages in which the Tekla Structures user interface
is available.

See also

Customize message files (page 270)

Customize message files
You can customize the messages that Tekla Structures displays in the user
interface.

1. Do one of the following: 

• To modify an .ail message file, go to the ..\Tekla Structures
\<version>\messages folder.

• To modify an .xml message file, go to the ..\Tekla Structures
\<version>\messages\DotAppsStrings folder.

2. Open the message file you want to customize using a standard text editor.

3. Modify the message as required.

4. Save the message file.

Files and folders in Tekla Structures 270 Message files



Example: customize a message file

In this example, you will modify a message that Tekla Structures uses for near
side plates in drawings. You want Tekla Structures to display (NS) instead of 
(N/S).

1. Go to the ..\Tekla Structures\<version>\messages folder.

2. Open by_number.ail using a standard text editor.

The by_number.ail file contains both prompts and default texts that
Tekla Structures uses in drawings.

3. Browse to the following section:

string by_number_msg_no_675
{
...
entry = ("enu", "(N/S)");
};

4. Change (N/S) to (NS) in the entry row.

5. Save and close the file.

See also

Message files (page 270)

5.7 Standard files
Standard files are property files that Tekla Structures uses by default when you
apply commands.

These properties are displayed in the property pane of different model
objects, such as beams, columns or plates, or in the dialog boxes of other
objects.

• In the property pane: the properties are taken into use when you select the
standard option in the upper part of the property pane. The properties are
loaded immediately, and the values that are different from the currently
selected object are highlighted in the property pane.

Files and folders in Tekla Structures 271 Standard files



• In the dialog boxes: the properties are taken into use when you select the
standard option in the list next to the Load button, and click the Load
button.

Standard files are named standard.* where the symbol * is the file name
extension. For example, standard.clm file is used for column properties.
Note that default standard files are read from the environment's \system
folder, but user-defined standard files are stored in the ..
\TeklaStructuresModels\<model_name>\attributes folder.

List of standard files saved with Save defaults command

You can save a set of standard files in the model folder. You can then copy the
standard files to the project or firm folders for future use, to set up Tekla
Structures to suit the way you work.

To save a set of standard files in the model folder, go to Quick Launch, start
typing save defaults and select the Save defaults command from the list.
Tekla Structures saves a set of standard files in the attributes folder in the
current model folder.

File Property
standard.cpl Contour plate properties
standard.fpl Folded plate properties
standard.prt Beam properties
standard.clm Column properties
standard.crs Orthogonal beam properties
standard.dia Twin profile properties
standard.scr Bolt properties
standard.wld Weld properties
standard.prf Project properties
standard.ler Layer properties
standard.fms Plotting frames
standard.num Numbering setup
standard.mvi Model view properties
standard.ipc Concrete item properties
standard.ips Item properties
standard.bpl Plate properties

See also

Settings in the Options dialog box (page 235)
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5.8 Property files
Tekla Structures stores a number of files, all of which contain object
properties, in the current model folder.

• In the property pane: Tekla Structures creates property files when you click

.

• In the dialog boxes: Tekla Structures creates property files when you click
Save or Save as.

Note that the default property files are read from the environment's \system
folder, but user-defined property files are stored in the model’s \attributes
folder.

Example

You can change the standard column properties to create a new type of
column that you call custom1.

1. In the property pane, enter or modify the properties you want to save.

2. In the box next to the  button, enter a name for the new set of
properties, for example, custom1.

3. Click .

The set of properties has now been added to the list of saved properties
in the current model folder, in the \attributes folder.

5.9 Catalog files
Tekla Structures uses ASCII and binary files to manage profile, material,
reinforcing bar, bolt and bolt assembly catalogs.

Each environment has its own folder, where the files related to different
catalogs are stored. For example, ..\environments\uk\profil\ contains
the files for managing catalog files used in the United Kingdom.

The following table lists files and file types related to catalogs.

File type File name Used for Located in
.inp profitab.inp Defines the names

that you can use
for parametric
profiles.

..\ProgramData
\Tekla Structures
\<version>
\environments
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File type File name Used for Located in
\<environment>
\profil

rebar_databas
e.inp

Contains details of
the reinforcement
used in concrete
structures.
Includes both the
standard bending
radii and the
standard hook
dimensions.

..\ProgramData
\Tekla Structures
\<version>
\environments
\<environment>
\profil

mesh_database
.inp

Contains details of
the reinforcement
meshes used in
concrete
structures.

..\ProgramData
\Tekla Structures
\<version>
\environments
\<environment>
\profil

.cnv matexp_<softw
are>.cnv

Contains
information to
convert material
names when
transferring model
information using
links. For example,
converts S235JR to
FE360B for DSTV.

..\ProgramData
\Tekla Structures
\<version>
\environments
\<environment>
\profil

prfexp_<softw
are>.cnv

Contains
information to
convert profile
names when
transferring model
information using
links. For example,
converts HEA100
to HE100A for
DSTV.

..\ProgramData
\Tekla Structures
\<version>
\environments
\<environment>
\profil

.clb For example,
RU_CF.clb

Contains the
definitions of
parametric
profiles used in
profitab.inp.

..\ProgramData
\Tekla Structures
\<version>
\environments
\common\inp

.lis You can define
the file name
while exporting.

Created when you
export bolt, profile
and material
catalogs.

You can define the
folder where to export
the files.

Files and folders in Tekla Structures 274 Catalog files



File type File name Used for Located in
.db assdb.db The bolt assembly

catalog.
..\ProgramData
\Tekla Structures
\<version>
\environments
\<environment>
\profil

screwdb.db The bolt catalog. ..\ProgramData
\Tekla Structures
\<version>
\environments
\<environment>
\profil

.bin profdb.bin The profile
catalog.

..\ProgramData
\Tekla Structures
\<version>
\environments
\<environment>
\profil

matdb.bin The material
catalog.

..\ProgramData
\Tekla Structures
\<version>
\environments
\<environment>
\profil

See also

Customize the profile catalog (page 146)

Customize the material catalog (page 138)

Customize the bolt catalog (page 205)

5.10 Font files and font conversion files
You can define the location of font files with the advanced option 
DXK_FONTPATH in the teklastructures.ini or your environment
initialization file. For example, you can use fonts available in the folder ..
\ProgramData\Tekla Structures\<version>\environments\common
\fonts.

This folder includes the following fonts:

Font Font type
fixfont.fon Tekla Structures system font
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Font Font type
romco.fon Tekla Structures system font
romsim.fon Tekla Structures system font
romsim8.fon Tekla Structures system font
GOST 2.304-81 type A.ttf True Type font (Cyrillic)
GOST 2.304-81 type B.ttf True Type font (Cyrillic)

Fonts are converted using font conversion files available in the same folder:

File Description
template_fonts.cnv Used for converting Tekla Structures

system fonts (Template Editor fonts)
to Windows fonts in DWG/DXF export.

dxf_fonts.cnv Used for converting True Type fonts
to SHX fonts (font format understood
by AutoCAD) in DWG/DXF export.

See also

Initialization files (.ini files) (page 226)

5.11 Symbol files
Symbols are used for example in various places in drawings, for example, as
separate objects, and in marks.

You can create symbols with Symbol Editor. In this case, the file name
extension is .sym. You can also use symbols of .dwg format.

Tekla Structures symbol files are by default located in the folder ..
\environments\common\symbols.

5.12 Files related to templates, reports and drawings
Tekla Structures has several files that relate to templates, reports, drawings
and printing.

File or file type Description Location
.rpt Report templates

(page 311) created with
the Template Editor

..\environments
\<your_environment>
\system\ and its role-
specific sub-folders

Files and folders in Tekla Structures 276 Symbol files



File or file type Description Location
.tpl Drawing templates

(page 311) created with
the Template Editor

..\environments
\<your_environment>
\template

.lay Layout definitions
created with the
Drawings & reports -->
Drawing properties -->
Drawing layout
command.

..\environments
\<your_environment>
\system\ and its role-
specific sub-folders

plotdev.bin Printer device definitions
created with the

Printer Catalog printer
instances.

..\environments
\<your_environment
\system

xdproc Master Drawing
Catalog rule set

..\environments
\<your_environment>
\system\ and its role-
specific sub-folders

xdproc.master Master Drawing
Catalog master drawing
file

..\environments
\<your_environment>
\system\ and its role-
specific sub-folders

xdproc.master.png Master Drawing
Catalog sample
(preview) image files

..\environments
\<your_environment>
\system\ and its role-
specific sub-folders

xdproc.png Master Drawing
Catalog thumbnail
image files

..\environments
\<your_environment>
\system\ and its role-
specific sub-folders

Note that default drawing, report, and template files are read from the
environment's \system folder (or from the \template folder), but user-
defined files are stored in the model’s \attributes folder.

5.13 Image files
Tekla Structures uses image files in several places:

• In templates in drawings

• In drawing snapshots

• In component dialog boxes and thumbnails
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• In drawing line types

• In the surface treatment dialog box

• In the Master Drawing Catalog for thumbnails and sample images

• In profile properties dialog boxes

The following image file formats are supported in Tekla Structures:

• In templates: bmp, gif, grd, jpg, ppm, pgm, rle, tiff and xkrl
• In drawing snapshots, and int thumbnail and sample images for the

Master Drawing Catalog: png
• Other situations: bmp

See also

Add images in a template (page 326)

5.14 Log files
Tekla Structures writes information to log files when you, for example, number
a model or save a model.

TIP All log files are located in the current model folder.

File Description
analysis.log Tekla Structures stores information in

this file when you run the analysis.
The file also contains information on
the errors that occurred during load
distribution.

check_database.log Tekla Structures stores information in
this file when you run the Repair
command in File menu --> Diagnose
& repair --> Model.

ClashCheck.log Contains clashes found in the most
recent clash check.

conflict.log Contains conflicts that have occurred
in the multi-user mode when more
than a one user has modified an
object.

drawing_cloning.log Contains information on cloned
drawings.

drawing_history.log Contains information on drawing
history. Use the advanced option XS_
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File Description
DRAWING_HISTORY_LOG_TYPE to
define the contents of the file.

dstv_nc.log Each time you create NC files, Tekla
Structures stores information in this
file about the processed assemblies.

filetranerror.log Used only for cold rolled components,
such as Albion, Ayrshire, and Hispan.
If the File Transfer components do
not work as expected, Tekla
Structures stores error messages in
this file.

numberinghistory.txt Contains full details of each
numbering session carried out on the
model. Each session is in a different
block of the file.

save_history.log Tekla Structures stores information in
this file each time you save a model.

TeklaStructures.log Contains information on the entire
Tekla Structures session from opening
the model to closing it. The file
contains, for example, errors and
information on which catalogs were
used.

wizard.log Tekla Structures stores information in
this file when you run a drawing rule
set (wizard) file. The file contains, for
example, errors and number of
drawings created.

See also

View a log file (page 279)

View a log file
The parts that are listed in a log file can be viewed in the model.

1. Open the model whose log history you want view.

2. On the File menu, click Logs and select a log file you want to see. 

• Clash Check history log (ClashCheck.log)

• Session history log (TeklaStructures.log)

• Numbering history log (numberinghistory.txt)

• Saving history log (save_history.log)
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• Drawing history log (drawing_history.log)

• Analysis history log (analysis.log)

3. In the log file, select a row which contains a part or an assembly. 

Parts and assemblies have the prefix guid.

Tekla Structures highlights the part in the model. If there are several parts
or assemblies on a row and you select that row, Tekla Structures highlights
all the parts in the model. You can also select parts on different rows.

4. If you want to view the log files in a viewer that has been associated with
the file type, for example, in Microsoft Notepad, on the File menu click
Logs and select View with the default application.

TIP You can access a part’s or an assembly’s pop-up menu from the log file
by right-clicking a row that contains a part or an assembly. Tekla
Structures displays the same pop-up menu as when you right-click a part
or an assembly in the model.

See also

Log files (page 278)

Change the name and location of session history log file (page 280)

Numbering history log file (page 281)

Change the name and location of session history log file
You can change the name and location of the session history log file
(TeklaStructures.log). Do not change these settings if you are not an
administrator.

1. Open a suitable initialization file (page 226) for editing. 

For example, user.ini or company.ini.

2. To change the name of the session history log file, add the following line
to the initialization file: 

set XS_LOG_FILE_NAME=<name of the file>
For example:

set XS_LOG_FILE_NAME=sessionhistory.log
The default name is TeklaStructures.log.

3. To change the location of the session history log file, add the following
line to the initialization file: 
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set XS_LOGPATH=<location of the file>
The default location is ..\Users\<user>\AppData\Local\Trimble
\TeklaStructures\<version>

4. Save the initialization file.

5. Restart Tekla Structures for the changes to take effect.

See also

Log files (page 278)

View a log file (page 279)

Numbering history log file
The numberinghistory.txt log file contains full details of each numbering
session carried out on the model. Each numbering session is in a different
block of the file.

NOTE If you remove or delete the numberinghistory.txt log file, Tekla Structures
generates a new file with the same name next time when you run numbering.
The new file does not contain a history of previous numbering sessions.

Example

Below is an example of the contents of a numberinghistory.txt log file.

1 User name, date and time of the numbering.
2 Numbering method.

• Modified numbering is displayed when you run the Number
modified objects command.

• Modified numbering for selected series is displayed
when you run the Number series of selected objects
command.

• Diagnose & Repair Numbering: All is displayed when you
run the Diagnose & repair numbering: All command.
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• Diagnose & Repair Numbering: Series of selected
objects is displayed when you run the Diagnose & repair
numbering: Series of selected objects command.

• Renumber all is displayed when you select the Renumber all
option in the Numbering Setup dialog box.

3 Some Compare options set in the Numbering Setup dialog box are
displayed in the numbering.history log file only if they are set
differently than the default value:

• Compare modified to old parts
• Compare new to old part
• No holes comparing
• No part name comparing
• Beam orientation
• Column orientation
Some Compare options are not displayed at all:

• Reinforcing bars

• Embedded objects

• Surface treatment
4 Numbering options.

• Use old numbers is displayed only when you have selected
the Re-use old numbers option in the Numbering Setup dialog
box.

• Check for standard parts is displayed only when you have
selected the Check for standard parts option in the
Numbering Setup dialog box.

5 Tolerances are set in the Numbering Setup dialog box.
6 Changes in the position numbers and in the numbering series

during one numbering session.
 In addition:

If a numbering series overlaps another, the errors are written to the
log file.

See also

Numbering series in the numbering history log file (page 282)

Numbering series in the numbering history log file
Tekla Structures lists information on the numbered parts and assemblies in
the numberinghistory.txt log file.
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Example 1

The numberinghistory.txt log after one concrete beam B/20 has been
created and numbered:

1 Part position number.

• The part with the GUID 
ID510F595D-0000-0030-3133-353939383335 is a part of the
numbering series Concrete_B-20/1.

• The part becomes the first part in the numbering series: 
Concrete_B-20/0 -> Concrete_B-20/1.

2 Assembly position number.

• The assembly ID of the part is 
ID510F595D-0000-002F-3133-353939383335.

• The part belongs to the B/20 assembly numbering series, which
is also the cast unit numbering series.

• The part gets the assembly position number: B/20: B/0 ->
B/20.

Example 2

The numberinghistory.txt log after another concrete beam B/21 has been
created and numbered:
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1 Part position number of the new part.

• The part with the ID 
ID510F595D-0000-0030-3133-353939383335 is part of the
numbering series Concrete_B-20/1.

• The part becomes the second part in the numbering series: 
Concrete_B-20/0 -> Concrete_B-20/2.

2 Assembly position number.

• The assembly ID of the part is 
ID510F595D-0000-002F-3133-353939383335.

• The part belongs to the B/20 assembly numbering series, which is
also the cast unit numbering series.

• The part gets the assembly position number: B/20 B/0 ->
B/21.

See also

Numbering history log file (page 281)

5.15 Model folder files and file name extensions
The following table lists the folders, files and file name extensions of files
located in a Tekla Structures model folder.

Files in the Tekla Structures model folder

File or file name extension Description
.db1 Model database
.db2 Numbering database
environment.db Database for user-defined attribute

definitions
xslib.db1 Contains information on user-defined

connections and details, and default
component descriptions.

.idrm Mapping file, which handles IDs. Do
not modify.

xslib.db2 Contains numbering information.
options_model.db and
options_drawings.db

Contain values for model-specific
options from the Options dialog box
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File or file name extension Description
and values for model-specific
advanced options from the Advanced
Options dialog box. When a model is
created, Tekla Structures reads
model-specific options and advanced
options values from the
standard.opt file and .ini files in
the environment folders and saves
them in these two databases.

history.db Model history database for Tekla
Model Sharing and multi-user
models.

xsdb.xs File used for displaying the name of
the model in the Open dialog box.

xs_user.<username> Contains interface settings specified
by the user.

Each time a model is saved, an
xs_user.<username> file is created
or updated. These settings are user
specific. If the xs_user.<username>
file is not found in the model folder
when you open the model, Tekla
Structures searches for the
xs_user.default file in the
following folder search order: model,
model\attributes, project, XS_FIRM
\attributes, system. If this file is not
found, Tekla Structures default
settings will be used.

This file contains settings for many of
the options in the Options dialog box
and the settings for the icons on the
Selecting and Snapping toolbars.

save_history.log Tekla Structures stores the
information in this file each time the
model is saved. The file includes the
saving time, date and information on
any conflicts during saving.

notification_report.xsr File used for displaying a notification
report of assignments when you open
a model.

TeklaStructuresModel.xml Contains information on the Tekla
Structures session, for example on
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File or file name extension Description
opening, closing and what catalogs
are being used.

dotlog.txt A log file that contains information on
Tekla Open API application use.

.locked A temporary file that locks the model
folder files to prevent modifications
while the model is in use.

.bak A backup copy of the model database.
assert.txt A log file that contains information on

assertion errors.
ClashCheck.txt A log file that contains information on

clashes found in the most recent
clash check and the date and time of
the clash check.

ClashCheck.history A file that contains information on all
clashes found in all clash checks and
the dates and times of the clash
checks.

wizard.txt Tekla Structures stores information in
this file when you run a drawing rule
set (wizard) file. The file contains, for
example, errors, number of drawings
created, and information on which
commands were used.

.lis Different catalogs can be exported
from and imported to different Tekla
Structures models as .lis files.
These include profile, material and
bolt catalogs.

.tsc Shapes can be exported from and
imported to different Tekla Structures
models as .tsc files.

.This_is_multiuser_model Contains information about the PC
running the Tekla Structures multi-
user server.

Do not alter or delete this file in
normal circumstances. If you move a
model to a different server, you
should delete this file. Tekla
Structures generates a new file with
the same name.

ComponentCatalog.xml Contains the model level catalog
definitions of the Applications &
components catalog.
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File or file name extension Description
<user>_ComponentCatalogUserSe
ttings.xml

Lists the recently used applications
and components, and their location in
the Applications & components
catalog structure.

Worktypes.xml Lists available task types. Created
when you start Task Manager.

WorkTypeProperties.xml Lists allowed property types and their
units.

.tmp A file used to store temporary data.

.cnv A file used to map Tekla Structures
profile and material names with
names used in other software.

.colorset Created when you export a color set
from Organizer.

Files in the \Analysis folder

File or file name extension Description
.ifc The analysis model exported in IFC

format.
.stp The analysis model exported in CIS/2

format.
.map A file used for debugging analysis

models.
analysis_results.db5 Database for analysis load

combination results.
.db6 Analysis model database.

Files in the \attributes folder

  
.rop Reference object properties
.rop.more Reference object user-defined

attribute properties
.m10000017 FabTrol XML import properties
.m10000015 Import attribute properties
.ncf NC file properties
.ExportIFC.MainDialog IFC export properties
.m440000004 3D DWG/DXF export properties
.m440000003 3D DGN export properties
.m1000004 FEM export properties
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.m10000011 CIS analysis model export properties
.m10000026 CIS manufacturing model export

properties
.m1000007 CAD export properties
.m10000016 Cover sheet export properties
.SObjGrp Model selection filter properties
.VObjGrp Model view filter properties
.OrgObjGrp Organizer filter properties
.PObjGrp Object group filter properties
.grd Grid properties
.grd.more Grid user-defined attribute properties
.grdp Grid line properties
.grdp.more Grid line user-defined attribute

properties
.mvi Model view properties that you have

saved for the model.

Default 3D, part, component, custom
component, assembly, and cast unit
view settings files need to be saved
with names used in common
environment:

3D view: basic_view

3D part view: part_basic_view

Part front view: part_front_view

Part top view: part_top_view

Part end view: part_end_view

Part perspective view:
part_persp_view

3D component view: joint_basic_view

Component front view:
joint_front_view

Component top view: joint_top_view

Component end view: joint_end_view

Component perspective view:
joint_persp_view

Custom component front view:
custom_object_editor_front_view
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Custom component top view:
custom_object_editor_top_view

Custom component end view:
custom_object_editor_end_view

Custom component perspective view:
custom_object_editor_perspective_vie
w

3D assembly or cast unit view:
assembly_basic_view

Assembly or cast unit front view:
assembly_front_view

Assembly or cast unit top view:
assembly_top_view

Assembly or cast unit end view:
assembly_end_view

Assembly or cast unit back view:
assembly_back_view

Assembly or cast unit bottom view:
assembly_bottom_view

Assembly or cast unit perspective
view: assembly_persp_view

.gvi Saved properties for creating views
along grid lines

.rep Object representation properties

.clm Steel column properties

.clm.more Steel column user-defined attribute
properties

.prt Steel beam properties

.prt.more Steel beam user-defined attribute
properties

.sb Steel spiral beam properties

.sb.more Steel spiral beam user-defined
attribute properties

.crs Orthogonal beam properties

.crs.more Orthogonal beam user-defined
attribute properties

.dia Twin profile properties

.dia.more Twin profile user-defined attribute
properties
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.cpl Contour plate properties
.cpl.more Contour plate user-defined attribute

properties
.ips Item properties
.ips.more Item user-defined attribute properties
.cpf Pad footing properties
.cpf.more Pad footing user-defined attribute

properties
.csf Strip footing properties
.csf.more Strip footing user-defined attribute

properties
.ccl Concrete column properties
.ccl.more Concrete column user-defined

attribute properties
.cbm Concrete beam or concrete polybeam

properties
.cbm.more Concrete beam or concrete polybeam

user-defined attribute properties
.csb Concrete spiral beam properties
.csb.more Concrete spiral beam user-defined

attribute properties
.csl Concrete slab properties
.csl.more Concrete slab user-defined attribute

properties
.cpn Concrete panel properties
.cpn.more Concrete panel user-defined attribute

properties
.ipc Concrete item properties
.ipc.more Concrete item user-defined attribute

properties
.rbr Reinforcing bar properties
.rbr.more Reinforcing bar user-defined attribute

properties
.rbg Reinforcing bar group properties
.rbg.more Reinforcing bar group user-defined

attribute properties
.rcu Curved reinforcing bar group

properties
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.rci Circular reinforcing bar group

properties
.rbm Reinforcement mesh properties
.rbm.more Reinforcement mesh user-defined

attribute properties
.rbs Reinforcement strand pattern

properties
.rbs.more Reinforcement strand pattern user-

defined attribute properties
.rsp Reinforcement splice properties
.rsp.more Reinforcement splice user-defined

attribute properties
.rst Rebar set properties
.rst.more Rebar set user-defined attribute

properties
.rst.zones Rebar set spacing zone properties
.rst_pm Rebar set property modifier

properties
.rst_pm.more Rebar set property modifier user-

defined attribute properties
.rst_edm Rebar set end detail modifier

properties
.rst_sm Rebar set splitter properties
.admodel Analysis model properties
.admodel.more Analysis model user-defined attribute

properties
.lm1 Point load properties
.lm2 Line load properties
.lm3 Area load properties
.lm4 Uniform load properties
.m10000028 Wind load properties
.lm6 Temperature load properties
.lco Load combination properties
.adnode Analysis node properties
.adnode.more Analysis node user-defined attribute

properties
.prt_ad, .prt_design File types associated with steel beam

analysis property settings. .prt_ad
contains information associated with
the analysis part properties
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and .prt_design contains
information associated with the
actual steel beam design.

.crs_ad, .crs_design File types associated with orthogonal
steel beam analysis property
settings. .crs_ad contains
information associated with the
analysis part properties
and .crs_design contains
information associated with
orthogonal steel beam design.

.clm_ad, .clm_design File types associated with steel
column analysis property
settings. .clm_ad contains
information associated with the
analysis part properties
and .clm_design contains
information associated with the
actual steel column design.

.dia_ad, .dia_design File types associated with steel twin
profile analysis property
settings. .dia_ad contains
information associated with the
analysis part properties
and .dia_design contains
information associated with actual
twin profile design.

.cpl_ad, .cpl_design File types associated with contour
plate analysis property
settings. .cpl_ad contains
information associated with the
analysis part properties
and .cpl_design contains
information associated with actual
contour plate design.

.cpf_ad, .cpf_design File types associated with pad footing
analysis property settings. .cpf_ad
contains information associated with
the analysis part properties
and .cpf_design contains
information associated with the
actual pad footing design.

.csf_ad, .csf_design File types associated with strip footing
analysis property settings. .csf_ad
contains information associated with
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the analysis part properties
and .csf_design contains
information associated with the
actual strip footing design.

.ccl_ad, .ccl_design File types associated with concrete
column analysis property
settings. .ccl_ad contains
information associated with the
analysis part properties
and .ccl_design contains
information associated with the
actual concrete column design.

.cbm_ad, .cbm_design File types associated with concrete
beam analysis property
settings. .cbm_ad contains
information associated with the
analysis part properties
and .cbm_design contains
information associated with the
actual concrete beam design.

.csl_ad, .csl_design File types associated with concrete
slab analysis property
settings. .csl_ad contains
information associated with the
analysis part properties
and .csl_design contains
information associated with the
actual slab design.

.cpn_ad, .cpn_design File types associated with concrete
panel analysis property
settings. .cpl_ad contains
information associated with the
analysis part properties
and .cpl_design contains
information associated with the
actual concrete panel design.

.srf Surface treatment properties

.srf.more User-defined surface treatment
attribute properties

.srfo Surface properties

.srfo.more User-defined surface attribute
properties

.cha Edge chamfer properties
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.cha.more User-defined edge chamfer attribute

properties
.scr Bolt properties
.scr.more User-defined bolt attribute properties
.wld Weld properties
.wld.more User-defined weld attribute

properties
*.udwcs User-defined weld cross sections

(UserDefinedWeldCrossSections.udwc
s)

.m1000009 Control number properties

.m1000010 Control number locking properties

.num Numbering setup properties

.rpr Report properties

.4d Project status visualization properties
standard.opt Settings are saved in standard.opt

in the \attributes folder only when
you save your own settings in the
Options dialog box using Save.

There is a standard.opt file in the
environment folder that gives the
initial values to be loaded when a
model is created.

Component properties files in the \attributes folder

• Properties files for components available in the Applications &
components catalog, for example .j310000063 for 2L Splice (63)
component properties. These files are stored in the attributes folder
under the model folder.

Object level drawing settings, saved in \attributes folder

File or file name extension Description
.dprt Object level part properties
.dim Object level dimension properties
.pm Object level part mark properties
.jm Object level connection mark

properties
.sm Object level bolt mark properties
.rm Object level reinforcement mark

properties
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File or file name extension Description
.mrms Object level merged reinforcement

mark properties
.pom Pour object mark properties
.surfm Object level surface treatment mark

properties
.note Object level associative note

properties
.wls Object level weld mark properties
.lev Object level level mark properties
.rev Object level revision mark properties
.drmsh Object level reinforcement mesh

properties
.drbr Object level reinforcement properties
.po Object level pour object properties
.sc Object level bolt properties
.srf Object level surface treatment

properties
.dgr Object level grid properties
.sbl Object level symbol properties
.wls Object level weld mark properties
.drtxt Object level text properties
.gln Object level line properties
.grt Object level rectangle properties
.gci Object level circle properties
.gar Object level arc properties
.gpl Object level polyline properties
.gpg Object level polygon and cloud

properties

View level drawing settings, saved in \attributes folder

File or file name extension Description
.vi View level view properties
.vi.copt View level detailed object level

settings
.vpm View level part mark properties
.vsm View level bolt mark properties
.vnpm View level neighbor part mark

properties
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File or file name extension Description
.vsurfm View level surface treatment mark

properties
.vjm View level connection mark properties
.vrm View level reinforcement mark

properties
.vnrm View level neighbor reinforcement

mark properties
.vpom View level pour object mark

properties
.vp View level part properties
.vs View level bolt properties
.vnp View level neighbor part properties
.vsurf View level surface treatment

properties
.vw View level welding properties
.vr View level reinforcement properties
.vnr View level neighbor reinforcement

properties
.vrmp View level reference object properties
.vpo View level pour object properties
.vg View level grid properties
.vf View level filter properties
.vnf View level neighbor part filter

properties

Files related to single-part drawings, drawing level properties, saved in
\attributes folder

File or file name extension Description
.wd Single-part drawing properties
.wd.copt Single-part drawing detailed object

level settings
.wd.more Single-part drawing user-defined

attributes
.wdf Single-part drawing filter properties
.wdnf Single-part drawing neighbor part

filter properties
.wdl Single-part drawing layout properties
.wdl.more Single-part drawing user-defined

layout attributes
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File or file name extension Description
.wdv Single-part drawing view properties
.wdv.more Single-part drawing user-defined view

attributes
.wdc Single-part drawing section view

properties
.wdc.more Single-part drawing user-defined

section view attributes
.wdd Single-part drawing dimension

properties
.wdd.more Single-part drawing user-defined

dimension attributes
.wdcd Single-part drawing dimensioning

properties
.wdcd more Single-part drawing user-defined

dimensioning attributes
.wpm Single-part drawing part mark

properties
.wsm Single-part drawing bolt mark

properties
.wnpm Single-part drawing neighbor part

mark properties
.wdsurfm Single-part drawing surface treatment

mark properties
.wdsurfm.more Single-part drawing user-defined

surface treatment mark attributes
.wjm Single-part drawing connection mark

properties
.wdp Single-part drawing part properties
.wds Single-part drawing bolt properties
.wds.more Single-part drawing user-defined bolt

attributes
.wdnp Single-part drawing neighbor part

properties
.wdnp.more Single-part drawing user-defined

neighbor part attributes
.wdsrf Single-part drawing surface treatment

properties
.wdsrf.more Single-part drawing user-defined

surface treatment attributes
.wdgr Single-part drawing grid properties
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File or file name extension Description
.wdgr.more Single-part drawing user-defined grid

attributes
.wdr Single-part drawing protection

properties
.wdr.more Single-part drawing user-defined

protection attributes

Files related to assembly drawings, drawing level properties, saved in
\attributes folder

File or file name extension Description
.ad Assembly drawing properties
.ad.more Assembly drawing user-defined

attributes
.adf Assembly drawing filter properties
.adnf Assembly drawing neighbor part filter

properties
.adl Assembly drawing layout properties
.adl.more Assembly drawing user-defined

layout attributes
.adv Assembly drawing view properties
.adc Assembly drawing section view

properties
.add Assembly drawing dimension

properties
.add.more Assembly drawing user-defined

dimension attributes
.adcd Assembly drawing dimensioning

properties
.adcd.more Assembly drawing user-defined

dimensioning attributes
.apm Assembly drawing part mark

properties
.asm Assembly drawing bolt mark

properties
.anpm Assembly drawing neighbor part

mark properties
.adsurfm Assembly drawing surface treatment

mark properties
.adsurfm.more Assembly drawing user-defined

surface treatment mark attributes
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File or file name extension Description
.ajm Assembly drawing connection mark

properties
.adp Assembly drawing part properties
.adp.more Assembly drawing user-defined part

attributes
.ads Assembly drawing bolt properties
.adnp Assembly drawing neighbor part

properties
.adnp.more Assembly drawing user-defined

neighbor part attributes
.adsrf Assembly drawing surface treatment

properties
.adsrf.more Assembly drawing user-defined

surface treatment attributes
.adw Assembly drawing welding properties
.adw.more Assembly drawing user-defined

welding attributes
.adgr Assembly drawing grid properties
.adgr.more Assembly drawing user-defined grid

attributes
.adr Assembly drawing protection

properties

Files related to cast unit drawings, drawing level properties, saved in
\attributes folder

File or file name extension Description
.cud Cast unit drawing properties
.cud.copt Cast unit drawing detailed object level

settings
.cud.more Cast unit drawing user-defined

attributes
.cudl Cast unit drawing layout properties
.cudl.more Cast unit drawing user-defined layout

attributes
.cudv Cast unit drawing view properties
.cudv.more Cast unit drawing user-defined view

attributes
.cudc Cast unit drawing section view

properties
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File or file name extension Description
.cudc.more Cast unit drawing user-defined

section view attributes
.cudd Cast unit drawing dimension

properties
.cudd.more Cast unit drawing user-defined

dimension attributes
.cudcd Cast unit drawing dimensioning

properties
.cudcd.more Cast unit drawing user-defined

dimensioning properties
.cupm Cast unit drawing part mark

properties
.cusm Cast unit drawing bolt mark

properties
.cunpm Cast unit drawing neighbor part mark

properties
.cudsurfm Cast unit drawing surface treatment

mark properties
.cudsurfm.more Cast unit drawing user-defined

surface treatment mark attributes
.cudrm Cast unit drawing reinforcement mark

properties
.cudrm.more Cast unit drawing user-defined

reinforcement mark attributes
.cudp Cast unit drawing part properties
.cudp.more Cast unit drawing user-defined part

attributes
.cuds Cast unit drawing bolt properties
.cuds.more Cast unit drawing user-defined bolt

attributes
.cudnp Cast unit drawing neighbor part

properties
.cudnp.more Cast unit drawing user-defined

neighbor part attributes
.cudsrf Cast unit drawing surface treatment

properties
.cudsrf.more Cast unit drawing user-defined

surface treatment attributes
.cudr Cast unit drawing reinforcement

properties
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File or file name extension Description
.cudr.more Cast unit drawing user-defined

reinforcement attributes
.cudw Cast unit drawing welding properties
.cudw.more Cast unit drawing user-defined

welding attributes
.cudgr Cast unit drawing grid properties
.cudgr.more Cast unit drawing user-defined grid

attributes
.cudrp Cast unit drawing protection

properties
.cudrp.more Cast unit drawing user-defined

protection attributes
.cuf Cast unit drawing filter properties
.cunf Cast unit drawing neighbor part filter

properties

Files related to general arrangement drawings, drawing level properties,
saved in \attributes folder

File or file name extension Description
.gd General arrangement drawing

properties
.gd.copt General arrangement drawing

detailed object level settings
.gd.more General arrangement drawing user-

defined properties
.gdl General arrangement drawing layout

properties
.gdl.more General arrangement drawing user-

defined layout attributes
.gdv General arrangement drawing view

properties
.gdv.more General arrangement drawing user-

defined view attributes
.gdd General arrangement drawing

dimension properties
.gdd.more General arrangement drawing user-

defined dimension attributes
.gdcd General arrangement drawing

dimensioning properties
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File or file name extension Description
.gdcd.more General arrangement drawing user-

defined dimensioning attributes
.gpm General arrangement drawing part

mark properties
.gsm General arrangement drawing bolt

mark properties
.gnpm General arrangement drawing

neighbor part mark properties
.gdsurfm General arrangement drawing surface

treatment mark properties
.gdsurfm.more General arrangement drawing user-

defined surface treatment mark
attributes

.gjm General arrangement drawing
connection mark properties

.gdrm General arrangement drawing
reinforcement mark properties

.gdrm.more General arrangement drawing user-
defined reinforcement mark
attributes

.gnrm General arrangement drawing
neighbor reinforcement mark
properties

.gpom General arrangement drawing pour
object mark properties

.gdp General arrangement drawing part
properties

.gdp.more General arrangement drawing user-
defined part attributes

.gds General arrangement drawing bolt
properties

.gds.more General arrangement drawing user-
defined bolt attributes

.gdnp General arrangement drawing
neighbor part properties

.gdnp.more General arrangement drawing user-
defined neighbor part attributes

.gdsrf General arrangement drawing surface
treatment properties

.gdw General arrangement drawing
welding properties
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File or file name extension Description
.gdw.more General arrangement drawing user-

defined welding attributes
.gdr General arrangement drawing

reinforcement properties
.gdr.more General arrangement drawing user-

defined reinforcement attributes
.gnr General arrangement drawing

neighbor reinforcement properties
.gpo General arrangement drawing pour

object properties
.gpbr General arrangement drawing pour

break properties
.gdrmp General arrangement drawing

reference object properties
.gdrmp.more General arrangement drawing user-

defined reference model attributes
.gdgr General arrangement drawing grid

properties
.gdgr.more General arrangement drawing user-

defined grid attributes
.gdrp General arrangement drawing

protection properties
.gdrp.more General arrangement drawing user-

defined protection attributes
.gdf General arrangement drawing filter

properties
.gdnf General arrangement drawing

neighbor part filter properties

Files related to multidrawings, drawing level properties, saved in
\attributes folder

File or file name extension Description
.md Multidrawing properties
.md.more Multidrawing user-defined attributes
.mdl Multidrawing layout properties
.mdl.more Multidrawing user-defined layout

attributes
.mdr Multidrawing protection properties
.mdr.more Multidrawing user-defined protection

attributes
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Files common to all drawings, and files in the \drawings folder

File or file name extension Description
.dg Drawing files
.ldb Drawing export layer properties
.ldr Drawing link properties
.cs Section symbol properties
.detail Detail symbol properties
.fas Text file properties
.fhl Hyperlink properties
.dsf Drawing selection filter properties.

This file is saved when you select the
Drawing --> Selection filter check
box in the Filter or Selection Filter
properties.

.GridsDimXml

.ShapeDimXml

.HolesDimXml

.FilterDimXml

.OverallDimXml

.RecessesDimXml

.SecPartsDimXml

Dimensioning rules

.dg.DPM Drawing snapshot files created with
the snapshot tool in \snapshots
subfolder

Files related to IFC export in \IFC folder

File or file name extension Description
.ifc Exported IFC files

Files related to NC in the \DSTV_Profiles folder

File or file name extension Description
.nc1 NC (numerical control) files

Files in the \ModelSharing folder

File or file name extension Description
ModelSharingService.key Key file that is needed to perform

sharing in Tekla Model Sharing.
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File or file name extension Description
FileSharing.ini File sharing settings in Tekla Model

Sharing .
FileSharing.xml File needed for file sharing in Tekla

Model Sharing.

Files in the \ProjectOrganizer folder

File or file name extension Description
.db Created when Organizer is opened

for the first time. Contains all
property template and category
information used in the model.

The database name shows the
version of the database, for example,
ProjOrg000020.db.

.propertytemplate Created when you export a property
template from Organizer.

.category Created when you export a category
from Organizer.

Files related to reports in the \Reports folder

File or file name extension Description
.xsr Tekla Structures reports

Files in the \SessionFileRepository folder

File or file name extension Description
Files in the
SessionFileRepository folder

Backup copies of the files that are
updated or deleted in Tekla Model
Sharing read in.

SessionFile.db Database for managing model folder
files in Tekla Model Sharing .

.storage Configuration file of
SessionFile.db.

Files related to shapes in the \ShapeGeometries and \Shapes folders

File or file name extension Description
.tez
.xml

Shape geometry descriptions in the
\ShapeGeometries folder

.xml Shape descriptions in the Shapes
folder
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Files in the \screenshots folder

File or file name extension Description
.png Screenshot taken in Tekla Structures.

Files related to Unitechnik export in the \UT_files folder

File or file name extension Description
.uni Exported Unitechnik files

Files related to Web Viewer in the \PublicWeb folder

File or file name extension Description
Model.xml Web Viewer model in XML format
index.html Index file for the Web Viewer model
Model.zsol Contains information on solid objects

in the Web Viewer model
Files in the css folder Contains Cascading Style Sheet (CSS)

files for the Web Viewer Model
Files in the dll folder Contains dynamic link libraries (DLL)

files for the Web Viewer model
Files in the help folder Contains Web Viewer help and css

files.
Files in the images folder Contains image files used in Web

Viewer

5.16 Check and change Tekla Structures file and folder
locations in Directory browser
Directory browser is a tool that helps you to find and modify the location of
the various Tekla Structures files and folders, and customize user settings.

NOTE Generally, only administrators should change these settings. If you
change them yourself, and you are sharing the same model with other
users, and your settings differ from those of the project, you will have
problems. Also, adding or modifying files in some of these folders may
require administrator rights.

To locate files and folders, and customize your Tekla Structures settings:

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.
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2. Click the arrow next to Applications to open the applications list.

3. Double-click Directory browser. 

The Directory browser dialog box opens. You can check the most
common folder paths, and customize the settings in your user.ini file,
or in the user-specific or model-specific options.ini file.

4. Check the folder paths and change them if necessary by clicking the
buttons on the left of the Basic tab. 

If you click the Project or Firm button and you have not set your firm and
project folder, Tekla Structures will prompt you to do so and add the
folder path definition to your user.ini file.

5. Check the settings in the user.ini and options.ini files and change
them if necessary by clicking the buttons on the right of the Basic tab.

6. Go to the Advanced tab and define the folder paths for additional folders
that you may need to access, such as custom components and macros.

5.17 Folder search order
When you open a model, Tekla Structures searches for the associated files in
specific folders in a set order.

It is important that you keep files in correct folders. Once Tekla Structures
finds the associated files, it stops searching. This means that files that have the
same name but are located lower down the search order are ignored.

The folder search order is:

Folder Defined by
Current model The open model
Project Advanced option XS_PROJECT
Firm Advanced option XS_FIRM
System Advanced option XS_SYSTEM

Tekla Structures does not search for certain files in exactly this order. The
exceptions are listed below.

The exceptions are:

File (type) Search order
objects.inp (page 259) • Model folder

• Project folder (XS_PROJECT)

• Firm folder (XS_FIRM)
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File (type) Search order
• System folder (XS_SYSTEM)

• inp folder (XS_INP)
privileges.inp • Model folder

• Project folder (XS_PROJECT)

• Firm folder (XS_FIRM)

• System folder (XS_SYSTEM)

• inp folder (XS_INP)
.dat files (page 269) System folder (XS_SYSTEM)
Templates (page 311) • Folder containing your templates

indicated by the advanced option
XS_TEMPLATE_DIRECTORY

• Model folder

• Project folder (XS_PROJECT)

• Firm folder (XS_FIRM)

• Environment-specific system
templates indicated by the
advanced option
XS_TEMPLATE_DIRECTORY_SYSTE
M

• System folder (XS_SYSTEM)
Catalogs Profile (page 146), bolt (page 205),

material (page 138) and reinforcing
bar catalogs:

• Model folder

• Project folder (XS_PROJECT)

• Firm folder (XS_FIRM)

• Folder indicated by the advanced
option XS_PROFDB

Shape catalog (page 200):

• Model folder

• Project folder (XS_PROJECT)

• Firm folder (XS_FIRM)

• System folder (XS_SYSTEM)

• Folder indicated by the advanced
option XS_DEFAULT_BREP_PATH

Printer catalog:
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File (type) Search order
• Model folder

• Project folder (XS_PROJECT)

• Firm folder (XS_FIRM)

• Folder indicated by the advanced
option XS_DRIVER

WARNING Do not use the system folder to store customized files. That way
you will avoid having problems or doing a lot of unnecessary
work when you upgrade to a newer version of the software.

5.18 Location of certain files in hidden folders
When Tekla Structures is installed in the \Program Files folder the following
settings files are located in hidden folders. You can see hidden folders if you
turn them visible in Windows Folder Options.

WARNING You can always check the settings below. If you run into problems with
the settings, ask your administrator or local support for assistance.

File Location
analysis_design_config.inp ..\ProgramData\Tekla

Structures\<version>
\environments\<environment>
\system

contentattributes.lst ..\ProgramData\Tekla
Structures\<version>
\environments\<environment>
\template\settings

contentattributes_global.lst ..\Program Files\Tekla
Structures\<version>\nt\TplEd
\settings

contentattributes_userdefined
.lst
(in USImperial and Metric
environments:
contentattributes_customer.ls
t)

..\Program Files\Tekla
Structures\<version>\nt\TplEd
\settings

dimension_marks.sym ..\ProgramData\Tekla
Structures\<version>
\environments\common\symbols
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File Location
InquiryTool.config ..\ProgramData\Tekla

Structures\<version>
\environments\common\macros
\modeling
\InquiryToolAttributes

objects.inp ..\ProgramData\Tekla
Structures\<version>
\environments\common\inp

options.bin ..\Users\<user>\AppData\Local
\Tekla Structures\<version>
\UserSettings

privileges.inp ..\ProgramData\Tekla
Structures\<version>
\environments\common\inp

product_finishes.dat ..\ProgramData\Tekla
Structures\<version>
\environments\common\system

rebar_config.inp ..\ProgramData\Tekla
Structures\<version>
\environments\<environment>
\system

TeklaStructures.lin ..\ProgramData\Tekla
Structures\<version>
\environments\common\inp

teklastructures.minitoolbar.x
ml

..\Users\<user>\AppData\Local
\Tekla Structures\<version>
\UserSettings

TilePatternCatalog.dtd ..\ProgramData\Tekla
Structures\<version>
\environments\common\system

TilePatternCatalog.xml ..\ProgramData\Tekla
Structures\<version>
\environments\<environment>
\system

user.ini ..\Users\<username>\AppData
\Local\Tekla Structures
\<version>\UserSettings\
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6 Templates

Templates are descriptions of forms and tables that can be included in Tekla
Structures. Templates are either graphical or textual. Graphical templates are
inserted in drawing layouts as tables, text blocks, and drawing headers, for
example. Textual templates are used for creating reports. The contents of the
template fields are filled in by Tekla Structures at run time.

Tekla Structures includes a large number of standard templates you can use.
Use Template Editor to modify existing templates, or create new ones to suit
your needs. Graphical template definitions have the file name extension .tpl.
Textual template definitions have the file name extension .rpt.

The ready-made templates in the default environment are located in the
following folders:

Testual templates: ...\ProgramData\Tekla Structures\<version>
\environments\default\system
Graphical templates: ...\ProgramData\Tekla Structures\<version>
\environments\default\template

Examples

Example of a title block:

Example of an inquiry report:
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Example of a part list report:

For more information on using templates, see Template Editor User's Guide or
open the Template Editor Help in Template Editor by clicking Help -->
Contents .
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See also

Create a template (page 313)

6.1 Create a template
1. On the File menu, click Editors --> Template Editor.

2. In Template Editor, click File > New.

3. Select the template type and click OK. A new empty template is created.

4. Add new rows in the template.

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row and click OK.

c. Repeat steps a–b for each new row.

5. Add value fields to get the required data from your Tekla Structures
database.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

6. Save the template.

a. Click File --> Save as.

b. Browse to the template folder ..\environment
\<your_environment>\template.

c. In the File name field, enter a name for the template.

d. Click OK.

See also

Templates (page 311)

Create a template in HTML format (page 313)

Create a template for nested assemblies (page 318)

Create a template for bending schedules or pull-out pictures (page 322)

Add images in a template (page 326)
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6.2 Create a template in HTML format
Templates in HTML format give you more possibilities for different layout,
fonts, and images. Templates that generate output in HTML format are
graphical and have the file name extension *.html.rpt.

1. On the File menu, click Editors --> Template Editor.

2. In Template Editor, click File > New.

3. Select Graphical template and click OK.

4. Add new rows in the template.

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row and click OK.

c. Repeat steps a–b for each new row.

5. Add value fields to get the required data from your Tekla Structures
database.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

6. Add a header for each value field.

a. Click Insert --> Component --> Header...

b. Click Insert --> Text...

c. Enter a heading for the template, and then click OK.

d. Click a point to define the location of the heading in the header row.

e. Repeat steps a–d to create headings for all the value fields.

7. Save the template:

a. Click File --> Save as

b. Browse to the template folder ..\environment
\<your_environment>\template.

c. In the File name field, enter a name for the template. 

Include the extension *.html.rpt in the file name. For example,
Part_list.html.rpt.

d. Click OK.
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NOTE If you add images in your HTML template, the images should be located in ..
\Program Files\Tekla Structures\<version>\nt\TplEd\bitmaps
folder, otherwise they are not shown in the HTML output.

Example

1. Header that contains text fields

2. Row that contains two value fields

See also

Templates (page 311)

Add images in a template (page 326)

6.3 Create a .pdf report template
You can create graphical templates to be used for .pdf reports.

1. On the File menu, select Editors --> Template editor.

2. Select File --> New --> Graphical template.

3. Click Edit --> Properties.

4. In Template page properties dialog box, set the page size to match the
target page size (for example A4): 
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The size must match a size defined in the PaperSizesForDrawings.dat
configuration file.

5. Add new rows and value fields to get the required data from your Tekla
Structures database. For more information about adding new rows and
value fields, see Create a template (page 313).

6. Click File --> Save as, and save the report with the filename
extension .pdf.rpt.

7. Copy the new template to your template folder, such as model or your
company settings folder (XS_FIRM). 

Now you can create a .pdf report using the new .pdf report template.
For more information about creating a report, see Create a report.

Example .pdf report

In this report example, the following page size is used:
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Below is an example of a report that has been created using this particular
report template. To open the report in a browser, click here.
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6.4 Create a template for nested assemblies
This example shows how to produce a template that displays the hierarchical
structure of nested assemblies. You will create a nested assembly structure in
a textual template similar to the one in the following picture:
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1. On the File menu, click Editors --> Template Editor.

2. In Template Editor, click File > New.

3. Select Textual template and click OK.

4. Add four new rows in the template.

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row, and then click OK. 

For the first and third row, select the ASSEMBLY content type, and for
the second and fourth row, select the PART content type.

c. Repeat steps a–b for each new row.

5. Use the arrow buttons under Sorting and drawing order to create a
nested assembly structure for the template.

a. Move the second and third row down one level.

b. Move the fourth row down two levels. 

The structure should now look like this:
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6. Add value fields to get the required data from your Tekla Structures
database. 

In this example, the added value fields are assembly or part position,
number, and weight.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

7. Modify the layout of the template. For example:

a. Move objects to display the nested assembly structure in the printed
report. To do this, select the object you want to move and drag it to
the desired position.

b. Align objects. To do this, select all the objects you want to align, right-
click and select the appropriate option from the pop-up menu, for
example Align --> Right .

c. Add a header and a footer. To do this, click Insert --> Component -->
Page header and Page footer. Add the required information to the
header and footer.

8. Save the template.

Example

Below is an example textual template and a report that has been created using
the template:
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NOTE You can create graphical templates for nested assemblies in the same manner
as textual templates. The difference between graphical and textual templates
is that in a graphical template you can display project and company
information and graphics, such as table outlines, pictures, or symbols.

See also

Templates (page 311)

Templates 321 Create a template for nested assemblies



6.5 Create a template for bending schedules or pull-out
pictures
You can use Template Editor for creating bending schedules or pull-outs
pictures on reinforcement bars and bent meshes, and control the type of
information that is shown in the bending schedules.

1. On the File menu, click Editors --> Template Editor.

2. Click File --> New .

3. Select Graphical template and click OK.

4. Click Insert --> Component --> Row to add a new row.

5. Select REBAR or MESH as the content type for the row.

6. Add value fields to get the required data from your Tekla Structures
database.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

7. Insert a graphical field to your REBAR or MESH content type row.

a. Click Insert --> Graphical Field...

b. Click and drag with the mouse to draw a frame.

8. Double-click the graphical field to open the Graphical Field Properties
dialog box.

9. Click Free attributes and go to the User tab.

10. Add the required bending diagram attributes. 

For a list of attributes and values that can be used for bending schedules
in templates, see Bending schedule attributes (page 324).

11. Save the template.
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Example

Autoscaling pull-out pictures

There is a free attribute available for the PULLOUT attribute in graphical
templates that you can use to define the scale type. If you set the free
attribute ScaleType to 1 on the User tab in the Free attributes dialog box,
the pull-out pictures will be scaled to fit the available space in both X and Y
dimensions. As a result, the shape becomes out of proportion, but small
segments can be seen more easily.
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A bending shape may look like this if you do not define the free attribute 
ScaleType:

The same bending shape that uses the free attribute ScaleType with value 1.

Change the appearance of the pull-out pictures

Tekla Structures uses the settings in the rebar_config.inp file in the ..
\ProgramData\Tekla Structures\<version>\environments
\<environment>\system folder to define the appearance of the pull-out
pictures. You can change the colors, lines, and dimension unit, format, and
precision used in pull-out pictures, for example. For a list of settings and
values in rebar_config.inp, see Reinforcement settings for drawings
(rebar_config.inp)

Bending schedule attributes
The following table lists the attributes and values that can be used for bending
schedules in templates.

Attribute Default value Available values
FontName romsim Available template fonts
FontSize 2.0 Available font sizes
FontColor 1 (black) 1 = black

2 = red

3 = bright green

4 = blue

5 = cyan

6 = yellow

7 = magenta

8 = brown
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Attribute Default value Available values
9 = green

10 = dark blue

11 = forest green

12 = orange

13 = gray
RotationAxis 2 0 = by view

1 = by global Z

2 = by local axis
ScaleType 0 0 = no

1 = yes

If you set the free
attribute ScaleType to 
1 for the PULLOUT
attribute, the pull-out
pictures will be scaled to
fit the available space in
both X and Y
dimensions. As a result,
the shape becomes out
of proportion, but small
segments can be seen
more easily.

Exaggeration 1 0 = no

1 = yes
EndMark 1 1 = straight

2 = half arrow

3 = full arrow
Dimensions 1 0 = no

1 = yes
BendingRadius 0 Shows the bending

radius in form of
diameter of the bending
roll.

0 = no

1 = yes
BendingAngle 1 0 = no

1 = yes
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Attribute Default value Available values
ImageWidth Width of the graphical

field multiplied by 4.
Number of pixels

ImageHeight Height of the graphical
field multiplied by 4.

Number of pixels

See also

Create a template for bending schedules or pull-out pictures (page 322)

6.6 Add images in a template
You can add images in graphical templates. For example, you might want to
include a company logo in your drawings. Tekla Structures supports the
following image formats in graphical
templates: .bmp, .jpg, .jpeg, .tif, .tiff and .png.

1. Open an existing graphical template or create a new graphical template in
Template Editor.

2. Add a new row in the template:

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row and click OK.

3. Ensure that you have the row selected, and click Insert > Picture to open
the Select Picture File dialog box. 

If a local symbols folder exists, the contents of that folder are shown by
default. You can browse for the contents of the common\symbols folder
by selecting that folder. If a local symbols folder does not exist, Tekla
Structures displays the contents of the common\symbols folder.

4. If you have images in other folders, you can display these folders in the
Select Picture File dialog box: 

a. In Template Editor, click Options --> Preferences.

b. Go to the File Locations tab and on the Symbols, pictures row, add
a new folder separated by a semicolon (;), for example:

The folder you defined is displayed in the Directory list:
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5. Select an image from the File list and click OK and add the image. 

You can adjust the size by dragging from the image handles.

Things to remember when adding images in templates

• Do not add very large images because they update very slowly.

• The image may look different in the image editor and in the printout or in
the exported DWG file.

• When you export the drawing to DWG, Tekla Structures copies the images
in the same folder as the DWG file. If the image for some reason is not in
the same folder, only the name of the image is displayed together with an
empty frame instead of the image in the DWG.

• If environments have local symbols, the local symbol folder is also included
in the search path with the common\symbols folder. If the local symbols
folder contains files with the same name as common\symbols folder, then
the local symbol file is used.

• When you open the drawing that contains images inserted in the template,
Tekla Structures first looks for the images in the model folder and then in
the \symbols folder in the current environment.

• You can define a folder where Tekla Structures always looks for images
using the advanced option DXK_SYMBOLPATH. You can also define a firm
folder for your images.

Example

Below are some examples of the Select Picture File dialog box showing folder
structure in different environments.
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In the following example, a company logo has been added in a template.
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See also

Templates (page 311)

6.7 Content types
When you create a new row in the template, you must select a content type for
the row. For example, when you add a row and then add a value field,
Template Editor is asking for the content type. The content type determines
which template attributes you can use on that row.

The available content types are:

Content type Description
ANTIMATERIAL Use to create lists of holes and recesses, or parts

removed as a result of a cut.

In Template Editor, the same attributes that are
available for PART are available for ANTIMATERIAL.
However, only the attributes that are useful to be
used with ANTIMATERIAL are shown, including 
NAME, LENGTH, WIDTH, HEIGHT, AREA, PROFILE,
and NUMBER, and user-defined attributes.

ASSEMBLY Use to create lists of assemblies and single parts.
Includes all assemblies containing the selected
parts and bolts.

BOLT Use to create screw and bolt lists. Includes all bolts
connected to selected parts.

CAST_UNIT Use to create lists of cast units.
CHAMFER Use to create lists of the length of the chamfers.
COMMENT Use to create empty rows or rows that only have

textual data or lines anywhere on a template.
CONNECTION Use to create lists of connections.
DRAWING Use to create drawing lists without revision history

information. Use for reports and included
drawings.

HIERARCHIC_OBJECT Use to create lists of various types of hierarchies.
For example, lists hierarchical objects in Organizer.

HISTORY Use to retrieve history information of the model.
You can use this content type with PART, REBAR, 
CONNECTION and DRAWING rows.

The following template attributes can be used with
this content type:
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Content type Description
• TYPE: the type of the historical action, for

example update or numbering.

• USER: the user who made the change.

• TIME: the time the change was made.

• COMMENT: the comment which was entered
upon clicking Save.

• REVISION_CODE: the revision code which was
entered upon clicking Save.

HOLE Use to create lists of holes.
LOAD Use to create lists of loads.
LOADGROUP Use to create lists of load groups.
MESH Use to create lists of meshes.
NUT Use to create lists of nuts. Contains all nuts for

bolts associated with the selected parts.
PART Use to create lists of parts.
POUR_BREAK Use to create lists of pour breaks.
POUR_OBJECT Use to create lists of pour objects.
POUR_UNIT Use to create lists of pour units.
REBAR Use to create lists of reinforcing bars.
REFERENCE_MODEL Use to list the reference models.
REFERENCE_OBJECT Use to list the reference model objects in a

reference model.

Only reference model objects that have user-
defined attributes are displayed in reports.

REFERENCE_ASSEMBLY Use to list the reference assemblies in a reference
model.

REVISION Use to create lists of revision marks.
SIMILAR_ASSEMBLY Use to create lists of similar parts.

To use this content type, you need to have an
empty (hidden in output) ASSEMBLY, PART or 
CAST_UNIT row in the row hierarchy above the row
with SIMILAR_* content type:

SIMILAR_CAST_UNIT
SIMILAR_PART
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Content type Description
You cannot have any rows below SIMILAR_* row
content type in the row hierarchy.

Note: Used in drawings to collect similar object
information from the model. All the other attribute
information is collected from visible drawing
objects.

SINGLE_REBAR Use to create lists of individual bars in reinforcing
bar groups.

For example, use it to get the lengths of the
individual bars in tapered reinforcing bar groups.

For rebar sets, SINGLE_REBAR works in the same
way as REBAR.

SINGLE_STRAND Use to create lists of individual prestressed
strands.

STRAND Use to create lists of prestressed strands.
STUD Use to create lists of studs.
SURFACE Use to create lists of surfaces.
SURFACING Use to create lists of surface treatments.
SUMMARY Use to summarize the contents of the row(s) that

are above SUMMARY in the hierarchy.

For example, use PART - SUMMARY hierarchy to
summarize the contents of the PART rows.

TASK Use to create lists of tasks.
WASHER Use to create lists of washers. Contains all washers

for all bolts associated with the selected parts.
WELD Use to create lists of welds.

See also

Template attribute files (contentattributes.lst) (page 331)
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6.8 Template attribute files (contentattributes.lst)
Template attributes represent object properties. You can use template
attributes in value fields, formulas, and row rules to get the required data from
your Tekla Structures database.

When you output the template, Tekla Structures replaces the attribute with the
actual value of the corresponding object property. For example, if you include
the attribute WEIGHT in a report template, Tekla Structures displays the weight
of the model object in the report.

Template attributes are defined in the following files:

File name Description
contentattributes.lst This is a container file listing all the

files that contain the actual attribute
definitions. The files are added with 
INCLUDE sentences. The order of the
files included in
contentattributes.lst defines
the reading order of the files.

This file is overwritten in the
installation when you install a newer
version of Tekla Structures. Ensure
that you make a copy of this file
before updating.

Generally, there is no need to modify
contentattributes.lst. Do not
modify it if you are not an
administrator.

contentattributes_global.lst This file contains attributes that are
hard-coded into the program. Do not
edit this file.

contentattributes_userdefined
.lst

This file contains user-defined
attributes, the same as in the
objects.inp file.

This file is overwritten in the
installation when you install a newer
version of Tekla Structures. To use
your own attributes in templates and
reports, create a copy of this file and
add the necessary attributes to that
file.

By default, these files are located in ..\Program Files\Tekla Structures
\<version>\nt\TplEd\settings, but the location may be different in your
environment.
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The search order for the contentattributes.lst file is the following:

1. Model folder

2. Project folder defined by XS_PROJECT

3. Firm folder defined by XS_FIRM

4. Folder defined by XS_TPLED_INI

5. Folder defined by XS_TEMPLATE_DIRECTORY/settings

See also

User-defined template attributes (page 333)

Location of certain files in hidden folders (page 309)

6.9 User-defined template attributes
User-defined template attributes are defined in the
contentattributes_userdefined.lst file. By default, this file includes
most of the user-defined attributes that are visible in the part properties
dialog boxes. To use your own attributes in templates and reports, you should
make a copy of the file, rename it appropriately, and add the necessary
attributes to that file.

The contentattributes_userdefined.lst file is divided into two sections:

• A list of attribute names and default settings:
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• A list of attributes assigned to content types:

1. The content type of the row in Template Editor

2. The attribute hierarchy in Template Editor

3. Customizable comments, such as the tab name in the user-defined
attributes dialog box

4. The name of the user-defined attribute, must be the same as in the
objects.inp file

See also

Add user-defined template attributes to Template Editor (page 334)

Add comments to user-defined template attributes (page 336)

Add hierarchy to user-defined template attributes (page 336)

Add user-defined template attributes to Template Editor
This example shows how to add your own user-defined attributes to the
attribute tree in Template Editor.

Before you start, add your user-defined attribute to the objects.inp file. For
example, you might add an attribute named MY_ATTRIBUTE to the user-
defined properties of drawings.

1. Open the contentattributes_userdefined.lst file in a text editor.
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2. Save the file with an appropriate name, for example
MY_contentattributes_userdefined.lst, in the same folder.

3. Add MY_ATTRIBUTE to the list of attribute names and, define the settings
as follows: 

4. Add MY_ATTRIBUTE to the list of attributes assigned to content types. 

Select the content type according to which object the attribute is
associated to in the objects.inp file. In this example, the content type is 
DRAWING. Add the attribute in the format 
USERDEFINED.<ATTRIBUTE_NAME>.

5. Save the changes.

6. Open the contentattributes.lst file.

7. Add the following line in the file: 

[INCLUDE MY_contentattributes_userdefined.lst]
8. Save the changes. 

The attribute is shown in the attribute tree in Template Editor, under 
DRAWING > USERDEFINED:
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See also

User-defined template attributes (page 333)

Add comments to user-defined template attributes
You can add your own comments to the user-defined attibutes in the Template
Editor attribute tree.

1. Open your copy of the contentattributes_userdefined.lst file. 

For example, MY_contentattributes_userdefined.lst. Do not
modify the original contentattributes_userdefined.lst file.

2. Scroll down to the list of attributes assigned to content types.

3. Add your comment inside quotation marks, after the attribute name. 

For example:

4. Save the changes. 

The comment you added is displayed in the attribute tree in Template
Editor:

See also

User-defined template attributes (page 333)

Add hierarchy to user-defined template attributes
You can add your own hierarchy to the Template Editor attribute tree.
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1. Open your copy of the contentattributes_userdefined.lst file. 

For example, MY_contentattributes_userdefined.lst. Do not
modify the original contentattributes_userdefined.lst file.

2. Scroll down to the list of attributes assigned to content types.

3. Define the hierarchy in square brackets, between USERDEFINED. and the
attribute name. 

For example:

NOTE Notice the periods after the brackets, and between the
hierarchies.

4. Save the changes. 

The new hierarchy is shown in the attribute tree:

WARNING User-defined attributes are case sensitive. Ensure that you enter the
attribute name using the correct case for all characters.

See also

User-defined template attributes (page 333)
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6.10 Tips for templates
There are some things that you might consider to be able to use templates
more efficiently.

Click the links below to find out more:

• Use text type attribute in calculations (page 338)

• Change value field content to use imperial units (page 338)

• Define customized date format (page 339)

• Assembly or cast unit drawing sheet number (page 339)

• Use format functions in value fields (page 340)

Use text type attribute in calculations

Change text to numeric format

double(GetValue("ASSEMBLY_TOP_LEVEL"))
Change into correct format for calculation (double=decimals)

format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)
Add all above into calculation formula

format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)+15000
Another example of the same for part elevation

(double(GetValue("TOP_LEVEL"))-
(double(GetValue("BOTTOM_LEVEL"))))*1000

Change value field content to use imperial units

Advanced option to check if imperial units are in use:

GetValue("ADVANCED_OPTION.XS_IMPERIAL")==1
Translated string call for multi lingual text:

GetValue("TranslatedText("albl_Diameter_")")
Formatting of units:

format(GetValue("DIAMETER"),"Length","inch-frac", 1/16)
format(GetValue("DIAMETER"),"Length","mm", 1)
Combine all above in a rule:
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if GetValue("ADVANCED_OPTION.XS_IMPERIAL")==1 then
GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","inch-frac", 1/16) + "
Inches"
else
GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","mm", 1)+" mm"
endif

Define customized date format

Use mid function to find year, month and day:

mid("","","") string, offset, n
year:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
month:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
days:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")
Combine all above in rule:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")

Assembly or cast unit drawing sheet number

Use match function to find "-" character

match(GetValue("NAME_BASE"),"*-*")
Use of mid function to return only characters after "-"

mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
Combine all above in rule

if (match(GetValue("NAME_BASE"),"*-*"))
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then mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
else ""
endif

Use format functions in value fields
You can define the format used in a value field in two ways: In the Value Field
Properties dialog box by filling in the fields for Datatype, Meaning, Unit and
Decimals, or by creating a formula in the Formula field. In formulas, you can
use the format function that converts an attribute value to a formatted
information string.

When you use a format function in a formula, always set the Datatype to Text
in the Value Field Properties dialog box. Leave the other fields in the Format
area empty.

For example, if you want to convert the attribute value to numbers with
decimals in the report, you need to include the conversion function double in
the format function:

The default values for unit and decimals are defined in the
contentattributes_global.lst file. The format function converts the
attribute value to a formatted information string on the basis of what you have
defined in the format function. The format function overrides the definitions in
the contentattributes_global.lst file and settings that you have defined
in the Format area of Value Field Properties dialog box.

Example of the result in a report when you use the formula above:

Mesh Information:
Geometry Size: 4/4-150/150-2750*2000
Length: 9'-1/4"
Height: 6'-6 3/4"
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Example of the result of the formula, when you use set the advanced option 
XS_IMPERIAL to FALSE instead of TRUE:

Mesh Information:
Geometry Size: 4/4-150/150-2750*2000
Length: 2750 mm
Height: 2000 mm
For a list of valid unit and precision strings, see the valuefieldclasses.lst
file located in the ..\Program Files\Tekla Structures\<version>\nt
\TplEd\settings folder. Do not make changes in this file. Below is an
example of the file content, which may change between Tekla Structures
versions.

// 
--------------------------------------------------------------------------
-------------
// 
// - Use only letters, numbers, slashes and underlines.
//
// 
--------------------------------------------------------------------------
-------------
//
// Class               =        units { presicions }

Length                 =        mm, dm, cm, m, inch, ft, yd, inch-frac 
{1/2, 1/4, 1/8, 1/16 }, ft-frac { 1/2, 1/4, 1/8, 1/16 }
Angle                  =        Degrees, radians
Area                   =        mm2, cm2, dm2, m2, sq.inch, sq.ft, sq.yd
Area/length            =        mm2/m, cm2/m, dm2/m, m2/m, in2/in, in2/
ft, ft2/ft, sq.yd/ft
Volume                 =        mm3, cm3, dm3, m3, cu.in, cu.ft, cu.yd 
Weight                 =        kg, T, N, lbf, kip
Weight/length          =        kg/m, T/m, N/m, daN/m, kN/m, lbf/ft
Density                =        kg/m3, T/m3, N/m3, kN/m3, lbf/ft3
Temperature            =        Kelvin, Celsius, Fahrenheit
Section_modulus        =        mm3, cm3, in3
Moment_of_inertia      =        mm4, cm4, in4
Warping_modulus        =        mm6, cm6, in6
Force                  =        kg, T, N, daN, kN, lbf, kip
Force/length           =        kg/m, T/m, N/m, daN/m, kN/m, lbf/in, lbf/
ft, kip/in, kip/ft
Force/area             =        kg/m, kg/cm, kg/mm, T/m, T/cm, T/mm, N/m, 
N/cm, N/mm, daN/m, daN/cm, daN/mm, kN/m, kN/cm, kN/mm, lbf/in, lbf/ft, 
kip/in, kip/ft
Moment                 =        kgm, Tm, Nm, daNm, kNm, lbf-in, lbf-ft, 
kip-in, kip-ft
Moment/length          =        kgm/m, Tm/m, Nm/m, daNm/m, kNm/m, lbf-ft/
ft, kip-ft/ft
Stress                 =        kg/m2, kg/cm2, kg/mm2, T/m2, T/cm2, T/
mm2, N/m2, N/cm2, N/mm2, daN/m2, daN/cm2, daN/mm2, kN/m2, kN/cm2, kN/mm2, 
psi, psf, ksi, ksf
Date                   =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yy, yyyy-mm-dd, dd/mm/yy
Time                   =        hh:mm:ss, hh:mm:ss:am/pm
Date&&Time             =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yyyy, yyyy-mm-dd, dd/mm/yy
Date_local             =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yyyy, yyyy-mm-dd, dd/mm/yy
Time_local             =        hh:mm:ss, hh:mm:ss:am/pm
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Date&&Time_local       =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yyyy, yyyy-mm-dd, dd/mm/yyLeadingZeroes
LeadingZeroes
DistanceList           =        mm, dm, cm, m, inch, ft, yd, inch-frac 
{1/2, 1/4, 1/8, 1/16 }, ft-frac { 1/2, 1/4, 1/8, 1/16 }

For more information about value fields, formats, format functions and other
functions, see Template Editor User's Guide.

Templates 342 Tips for templates

https://teklastructures.support.tekla.com/system/files/manual/Template_Editor_User_Guide.pdf


7 Tekla Model Sharing and multi-
user for administrators

7.1 Tekla Model Sharing
Tekla Model Sharing enables efficient global collaborative modeling within a
shared Tekla Structures model. Tekla Model Sharing gives users the freedom
to work with the same model at the same time in different locations and time
zones.

In Tekla Model Sharing each user has a local version of the model on their
computer, or on a network drive, and the model data is shared and
synchronized over the Internet using a Microsoft Azure cloud sharing service.
When a model is shared, it is connected to the cloud-based sharing service.
You can check the status of the service at any time.

When a user starts to share a model, the organization the user belongs to gets
the model ownership. In Tekla Model Sharing, an organization always owns all
the models shared by the users in the organization. A shared model is always
owned by only one organization. You can manage and view all the shared
models owned by your organization with the web-based Management Console
for Tekla Model Sharing. Logging in requires Trimble Identity administrator
rights.

Tekla Model Sharing requires a valid Tekla Model Sharing license and a Trimble
Identity which is part of a valid organization. Based on the Trimble Identity
information, you can assign and manage Tekla Model Sharing licenses in the
web-based Tekla Online Admin Tool. For more information, see Managing
Trimble Identities and Tekla Model Sharing licenses.

Tekla Model Sharing cloud sharing service status is publicly available at Tekla
Model Sharing Status. On this web-site, you can also find information about
any service breaks.

For more information on how Tekla Model Sharing works, see
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• What is Tekla Model Sharing

• Prerequisites for Tekla Model Sharing

• User roles in Tekla Model Sharing

• Tekla Model Sharing licenses

• Manage models in Management Console for Tekla Model Sharing

NOTE Tekla Model Sharing requires a single-user model. A model cannot be
simultaneously shared and used in the multi-user mode. If you want to start
using multi-user mode to share your model instead of Tekla Model Sharing,
you first need to exclude your local version of the model from the sharing
service and then convert it to a multi-user model.

The excluded model has no connection to the original shared model in the
sharing service. This means that if you exclude your local version of the model
from the sharing service and start to use the model in multi-user mode, you
cannot later merge the original shared model and the multi-user model.

7.2 Multi-user models
You can work on Tekla Structures models in either single-user or multi-user
mode. Multi-user mode allows several users to access the same model at the
same time. Several users can work on the same project and be aware of the
others' progress, so that copying and merging models is not needed.

The multi-user model consists of a single master model that can be located
anywhere in the network. Each user can access this model, and open their own
local view of the model on a client computer. This local view is called a working
model. Any changes that a user makes to the working model are local, and not
visible to other users, until the working model is saved to the master model.

The multi-user model is locked during opening, saving, and numbering. When
one of the users performs any of these operations, other users cannot
perform them during that time. For more information, see How multi-user
works.

NOTE All users of the multi-user model should use the same settings and the
same version and service pack of Tekla Structures.

Tekla Structures multi-user server runs as a service that is started
automatically when you start the computer. You do not need to log in to the
service. We recommend that you use the latest multi-user server version
available regardless of the Tekla Structures version that you use.

Setting access rights to a multi-user model

You can protect user-defined attributes using privileges. You can also prevent
your model and drawings from being accidentally modified by using the
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Locked user-defined attribute (UDA). You can use the UDA for parts
(separately for beams, columns, and so on), bolts, welds, specific drawing
types, project properties, and phase properties.

Using the Locked UDA and privileges together you can even restrict some
users or organizations from modifying your model. For more information on
access rights, see Access rights in multi-user mode.

The Locked UDA has three values: Yes, No, and Organization. When set to
Yes, the object is locked and you cannot modify its properties. You can only
change the object's user-defined attributes that do not affect numbering. If
you try to modify a locked object, Tekla Structures displays the following
warning message:

There are locked objects, see report. The operation could not
be performed.
To add the lock attribute to the user interface, you need to add the following
line in the object's section in the objects.inp file:

 attribute("OBJECT_LOCKED", attribute("OBJECT_LOCKED",
"Locked:", option,"%s", none, none, "0.0", "0.0")
{
value("No", 1)
value("Yes", 0) 
value("Organization", 0)
}  
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8 Model import

It is possible to import a model to an existing model by using the Import
model command that is available from Tekla Structures version 2017 onwards.
You can use the Import model command as a replacement to the old model
dump import. You can import the updated model several times.

1. Open an empty Tekla Structures model created without a model template.

2. Go to Quick Launch, start typing import model, and select the Import
model command from the list that appears.

3. Select a model folder to import to the currently open model.

The advanced option XS_MODEL_IMPORT_LOCK_OBJECTS in the Import
category of the Advanced Options dialog box adds locks to objects, the
default value is TRUE.

Notes and limitations

• It is not possible to import model to the same model. For example, create
model and objects and save. Then copying the model and deleting half of
the model and then importing this to the original model is not possible.

• If you import to an existing model, fix the possible numbering conflicts by
adding prefixes in numbering series.

• When you import a model, all components are exploded in Tekla Structures
version 2017i and earlier versions.
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9 Attribute import

You can import user-defined attribute (UDA) values to a model from a text file.
For example, you can import a list of manufactured or checked assemblies.

You can import the attribute values to Tekla Structures model objects,
drawings or some reference model objects by selecting an area in the model,
or the whole model.

The imported file can be:

• Exported from other software.

• Created manually using any standard text editor, for example, Microsoft
Notepad.

• A simple Tekla Structures report containing the part GUIDs and user-
defined attributes.

See also

Import attributes (page 347)

Input files in attribute import (page 348)

Examples of input files used in attribute import (page 349)

Data file used in attribute import (page 351)

Attribute import settings (page 351)

9.1 Import attributes
You can import user-defined attribute (UDA) values from a text file.

1. Copy the text file that you want to import to the current model folder.

2. If you want to import user-defined attributes to a selected area in the
Tekla Structures model, select an area in the model.

3. On the File menu, click Import --> Attributes . 

The Import Attribute dialog box opens.
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4. Click the ... button next to the Input file box to browse for the file to be
imported.

5. Select the delimiter used in the text file.

6. Select an option in the Input scope, Create log file and Display log file
boxes.

7. Click Create to import the file.

See also

Input files in attribute import (page 348)

Examples of input files used in attribute import (page 349)

Data file used in attribute import (page 351)

Attribute import settings (page 351)

9.2 Input files in attribute import
Input files used in the import of user-defined attribute (UDA) values are text
files, which are delimited by a comma, tab, semi-colon, space or a user-defined
delimiter. The input files contain the names and values of the user-defined
attributes to be imported to the Tekla Structures model.

In the input file, the column headings must contain the names of properties
and user-defined attributes in model objects and drawings. The remaining
lines contain the values of the properties and user-defined attributes.

You must include at least one key field as a column heading. Key fields are
drawing or model object properties. Tekla Structures uses the key fields to
identify the model objects or drawings to which the user-defined attributes are
assigned.

The key fields for model objects are:

Key field Example Action
GUID ID4FEAFC88-0

000-0004-313
3-
343038303031

Tekla Structures assigns the user-defined
attributes on this line in the input file to the
model object that has a GUID value of 
ID4FEAFC88-0000-0004-3133-34303830303
1.

ASSEMBLY_PO
S
or

MARK

A3 Tekla Structures assigns the user-defined
attributes on this line in the input file to the
assembly that has an ASSEMBLY_POS value of
A3.

Repeat this line for each assembly you want to
include.
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Key field Example Action
PHASE 2 Tekla Structures assigns the user-defined

attributes on this line in the input file to the
assembly that has a PHASE value of 2.

You must also use ASSEMBLY_POS as a key field
with this option.

The key fields for drawing objects are:

Key field Example Action
TYPE NAME A D4 Tekla Structures assigns the user-defined attributes on

this line in the input file to the drawing that has a TYPE
value of A and a MARK value of D4.

Use both key fields in the input file.
ID 134 Tekla Structures assigns the user-defined attributes in

this line in the input file to the drawing object that has an 
ID value of 134.

If you want to use user-defined attributes of other value types than the string
in the input file, you need to define them in the
import_macro_data_types.dat file, located in the ..\Tekla Structures
\<version>\environments\common\system folder.

TIP If you use Microsoft Excel to create the input file, save the file with the
Save as command to Text (Tab-delimited) (*.txt) format.

See also

Attribute import (page 347)

Import attributes (page 347)

Examples of input files used in attribute import (page 349)

Data file used in attribute import (page 351)

Attribute import settings (page 351)

Examples of input files used in attribute import

Example input file for parts

ASSEMBLY_POS and PHASE are the key fields. Tekla Structures adds several
user-defined attributes to the assemblies with values that match those listed
in the ASSEMBLY_POS and PHASE columns.

For example, an assembly with the ASSEMBLY_POS (assembly number) of B5 in
phase 1 gets the following user-defined attributes:
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STATUS: 3

USER_PHASE: 6

USER_ISSUE: 3/25/2012

The input file contains several entries for B1. In this case, Tekla Structures
writes the message Duplicate entry in input file in the log file and does not
overwrite the user-defined attributes that are listed earlier in the file with
those that are listed later. For example, at the end of the attribute import, B1
will have the following user-defined attributes:

STATUS: 7

USER_PHASE: 3

USER_ISSUE: 3/25/2012

This input file is tab-delimited. You can also use a comma, semi-colon, space or
a user-defined delimiter.

Example input file for drawings

TYPE and NAME are the key fields. Tekla Structures adds a value for the user-
defined attribute User field 4 to drawings with values that match those
listed in the TYPE and NAME columns.

For example, a drawing with the TYPE A (assembly drawing) and NAME B.2 gets
the value 4 in the User field 4.

See also

Attribute import (page 347)

Import attributes (page 347)

Input files in attribute import (page 348)
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Data file used in attribute import (page 351)

Attribute import settings (page 351)

Data file used in attribute import
If you want to use user-defined attributes of other value types besides string in
the attribute import input file, you need to define them in the
import_macro_data_types.dat file, located in the ..\Tekla Structures
\<version>\environments\common\system folder.

Theimport_macro_data_types.dat file is a simple text file listing the user-
defined attributes that you can include in an input file.

You can modify the file using any standard text editor, for example, Microsoft
Notepad.

You can:

• Change any of the user-defined attributes that are not key fields.

• Add user-defined attributes as INT, STRING, FLOAT, or DATE value types.

The file contains the following columns:

VARIABLE_NAME, VARIABLE_TYPE, CONVERSION_FACTOR, COMMENT

NOTE Tekla Structures uses CONVERSION_FACTOR to convert imperial values to
metric values. Tekla Structures only uses this value in Imperial environments.
We recommend that you check the FLOAT values to avoid conversion factor
errors.

Tekla Structures treats lines starting with double forward slash characters //
as comments and ignores them when reading the file.

See also

Attribute import (page 347)

Import attributes (page 347)

Input files in attribute import (page 348)

Examples of input files used in attribute import (page 349)

Attribute import settings (page 351)
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9.3 Attribute import settings
Use the options in the Import Attribute dialog box to define the input scope
and log file properties when importing user-defined attribute (UDA) values
from a text file to a model.

Option Description
Input file
delimeters

Select the delimeter used in the input file.

Input scope • Default, Entire model

Tekla Structures assigns the user-defined attribute values of
objects in the input file to matching objects in the model.

• Selection only

Tekla Structures only assigns the user-defined attribute
values of objects in the input file to matching objects in the
selected area of the model.

Use this option to import user-defined attributes to models.
Do not use it for drawings.

• Reference models

Tekla Structures assigns the user-defined attribute values of
objects in the input file to matching objects in reference
models.

Create log file • Create

Creates a new log file named attribute_import.log in
the current model folder each time you import the user-
defined attributes. Any previous attribute import log files
are overwritten.

• Append

Adds log entries to the attribute_import.log file in the
current model folder each time you import the user-defined
attributes. If the log file does not exist, Tekla Structures
creates it.

• No

Does not create a log file.
Display log file • No

The log file is not displayed.

• On dialog

Tekla Structures displays the log file in a separate window.
Click an object GUID in the log file to highlight the part in
the model.
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See also

Attribute import (page 347)

Import attributes (page 347)

Input files in attribute import (page 348)

Examples of input files used in attribute import (page 349)

Data file used in attribute import (page 351)
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10Uninstall Tekla Structures

When you no longer need a version of Tekla Structures or related components,
you can uninstall to save space on the computer.

Before you uninstall the license server, deactivate the licenses (page 83).

10.1 Uninstall Tekla Structures
Uninstall the Tekla Structures software and environments in the Windows
Control Panel.

You can have many Tekla Structures versions on your computer. When you
install and start using a new version, you do not need to uninstall the older
versions.

When you no longer use a Tekla Structures version, you can uninstall it without
affecting other installed Tekla Structures versions.

1. Go to the Windows Control Panel --> Programs --> Programs and
Features.

2. Select a component, click Uninstall and follow the prompts. Follow this
order:

a. Uninstall the service packs.

b. Uninstall the Tekla Structures environments. 

When you uninstall an environment of a Tekla Structures software
version you are still using, the uninstalled environment is not shown
in the Tekla Structures setup dialog box anymore.

c. Uninstall the main Tekla Structures software.

d. If installed, uninstall the offline help package.

e. If needed, delete the additional files or extensions related to Tekla
Structures manually from the installation folders.

3. If you no longer wish to run any version of Tekla Structures on the
computer, uninstall the components that are not version-specific.
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a. The Tekla Warehouse service and content components.

b. The Tekla Structures license borrowing tool. 

Return a borrowed Tekla Structures license (page 114) before you
uninstall the license borrowing tool.

c. The Tekla Structures license administration tool.

d. For uninstalling a Tekla Structures license server, see the instructions
below.

10.2 Uninstall the license server
Follow the instructions below when you want to permanently remove the
licensing server from this computer. If you are upgrading to a new version on
the same computer, see Update the Tekla Structures license server instead.

1. Make sure that all borrowed licenses are returned (page 114). You can use
LMTOOLS to check who has borrowed licenses.

2. Deactivate Tekla Structures licenses (page 83). 

Deactivating releases the license so that the license can be later activated
on another license server installation (applies even to licenses that have
expired or updated to a new Tekla Structures version).

3. Go to the Windows Services snap-in and stop the Tekla Structures
licensing service. 

You can find the snap-in using the Windows start menu search.

4. Go to the Windows Control Panel --> Programs --> Programs and
Features.

5. Select the Tekla Structures license server and click Uninstall. 

If the license server uninstallation fails, uninstall the license server
manually.

10.3 Uninstall the license server manually
Automatic Tekla Structures license server installation can normally be
uninstalled from the Control Panel.

If the automatic uninstallation cannot be performed, like in the case of manual
installation, you need to uninstall the license server manually.

Before you start license server uninstallation, stop FlexNet licensing services
and other licensing services.

To manually uninstall the licensing server:
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1. Make sure that all borrowed licenses are returned (page 114). You can use
LMTOOLS to check who has borrowed licenses.

2. Deactivate Tekla Structures licenses (page 83). 

Deactivating releases the license so that the license can be later activated
on another license server installation (applies even to licenses that are
updated to a new Tekla Structures version).

3. Go to Tekla Structures Licensing --> LMTOOLS through the Start menu
or Start screen, depending on your Windows operating system.

4. Go to the Service/License File tab tab, select Configuration using
Services, and ensure that Tekla Structures Licensing Service is selected
in the list.

5. Go to the Start/Stop/Reread tab and click Stop Server to stop the license
server.

6. Go to the Config Services tab, ensure that Tekla Structures Licensing
Service is shown in the Service name box and then click Remove
Service.

7. At the command prompt, enter the following command: 
uninstallanchorservice.exe

8. Uninstall Tekla Structures license server from the Control Panel to
complete the uninstallation.

The Tekla Structures license server is uninstalled.
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11Develop applications using
Tekla Open API

You can develop your own applications and additional features for Tekla
Structures through the Tekla Open API (Application Programming Interface).
Tekla Open API is implemented using Microsoft .NET technology.

Applications that are developed using Tekla Open API to work with Tekla
Structures are called extensions. To use the power of the Tekla Open API, you
must write program code outside Tekla Structures. If you do not know how to
program, you can still benefit from the Tekla Open API by downloading
extensions created by others from Tekla Warehouse.

With Tekla Open API you can:

• Record and run user interface actions

By recording and running user interface actions you can automate routine
tasks, such as creating daily reports.

• Create automation tools

You can create automation tools for frequently needed objects. With
automation tools you can, for example, create basic structures or add
typical details to drawings.

• Integrate Tekla Structures to other software

You can utilize the Tekla Open API and .NET in transferring information
between Tekla Structures and other software, such as Analysis & Design
software.

• Create new functionality.

For more information on Tekla Open API and extensions, visit the Tekla
Developer Center.
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12Disclaimer

© 2018 Trimble Solutions Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced
Software. Use of the Software, and use of this Software Manual are governed
by a License Agreement. Among other provisions, the License Agreement sets
certain warranties for the Software and this Manual, disclaims other
warranties, limits recoverable damages, defines permitted uses of the
Software, and determines whether you are an authorized user of the Software.
All information set forth in this manual is provided with the warranty set forth
in the License Agreement. Please refer to the License Agreement for important
obligations and applicable limitations and restrictions on your rights. Trimble
does not guarantee that the text is free of technical inaccuracies or
typographical errors. Trimble reserves the right to make changes and
additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by
international treaties. Unauthorized reproduction, display, modification, or
distribution of this Manual, or any portion of it, may result in severe civil and
criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tekla Civil, Tedds, Solve,
Fastrak and Orion are either registered trademarks or trademarks of Trimble
Solutions Corporation in the European Union, the United States, and/or other
countries. More about Trimble Solutions trademarks: http://www.tekla.com/
tekla-trademarks. Trimble is a registered trademark or trademark of Trimble
Inc. in the European Union, in the United States and/or other countries. More
about Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other
product and company names mentioned in this Manual are or may be
trademarks of their respective owners. By referring to a third-party product or
brand, Trimble does not intend to suggest an affiliation with or endorsement
by such third party and disclaims any such affiliation or endorsement, except
where otherwise expressly stated.
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reserved.

Open Cascade Express Mesh © 2015 OPEN CASCADE S.A.S. All rights reserved.

PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.

FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.

Teigha © 2002-2016 Open Design Alliance. All rights reserved.

CADhatch.com © 2017. All rights reserved.

FlexNet Publisher © 2014 Flexera Software LLC. All rights reserved.

This product contains proprietary and confidential technology, information
and creative works owned by Flexera Software LLC and its licensors, if any. Any
use, copying, publication, distribution, display, modification, or transmission of
such technology in whole or in part in any form or by any means without the
prior express written permission of Flexera Software LLC is strictly prohibited.
Except where expressly provided by Flexera Software LLC in writing,
possession of this technology shall not be construed to confer any license or
rights under any Flexera Software LLC intellectual property rights, whether by
estoppel, implication, or otherwise.

To see the third party open source software licenses, go to Tekla Structures,
click File menu --> Help --> About Tekla Structures and then click the 3rd
party licenses option.

The elements of the software described in this Manual are protected by
several patents and possibly pending patent applications in the United States
and/or other countries. For more information go to page http://
www.tekla.com/tekla-patents.

Disclaimer 359 Uninstall the license server manually

http://www.tekla.com/tekla-patents
http://www.tekla.com/tekla-patents


Disclaimer 360 Uninstall the license server manually



Index

A
access rights

configurations..........................................79
example definitions................................ 79
licenses..................................................... 77
modifying................................................. 77

activating licenses
troubleshooting.......................................90

activating
licenses...........................................71,72,74

adding toTemplate Editor.......................... 334
adding

bolt assemblies to catalog................... 210
bolts to catalog......................................207
material grades..................................... 140
profiles....................................................168
stud bolts to catalog............................. 208
user attributes to material grades...... 142
user attributes to profiles.................... 150

administrators
company.................................................129
customizing............................................116
environment.......................................... 129
folders.................................................... 116
help............................................................. 9
ini files.................................................... 116
installation................................................11
licensing....................................................11
multi-user...............................................343
project.....................................................129
readme....................................................... 9
setting up............................................... 116
tekla model sharing.............................. 343
tekla user assistance.................................9

advanced options....................................... 226
changing.................................................254
storing settings......................................234

angle dimensions........................................183
API.................................................................357
arcs............................................................... 176
assemblies

bolt assemblies.............................. 205,210
in templates........................................... 318

attributes
in bending schedules............................324
in templates........................................... 331

B
before installing the license server.............43
bending schedule........................................322
bending schedules

attributes and values............................324
bolt assemblies........................................... 210

deleting...................................................211
exporting................................................ 214
importing................................................214
modifying............................................... 211
properties...............................................221

bolt assembly.............................................. 205
bolt assembly catalog......................... 205,206
bolt assembly element...............................205
bolt catalog...........................................205,206
bolts

adding bolt assemblies to catalog...... 210
adding to catalog...................................207
bolt assemblies.............................. 205,211
bolt assembly catalog....................205,206
bolt catalog.....................................205,206
creating studs........................................ 208
deleting from catalog............................210

361



exporting................................. 212,213,216
importing........................................ 212,215
length calculation..................................216
modifying bolt information..................209

borrowing licenses
troubleshooting.......................................95

borrowing
exporting................................................ 111
licenses.............................109,111,112,113
product ID file.................................109,111

C
calculating

bolt length..............................................216
calculations..................................................338
catalog files..................................................273
catalogs

bolt assembly catalog....................206,221
bolt catalog.....................................206,220
exporting material catalog...................145
material catalog.....................................138
profile catalog........................................146

chamfers
in sketching............................................192

checking
sketched profiles................................... 191

circles............................................................177
clash check

settings................................................... 235
codes

configurations..........................................79
coincident constraints................................ 179
comments

in templates........................................... 336
company.ini................................................. 226
components

settings................................................... 235
compressing

shape geometry files............................ 202
configurations

codes.........................................................79
constraints

coincident...............................................179
deleting...................................................181
fixed........................................................ 180
horizontal...............................................180
in sketching.............. 177,178,179,180,181

parallel....................................................178
perpendicular........................................ 178
vertical.................................................... 181

content types...............................................329
converting

profiles....................................................171
copying

material grades..................................... 140
profiles....................................................170

creating
cross sections........................................ 162
customized initialization files.................21
profiles.....................................162,168,172
shortcuts.................................................. 21
sketched profiles................................... 175
studs....................................................... 208
templates............................................... 313

cross sections
creating...................................................162
defining....................................163,164,166
modifying............................................... 167
modifying profile with variable cross
sections.................................................. 198
profile with variable cross sections.....196
profiles with variable cross sections...195
user-defined.......................................... 162

customized initializations.............................21
customizing

message files......................................... 270
user-defined attributes........................ 259

custom
property pane layout............................137
ribbons................................................... 134
tabs......................................................... 135

D
data files.......................................................269
date

format.....................................................339
deactivating licenses

troubleshooting.......................................95
deactivating

licenses..................................................... 83
of licenses.................................................82

decimals
settings................................................... 235

defining

362



cross sections..........................163,164,166
flat bar sizes...........................................265
unfolding parameters...........................266

deleting
bolt assemblies......................................211
bolts from catalog................................. 210
material grades..................................... 142
profiles....................................................154
shapes.................................................... 204

dimensions
default format....................................... 235
default precision................................... 235
default unit............................................ 235
horizontal...............................................184
in sketching......................182,183,184,185
settings................................................... 235
vertical.................................................... 185

distributing
custom property pane layouts............ 137
custom ribbons..................................... 134
custom tabs........................................... 135
licenses..................................................... 36

drawing objects
settings................................................... 235

DWG profile to library (6)........................... 166
properties...............................................167

E
entitlement certificate........................71,72,74
environment settings

global default ........................................231
local.........................................................232

environment variables............................... 234
see advanced options...........................254

environment variables, see advanced
options......................................................... 226
environment.db.......................................... 260
environment

database file.......................................... 260
env_<environment>.ini................226,232,253
env_global_default.ini......................... 226,253
env_global_default.ini ................................231
examples

adding user attributes to profiles....... 150
creating user-defined attribute........... 261
flat bar sizes...........................................265
profile export file...................................158

updating user-defined attribute..........261
exporting

bolt assemblies......................................214
bolts......................................... 212,213,216
material grades.......................144,145,146
profiles.....................................155,157,161
shapes.................................................... 203
sketched profiles................................... 161

extensions....................................................357
extrusion types............................................194

F
file name extensions.................................. 284
file types

initialization files................................... 226
files............................................................... 224

extensions..............................................284
in model folder......................................284
initialization files................................... 226
locations................................................. 306
symbol.................................................... 276

firewall
allowing traffic in TCP/IP ports......... 57,62
exceptions................................................ 52
license server...........................................52

firewalls
exceptions...........................................53,56
licenses

exceptions in firewalls.......................53
lmgrd.exe............................................ 53,56
tekla.exe.............................................. 53,56

firm folders.................................................. 225
fixed profiles................................. 168,170,171

modifying............................................... 171
fixed

constraints............................................. 180
flat bars

in drawings ............................................265
in reports................................................265
sizes........................................................ 265

FlexNet............................................................31
administrator's tasks.............................. 35
examples of different setups.................38
IT resources..............................................34
starting Tekla Structures.........................76

fltprops.inp.................................................. 265
folders.......................................................... 224

363



in model folder......................................284
locations................................................. 306
search order...........................................307

font files....................................................... 275
fonts..............................................................275
fonts_<lang>.ini........................................... 226
formulas

format.....................................................340
free attributes...................................... 322,324

G
global default environment settings........ 231
graphical templates.............................313,322
grouping

profiles............................................ 148,149

H
handles

of positioning planes............................ 189
hiding

positioning planes.................................188
hierarchy

in templates........................................... 336
horizontal

constraints............................................. 180
dimensions............................................ 184

HTML templates..........................................313
html.rpt........................................................ 313

I
image files....................................................277
image

of profile.................................................199
images

file formats.............................................277
in templates........................................... 326

imperial units.............................................. 338
importing

bolt assemblies......................................214
bolts.................................................212,215
material grades..................................... 144
model......................................................346
profiles.....................................155,156,161

shapes.................................................... 201
sketched profiles................................... 161
SketchUp................................................ 204
user-defined attribute values....
347,348,349,351

ini files..................................................... 21,226
initialization files......................................... 226

creating customized................................21
env_<environment>.ini.........................232
env_global_default.ini...........................231
file types................................................. 226
reading order.........................................226
role_<role>.ini........................................232
usage...................................................... 226

input files..................................................... 256
installation

license server...........................................45
installing Tekla Structures

uninstalling............................................ 354

K
keywords

in access right definitions.......................79

L
lang_<lang>.ini.............................................226
length

bolt length calculation.......................... 216
License Borrow Tool

changing the language......................... 112
downloading.......................................... 112
using....................................................... 112

license file
modifying................................................. 49

license server.................................................31
administrator's tasks.............................. 35
configuring manually.............................. 50
firewall...................................................... 52
installing................................................... 43
manual installation................................. 46
notifying automatically........................... 72
notifying manually.................................. 74
uninstalling manually........................... 355

license server
version...................................................... 44

364



license servers
automatic installation.............................45

license service installation........................... 45
license service

manual installation................................. 46
licenses

access rights.............................................77
activating........................................71,72,74
administrator's tasks.............................. 35
allowing traffic through TCP/IP ports....
57,62
automatic installation of license server....
45
borrowing.........................109,111,112,113
deactivating........................................ 82,83
different ways of distributing................ 36
errors in activating.................................. 86
errors in borrowing.................................86
errors in deactivating..............................86
examples of different setups.................38
exceptions in firewall.............................. 56
installing license server.......................... 43
IT resources needed............................... 34
licensing system...................................... 31
maintaining.............................................. 77
modifying access rights.....................77,79
modifying license access rights............. 79
number of users......................................38
problems in activation............................ 90
problems in borrowing........................... 95
problems in deactivation........................95
problems in license server connection.87
problems in license server installation.87
product ID file.................................109,111
repairing..............................................77,84
returning................................................ 114
troubleshooting Tekla Structures
licensing....................................................86
trust status..........................................84,96
what is provided by Trimble Solutions..33

licensing applications
logging in as administrator.................... 35
running as administrator....................... 35

licensing in Tekla Structures........................ 31
lmgrd.exe.................................................. 53,56
LMTOOLS

configuring license server manually..... 50
load modeling

settings................................................... 235
local environment settings

env_<environment>.ini.........................232
location

of hidden files........................................309
locations

files..........................................................306
folders.................................................... 306

log files
list of....................................................... 278
numberinghistory.txt log.............. 281,282
session history.......................................280
viewing....................................................279
viewing parts..........................................279

M
manual installation

license server...........................................46
material catalog, see material grades...... 138
material catalog

exporting................................................ 145
material grades........................................... 138

adding.....................................................140
adding user attributes..........................142
copying................................................... 140
deleting...................................................142
exporting................................. 144,145,146
important buttons.................................139
importing................................................144
importing and exporting...................... 159
material types........................................138
modifying............................................... 141
saving changes...................................... 139
user-defined material symbols........... 143

message files............................................... 270
customizing............................................270

Migration Wizard.........................................232
model folder

file name extensions.............................284
files..........................................................284

model-specific settings...............................253
model

importing................................................346
modifying

bolt assembly information...................211
bolt information.................................... 209
cross sections........................................ 167

365



license file.................................................49
material grades..................................... 141
profile with variable cross sections.....198
profiles....................................................171
rules........................................................ 149
sketched profiles................................... 192

mouse
settings................................................... 235

N
non-solid...................................................... 201
north marks, see orientation marks.........235
notifying Tekla Structures license server....72
numbering history...............................281,282
numbering

settings................................................... 235

O
objects.inp................................................... 256
offline use of Tekla Structures...................112
Options dialog box

settings................................................... 235
options file

keywords for defining access rights......79
options.bin.............................226,234,253,254
options.ini.............................................226,253
options

storing saving........................................ 234
options_drawings.db............ 234,235,253,254
options_model.db.................234,235,253,254
orientation marks

settings................................................... 235

P
parallel constraints..................................... 178
parametric profiles..............................171,199

creating...................................................172
parts

defining the material of profile types. 153
pdf reports ..................................................315
perpendicular constraints..........................178
pictures

in templates........................................... 326

plates
flat bars.................................................. 265

plotdev.bin................................................... 276
polylines....................................................... 176
positioning planes........................186,187,188

moving....................................................189
reverting to default............................... 190

problems
in Tekla Structures licensing...................86

product ID file (.tpi)..................................... 109
profile catalog, see profiles........................146
Profile cross section from plate (10).........164

properties...............................................165
profile files................................................... 273
profiles

adding rules........................................... 148
adding user attributes..........................150
adding user attributes to profiles....... 150
associating with certain material........ 153
converting.............................................. 171
copying................................................... 170
creating....................................162,168,172
creating image of profile...................... 199
defining cross sections....
162,163,164,165,166,167
deleting...................................................154
exporting.........................................155,157
fixed......................................... 168,170,171
grouping..........................................148,149
importing........................................ 155,156
importing and exporting...................... 159
modifying............................................... 171
profile catalog........................................146
Profile Editor.......................................... 196
profile export file...................................158
rules........................................................ 148
saving changes...................................... 147
sketching................................................ 172
user-defined.......................................... 162
with variable cross sections.. 195,196,198

project folders............................................. 225
properties files............................................ 273
properties

bolt assembly catalog...........................221
bolt catalog............................................ 220
DWG profile to library (6)..................... 167
objects.inp..............................................256
Profile cross section from plate (10)... 165

366



property files............................................... 271
property pane layouts

custom....................................................137
pull-out pictures..........................................322
pullout pictures........................................... 322

R
radial dimensions....................................... 182
reading order

initialization files................................... 226
repairing licenses.....................................77,84
report files................................................... 276
reports

tips.......................................................... 337
returning

licenses...................................................114
reverting

to default positioning planes...............190
ribbons

customizing............................................134
role settings................................................. 232
roles..............................................................232
role_<role>.ini............................... 226,232,253
rules

in profile catalog............................ 148,149
profile catalog rules.............................. 148

S
saving

advanced options..................................234
options................................................... 234
profiles....................................................147
sketched profiles................................... 191
templates............................................... 313

search order................................................ 307
session history............................................ 280
settings

bolt assembly catalog properties........221
bolt catalog properties......................... 220
clash check.............................................235
components...........................................235
decimals................................................. 235
dimensions............................................ 235
drawing objects..................................... 235
general....................................................235

in the Options dialog box.....................235
load modeling........................................235
mouse.....................................................235
north marks, see orientation marks...235
orientation marks................................. 235
startup.................................................... 235
units........................................................ 235

shape catalog........................ 200,201,203,204
shapes

compressing geometry files.................202
deleting...................................................204
exporting................................................ 203
importing................................................201
shape catalog.........................................200

sheet numbers............................................ 339
shortcuts

creating.....................................................21
showing

positioning planes.................................188
sketch editor................................................173
sketched profiles.........................................172

adding constraints...177,178,179,180,181
adding dimensions......... 182,183,184,185
arcs..........................................................176
chamfers................................................ 192
checking................................................. 191
circles......................................................177
deleting constraints.............................. 181
deleting dimensions............................. 185
exporting................................................ 161
extrusion types......................................194
importing................................................161
modifying............................................... 192
polylines................................................. 176
positioning planes... 186,187,188,189,190
refining the shape................................. 177
saving......................................................191
setting the thickness.............................193
Sketch Browser......................................174
sketch editor.......................................... 173
sketching the outline............................ 175
using in model....................................... 195
variables................................................. 175

sketching, see sketched profiles............... 172
solid.............................................................. 201
standard files...............................................271
standard.opt................................................ 235
standardized values

367



for parametric profiles......................... 199
starting

Tekla Structures with FlexNet licensing 76
startup

settings................................................... 235
studs............................................................. 208
symbol files..................................................276
system-specific settings............................. 253

T
tabs

importing custom tabs......................... 135
TCP/IP ports

allowing traffic.................................... 57,62
Windows 7, 8, 8.1, 10 and Windows
Server 2012.............................................. 62
Windows Server 2008............................. 57

Tekla Open API............................................ 357
Tekla Structures files...................................224
Tekla Structures folders............................. 224
Tekla Structures License Borrow Tool

borrowing licenses................................113
returning licenses..................................114

Tekla Structures license server
problems in installation..........................87
problems in server connection..............87

tekla.exe.................................................... 53,56
tekla.lic

modifying manually................................ 49
tekla.opt.................................................... 77,79

example definitions................................ 79
teklastructures.ini....................................... 226
TeklaStructures.log..................................... 280
template attributes.....................................331
Template Editor...........................................311
template files...............................................276
templates..................................................... 311

adding images....................................... 326
aligning objects......................................318
attributes................................................331
comments.............................................. 336
content types.........................................329
creating...................................................313
free attributes........................................322
graphical templates................313,322,326
headers and footers......................313,318
hierarchy................................................ 336

in HTML format..................................... 313
moving objects...................................... 318
of bending schedules.................... 322,324
of nested assemblies............................318
rows........................................................ 329
saving......................................................313
sorting order..........................................318
textual templates.................................. 318
tips.......................................................... 337
user-defined attributes..........333,334,336

temporary licenses..................................... 113
testing

sketched profiles................................... 191
text type attributes

in calculations........................................338
textual templates........................................ 318
tez files...........................................200,201,202
thickness

sketch thickness.................................... 193
tips

templates and reports..........................337
troubleshooting

access rights.......................................... 101
error codes

Tekla Structures licensing errors... 102
error reports............................................ 86
license activation................................86,90
license borrowing...............................86,95
license deactivation........................... 86,95
license server connection.......................87
LMTOOLS..................................................97
problems with FlexNet............................90
starting Tekla Structures...................... 100
Tekla Structures license server
installation................................................87
Tekla Structures licensing............... 86,102
tekla.opt................................................. 101
trust status............................................... 96

trust status.....................................................84
trusted storage

broken licenses........................................96
status........................................................ 84

U
unfolding parameters

defining.................................................. 266
unfold_corner_ratios.inp............................266

368



uninstalling.................................................. 354
license server manually........................355

units
in importing and exporting..................159
settings................................................... 235

updating
user-defined attributes in model........ 260

updating
material catalog.....................................139
profile catalog........................................147

user attributes
adding to material grades....................142
to profiles............................................... 150

user-defined attribute values
importing......................... 347,348,349,351

user-defined attributes
customizing............................................259
environment.db.....................................260
example..................................................261
in templates............................ 333,334,336
objects.inp properties.......................... 256
updating in model.................................260

user-defined material symbols
creating...................................................143

user-defined profiles.................................. 162
user-specific settings.................................. 253
user.ini..........................................................226

modifying............................................... 232

V
value fields

format.....................................................340
value fields

imperial units.........................................338
variable cross sections............................... 195
variables

in sketching............................................175
vertical

constraints............................................. 181
dimensions............................................ 185

viewing parts
in log files............................................... 279

viewing
log files................................................... 279

virtual use of Tekla Structures..................... 25
virtualization.................................................. 25

W
Windows 7, 8, 8.1, 10 and Windows Server
2012................................................................ 56

allowing traffic in fixed TCP/IP ports..... 62
Windows Server 2008...................................53

allowing traffic in fixed TCP/IP ports..... 57

X
XML to TEZ................................................... 202

369



370


	Contents
	1 Get started as a Tekla Structures administrator
	1.1  Information sources for administrators 

	2 Tekla Structures installation for administrators
	2.1 Installation requirements
	2.2 Installing Tekla Structures
	2.3 Centralized installation of Tekla Structures
	2.4 Installation in a virtual environment
	2.5 Installing the license server
	2.6 Tekla Structures multi-user server
	2.7 Installing .tsep packages
	2.8 Upgrading Tekla Structures
	2.9 Folder structure
	2.10 Create startup shortcuts with customized initializations
	Create a startup shortcut with customized initialization
	Available parameters in shortcuts
	Example of an initialization file

	2.11  Using Tekla Structures with application and desktop virtualization
	Prerequisites for using Tekla Structures in a virtual environment
	Set up the virtual environment for Tekla Structures


	3  Manage licenses 
	3.1 Tekla Structures licensing system
	Checklist of Trimble Solutions deliverables needed in Tekla Structures licensing
	Checklist of IT resources needed in Tekla Structures licensing
	Checklist for the Tekla Structures license server administrator
	Rights needed for performing administrator's tasks in Tekla Structures licensing
	Distributing and managing Tekla Structures licenses
	Examples of different Tekla Structures licensing system setups

	3.2 Installing Tekla Structures license server
	Which license server version to use
	Install Tekla Structures license server - automatic installation
	Install Tekla Structures license service - manual installation
	Modify the license file tekla.lic manually
	Configure Tekla Structures license server manually

	3.3 Allowing Tekla Structures license server to operate through Windows Firewall
	Allow exceptions in firewall for lmgrd.exe and tekla.exe: Windows Server 2008
	Allow exceptions in firewall for lmgrd.exe and tekla.exe: Windows 7, 8, 8.1, 10 and Windows Server 2012
	Allow traffic in fixed TCP/IP ports: Windows Server 2008
	Allow traffic in fixed TCP/IP ports: Windows 7, 8, 8.1, 10 and Windows Server 2012

	3.4 Activating Tekla Structures licenses
	Activate Tekla Structures licenses using automatic server notification
	Activate Tekla Structures licensing using manual server notification

	3.5 Connect Tekla Structures to the license server
	3.6  Maintain licenses 
	Modify Tekla Structures license access rights (tekla.opt)
	Configuration codes and keywords used in access right definitions

	Deactivating Tekla Structures licenses
	Deactivate Tekla Structures licenses

	Repair a Tekla Structures license
	Troubleshoot Tekla Structures licensing
	View and diagnose errors in Tekla Structures license activation, deactivation and borrowing
	Problems in Tekla Structures license server installation and connecting to the license server
	Problems in FlexNet
	Problems in Tekla Structures license activation
	Problems in Tekla Structures license deactivation
	Problems in Tekla Structures license borrowing
	Problems in Tekla Structures license trusted storage
	Problems using LMTOOLS in Tekla Structures licensing
	Problems in starting Tekla Structures
	Problems with options file tekla.opt
	Problems in Tekla Structures licensing: Error codes and their descriptions


	3.7 Borrowing Tekla Structures licenses for offline use
	Provide offline users with a customized product ID file
	Set up Tekla Structures License Borrow Tool for Tekla Structures offline use
	Borrow a license from Tekla Structures license server
	Return a borrowed Tekla Structures license


	4  Create and distribute customized configurations 
	4.1 Tekla Structures setup guidelines for administrators
	Customizing Tekla Structures
	Overview of environments, roles and licenses
	Folder structure
	Project and firm folders
	Folder search order
	Initialization files
	Setting advanced options in .ini files
	Creating shortcuts
	Bypassing the login screen
	User-defined attributes

	4.2 Environment, company and project settings for administrators
	Environment settings
	Company settings
	Project settings

	4.3 Distribute custom ribbons using a firm or environment folder
	Add ribbons to the firm or environment folder
	Loading order of custom ribbons
	Naming convention for ribbon files

	4.4 Distribute custom tabs using a firm or environment folder
	4.5 Distribute customized property pane layouts using a project, firm, or environment folder
	Add a property pane layout file to a project, firm, or environment folder
	Search order of the customized property pane layout files

	4.6 Customize the material catalog
	Important buttons in the material catalog
	Add a material grade
	Copy a material grade
	Modify a material grade
	Delete a material grade
	Add user attributes to material grades
	Create user-defined material definitions
	Import and export material grades
	Import a material catalog
	Export an entire material catalog
	Export a part of the material catalog


	4.7 Customize the profile catalog
	Important buttons in the profile catalog
	Group profiles together
	Add a rule to the profile catalog
	Modify a rule in the profile catalog

	Add user attributes to profiles
	Example: Add a user attribute to a profile and use it in a rule

	Associate profile types with a certain material
	Delete a profile from the profile catalog
	Import and export profiles
	Import profile catalog items
	Export an entire profile catalog
	Export a part of the profile catalog
	Example of profile export file
	Units used in import and export
	Import and export sketched profiles
	Import sketched profiles
	Export sketched profiles


	Create your own profiles
	Create user-defined cross sections
	Define a cross section using polygon
	Define a cross section using a plate
	Properties: Profile cross-section from plate (10)

	Define a cross section using a DWG file
	Properties: DWG Profile to Library (6)

	Modify a user-defined cross section

	Create fixed profiles
	Create a fixed profile
	Create a fixed profile by copying
	Create a fixed profile based on a parametric profile
	Modify a fixed profile

	Create parametric profiles by sketching
	Open the sketch editor
	Sketch Browser
	Variables in sketched profiles

	Sketch the outline of a profile
	Sketch a polyline
	Sketch an arc
	Sketch a circle

	Refine the shape of a sketched profile
	Add a parallel constraint
	Add a perpendicular constraint
	Add a coincident constraint
	Add a fixed constraint
	Add a horizontal constraint
	Add a vertical constraint
	Delete a constraint

	Add dimensions to a sketched profile
	Add a radial dimension to a sketch
	Add an angle dimension to a sketch
	Add a dimension between two points in a sketch
	Add a horizontal dimension to a sketch
	Add a vertical dimension to a sketch
	Delete a dimension from a sketch

	Define positioning planes for a sketched profile
	Part positioning planes
	Connection positioning planes
	Show and hide positioning planes
	Move positioning planes
	Revert to default positioning planes

	Check a sketched profile
	Save a sketched profile
	Modify a sketched cross section
	Modify chamfers in a sketch
	Set the sketch thickness
	Extrusion types

	Use sketched profiles in a model

	Create parametric profiles with variable cross sections
	Create a profile with variable cross sections
	Modify a profile with variable cross sections


	Define standardized values for parametric profiles
	Create an image of a profile

	4.8 Customize the shape catalog
	Import a shape
	Compress shape geometry files
	How to compress shape geometry files

	Export a shape
	Delete a shape
	Example: Import a shape from SketchUp Pro

	4.9 Customize the bolt catalog
	How the bolt catalog and bolt assembly catalogs work together
	Manage bolts and bolt assemblies
	Add a bolt to the catalog
	Add a stud bolt to the catalog
	Modify bolt information in the catalog
	Delete a bolt from the catalog
	Add a bolt assembly to the catalog
	Modify bolt assembly information in the catalog
	Delete a bolt assembly from the catalog

	Import and export bolts and bolt assemblies
	Import bolts to the catalog
	Export bolts from the catalog
	Import bolt assemblies to the catalog
	Export bolt assemblies from the catalog
	Import a bolt catalog
	Import a part of the bolt catalog
	Export an entire bolt catalog

	Bolt length calculation
	Bolt catalog properties
	Bolt assembly catalog properties


	5 Files and folders in Tekla Structures
	5.1 Create project and firm folders
	Create a project or firm folder

	5.2 Initialization files (.ini files)
	Typical initialization files (.ini files) and their reading order
	Global default environment settings - env_global_default.ini
	Local environment settings - env_<environment>.ini
	Role settings - role_<role>.ini
	Add an advanced option to the user.ini file

	5.3 File storing options and advanced options
	Settings in the Options dialog box
	Clash check settings
	Components settings
	Drawing dimensions settings
	Drawing objects settings
	General settings
	Load modeling settings
	Numbering settings
	Orientation marks settings
	Reinforcement settings
	Units and decimals settings

	Settings defined by advanced options
	Change the advanced option values in the Advanced Options dialog box

	5.4 Input files (.inp files)
	Properties of the objects.inp file
	Define and update user-defined attributes (UDAs)
	Update definitions of user-defined attributes (UDAs) in a model
	Environment database file
	Example: Create and update a user-defined attribute (UDA)

	Show plates as flat bars in drawings and reports
	Define flat bar sizes with the Fltprops.inp file
	Define unfolding parameters in the unfold_corner_ratios.inp file

	5.5 Data files (.dat files)
	5.6 Message files
	Customize message files

	5.7 Standard files
	5.8 Property files
	5.9 Catalog files
	5.10 Font files and font conversion files
	5.11 Symbol files
	5.12 Files related to templates, reports and drawings
	5.13 Image files
	5.14 Log files
	View a log file
	Change the name and location of session history log file
	Numbering history log file
	Numbering series in the numbering history log file

	5.15 Model folder files and file name extensions
	5.16 Check and change Tekla Structures file and folder locations in Directory browser
	5.17 Folder search order
	5.18 Location of certain files in hidden folders

	6 Templates
	6.1 Create a template
	6.2 Create a template in HTML format
	6.3 Create a .pdf report template
	6.4 Create a template for nested assemblies
	6.5  
	 Create a template for bending schedules or pull-out pictures 
	Bending schedule attributes

	6.6 Add images in a template
	6.7 Content types
	6.8 Template attribute files (contentattributes.lst)
	6.9 User-defined template attributes
	Add user-defined template attributes to Template Editor
	Add comments to user-defined template attributes
	Add hierarchy to user-defined template attributes

	6.10  Tips for templates 
	Use text type attribute in calculations
	Change value field content to use imperial units
	Define customized date format
	Assembly or cast unit drawing sheet number
	Use format functions in value fields


	7 Tekla Model Sharing and multi-user for administrators
	7.1 Tekla Model Sharing
	7.2 Multi-user models

	8 Model import
	9 Attribute import
	9.1 Import attributes
	9.2 Input files in attribute import
	Examples of input files used in attribute import
	Data file used in attribute import

	9.3 Attribute import settings

	10 Uninstall Tekla Structures
	10.1 Uninstall Tekla Structures
	10.2 Uninstall the license server
	10.3 Uninstall the license server manually

	11 Develop applications using Tekla Open API
	12 Disclaimer
	Index



